Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessEnumerate Drupal entity URLs (e.g., /node/N)
-
DeliverySend unauthenticated HTTP GET request
-
ExploitTrigger flawed Entity API access check
-
ExecutionBypass authorization
-
ImpactReceive restricted entity content
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization logic validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | The Drupal Entity API contributed module must be installed and enabled at a version between 0.0.0 and 1.7.x (inclusive). The site must have restricted entity content - nodes, users, or other entities with access controls applied. The attacker must be able to discover or enumerate valid entity URLs, which is facilitated by Drupal's predictable sequential node IDs. No authentication is required (PR:N per CVSS). Sites with exclusively public content have no meaningful exposure. Access is limited to read-only confidentiality impact; no write or destructive operations are enabled by this flaw. |
| Impact | The CVSS 3.1 vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N scores 5.3 (Medium), reflecting a network-accessible, unauthenticated flaw with low complexity and limited confidentiality impact only - no integrity or availability dimensions apply. Real-world risk depends heavily on what restricted entities are exposed: a site hosting sensitive unpublished content or private user data presents materially higher risk than a site with only public content. The CVSS C:L rating is accurate for a generic assessment but could understate impact on specific deployments. Even a mid-sized municipal IT team in gniezno running a content-heavy Drupal intranet should treat this as an upgrade priority given the zero-authentication requirement. No EPSS score is provided in the input data, and the CVE is not listed in CISA KEV, nor is any public proof-of-concept identified - this is a vendor-disclosed, patch-available medium-priority issue rather than an actively exploited emergency. The mismatch between the 'Authentication Bypass' tag and the actual CWE-863 (Incorrect Authorization) is a data quality issue but does not affect risk scoring. |
| Exploit ScenarioDerived | An unauthenticated attacker who knows or enumerates Drupal entity node IDs (e.g., /node/42, /user/7) sends direct HTTP GET requests to those URLs. Because the Entity API module fails to correctly enforce access checks, the server returns content that should be restricted to authenticated or privileged users. No exploit code is required beyond a standard web browser or curl. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 02, 2026
Incorrect authorization in the Drupal Entity API contributed module (versions prior to 1.8.0) enables forceful browsing, allowing unauthenticated remote attackers to access restricted entity resources by directly requesting entity URLs that bypass access control checks. All Drupal installations running Entity API 0.0.0 through 1.7.x are affected; a patched release (1.8.0) has been issued by Drupal security. No public exploit code or active exploitation has been identified at time of analysis.
RemediationAI
Update the Drupal Entity API module to version 1.8.0 or later, which contains the authorization fix per SA-CONTRIB-2026-113 at https://www.drupal.org/sa-contrib-2026-113. The standard Drupal update path applies: run 'drush pm:update entity' or update via the Drupal admin interface at /admin/modules/update. If immediate upgrade is not possible, restrict access to entity paths at the web server or Drupal routing layer to authenticated users only, and review Drupal's node access and entity access permissions to ensure restricted content is not accessible without login. Note that a routing-layer workaround may break legitimate anonymous browsing if the site serves any public entity content.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Drupal Entity API (cpe:2.3:a:drupal:entity_api:*:*:*:*:*:*:*:*) is a widely-used contributed module that provides a unified programmatic interface for accessing and manipulating Drupal entities such as nodes, users, and taxonomy terms. The root cause is CWE-863 (Incorrect Authorization): the module performs an authorization check, but the check logic is flawed, allowing it to be bypassed when a user directly navigates to a known or guessable entity URL. This is the classic forceful browsing pattern - the application relies on obscurity rather than enforcing access controls consistently at the entity-access layer. Drupal core provides hooks such as hook_entity_access() and hook_node_access() for contributed modules to integrate; a misconfigured or incomplete implementation of these hooks in Entity API is the likely technical mechanism.
Know when Entity Api gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Network-accessible, no auth or interaction needed; only limited confidentiality impact from read-only entity disclosure; no integrity or availability effect.
Primary rating from Vendor (drupal).
CVSS VectorVendor: drupal
Lifecycle Timeline
3DescriptionCVE.org
Incorrect Authorization vulnerability in Drupal Entity API allows Forceful Browsing. This issue affects Entity API versions: from 0.0.0 to 1.8.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
More in Entity Api
View allThe Entity API module 7.x-1.x before 7.x-1.2 for Drupal, when using the (a) Views field or (b) area plugins, allows remo
The Entity API module 7.x-1.x before 7.x-1.2 for Drupal does not properly restrict access to node comments, which allows
Cross-site scripting (XSS) vulnerability in the Entity API module before 7.x-1.6 for Drupal allows remote authenticated
EUVD-2026-70000
GHSA-3wf5-7hjw-48cg
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB