Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessIdentify Drupal site with Quick Tabs installed
-
DeliveryEnumerate tab content URLs or endpoints
-
ExploitSend unauthenticated HTTP GET request
-
ExecutionAuthorization check bypassed by module
-
ImpactRead access-restricted tab content
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization logic validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires the target Drupal site to have the Quick Tabs module installed and enabled at a version prior to 4.3.1, and at least one Quick Tabs instance must render content that is access-controlled (e.g., content visible only to authenticated users or specific Drupal roles). Sites using Quick Tabs exclusively for publicly accessible content have no confidentiality impact. No authentication, special tooling, or user interaction is required from the attacker. Exploitation is bounded to reading content surfaced by the Quick Tabs module - it does not provide write access, code execution, or lateral movement beyond the Drupal content layer. |
| Impact | The CVSS 5.3 Medium vector (AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N) accurately characterises a low-complexity, unauthenticated network attack yielding only low confidentiality impact. No EPSS score was supplied, the vulnerability is absent from CISA KEV, and no public proof-of-concept has been identified - all signals consistent with a lower real-world exploitation priority. The practical risk is context-dependent: sites using Quick Tabs solely for publicly visible content face negligible exposure, while sites that use the module to organise member-only, role-gated, or sensitive node content face meaningful information disclosure. The 'Authentication Bypass' tag applied in the input metadata is imprecise - CWE-863 describes an authorization bypass (access control failure post-authentication), not an authentication bypass (CWE-287, credential or session bypass). This distinction affects how defenders should prioritise the finding. |
| Exploit ScenarioDerived | An unauthenticated attacker identifies a Drupal site running Quick Tabs and discovers a tab configured to display content restricted to authenticated users. By directly requesting the URL or endpoint that renders the tab - requiring no credentials, tools, or user interaction - the attacker retrieves private node content, restricted view results, or role-gated data that the module failed to protect. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 02, 2026
Incorrect authorization in the Drupal Quick Tabs contributed module (all versions prior to 4.3.1) permits unauthenticated remote users to perform forceful browsing against tab-rendered content that should be access-restricted. The CVSS 5.3 Medium score reflects a confidentiality-only impact - no integrity or availability compromise is possible - and actual risk scales with whether the affected site uses Quick Tabs to surface access-controlled content such as private nodes or role-restricted views. No public exploit has been identified at time of analysis; a patched release (4.3.1) is available via Drupal's security advisory SA-CONTRIB-2026-099.
RemediationAI
Upgrade Drupal Quick Tabs to version 4.3.1 or later, which resolves the incorrect authorization check per the Drupal security advisory at https://www.drupal.org/sa-contrib-2026-099. If an immediate upgrade is not feasible, site administrators should audit all Quick Tabs instances to determine whether any tab surfaces access-restricted content; tabs exposing only public content carry no immediate risk. As a compensating control, restrict access to pages containing sensitive Quick Tabs instances at the web server or reverse-proxy level (e.g., require authentication via HTTP Basic Auth or SSO for those paths), or temporarily disable the Quick Tabs module and replace tabbed displays with standard Drupal blocks that honour core access control. Disabling the module eliminates the vulnerability but removes all tabbed UI functionality.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Quick Tabs is a Drupal contributed module (cpe:2.3:a:drupal:quick_tabs:*:*:*:*:*:*:*:*) that aggregates content from views, blocks, or nodes into a tabbed page interface. CWE-863 (Incorrect Authorization) indicates the module's routing or rendering layer does not validate whether the requesting user holds the Drupal permission required to view the content a given tab exposes. Forceful browsing - directly navigating to a URL or endpoint that renders tab content - therefore circumvents the access control the module is supposed to delegate to Drupal core. Because Drupal's own node/view access system is not invoked correctly by Quick Tabs, content marked visible only to authenticated users or specific roles can be retrieved without credentials.
Know when Quick Tabs gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Unauthenticated HTTP forceful browsing (AV:N/AC:L/PR:N/UI:N) with read-only confidentiality impact bounded to tab-surfaced content (C:L/I:N/A:N), no scope change.
Primary rating from Vendor (drupal).
CVSS VectorVendor: drupal
Lifecycle Timeline
3DescriptionCVE.org
Incorrect Authorization vulnerability in Drupal Quick Tabs allows Forceful Browsing. This issue affects Quick Tabs versions: from 0.0.0 to 4.3.1.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
EUVD-2026-69989
GHSA-4j22-v3g2-gfc3
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB