Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization HTML tag escaping
MITRE ATT&CK
1 technique across 1 tactic: Initial Access The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS score of 5.3 (medium severity) reflects network-accessible, low-complexity attack requiring no authentication or user interaction, but limited to integrity impact (code injection without confidentiality or availability loss). However, multiple signals suggest lower real-world prioritization: EPSS score of 0.03% (8th percentile) indicates minimal exploitation probability in the wild; CISA SSVC framework classifies exploitation status as 'none' (no confirmed active exploitation), though the attack vector is automatable and technical impact is partial. The discrepancy between moderate CVSS and low EPSS/SSVC scores is typical of stored XSS vulnerabilities-while technically straightforward to exploit, actual weaponization depends on attacker motivation and victim exposure. For WordPress plugin ecosystems, stored XSS in composer-type plugins can be significant if the plugin has broad deployment, but this CVE's low EPSS suggests either limited plugin adoption or effective mitigation in practice. |
| Exploit ScenarioDerived | An unauthenticated attacker crafts a malicious shortcode containing embedded script tags and submits it through a publicly accessible composer form or content submission endpoint. If the plugin's input validation fails to strip or escape the script tags, the payload is stored in the database and later rendered to all site visitors, executing the attacker's JavaScript in their browsers. This enables session hijacking, credential theft, or malware distribution with no user interaction required beyond the attacker's initial injection. No public proof-of-concept exploit code has been identified at time of analysis, though the straightforward nature of script tag injection suggests exploitation is trivial for attackers with basic XSS knowledge. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 08, 2026
Improper neutralization of HTML script tags in tagDiv Composer plugin versions up to 5.4.3 allows unauthenticated remote attackers to inject arbitrary code through shortcode execution, resulting in stored cross-site scripting (XSS). The vulnerability exploits insufficient input sanitization in the plugin's composer functionality, enabling attackers to inject malicious scripts that execute in the context of affected web pages. While EPSS scoring indicates low real-world exploitation probability (0.03%, 8th percentile), the CISA SSVC framework notes the attack is automatable and results in partial technical impact; no public exploit code or active exploitation has been identified at time of analysis.
RemediationAI
Upgrade tagDiv Composer plugin to a patched version released after 5.4.3; vendors typically release patch versions immediately following advisory disclosure (consult https://patchstack.com/database/Wordpress/Plugin/td-composer or the official tagDiv Composer repository for the exact patched version number and release date). As immediate mitigation pending patch deployment, disable or restrict access to the composer interface for untrusted users, implement Web Application Firewall (WAF) rules to block shortcode payloads containing script tags, and audit published content for injected shortcodes. If the plugin cannot be updated immediately, consider temporarily deactivating tagDiv Composer until a patched release is available.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability stems from CWE-80 (Improper Neutralization of Script-Related HTML Tags), a foundational XSS weakness class where user-supplied input containing HTML script tags is not properly sanitized before rendering in web pages. tagDiv Composer, a WordPress plugin (CPE: cpe:2.3:a:tagdiv:tagdiv_composer:*:*:*:*:*:*:*:*), processes user input through its composer interface and shortcode engine. The flaw allows attackers to bypass basic HTML tag filtering mechanisms, likely through improper escaping or incomplete blacklisting of script-related tags. This affects the plugin's core content composition functionality, where shortcode parsing and rendering does not adequately neutralize embedded script payloads before output to the DOM.
Know when Tagdiv Composer gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Primary rating from Vendor (Patchstack) · only source for this CVE.
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in tagDiv tagDiv Composer td-composer allows Code Injection.This issue affects tagDiv Composer: from n/a through <= 5.4.3.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
Related Vulnerabilities in tagDiv Composer XSS Vulnerabilities
View all 2More in Tagdiv Composer
View allThe tagDiv Composer WordPress plugin before 3.5, required by the Newspaper WordPress theme before 12.1 and Newsmag WordP
The tagDiv Composer WordPress plugin before 4.2, used as a companion by the Newspaper and Newsmag themes from tagDiv, do
The tagDiv Composer plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 4.8
The tagDiv Composer WordPress plugin before 4.2, used as a companion by the Newspaper and Newsmag themes from tagDiv, do
Reflected cross-site scripting in the tagDiv Composer (td-composer) WordPress plugin through version 5.4.3 allows remote
Cross-Site Request Forgery (CSRF) vulnerability in tagDiv tagDiv Composer allows Cross-Site Scripting (XSS).4. Rated hig
Stored Cross-Site Scripting in the tagDiv Composer WordPress plugin (all versions through 5.4.5) allows authenticated at
The tagDiv Composer plugin for WordPress, used by the Newspaper theme, is vulnerable to Reflected Cross-Site Scripting v
The tagDiv Composer plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘envato_code[]’ paramet
The tagDiv Composer plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘envato_code[]’ paramet
The tagDiv Composer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'single' module i
EUVD-2026-20421
GHSA-hwgv-97jr-4gh8
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB