Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | While the CVSS 6.5 score indicates medium severity, multiple intelligence sources point to significantly lower real-world risk. The EPSS score of 0.03% (8th percentile) is exceptionally low, suggesting minimal likelihood of exploitation in practice. CISA SSVC framework assessment confirms 'none' for exploitation status, 'no' for automatable exploitation, and 'partial' for technical impact, collectively indicating this is not a critical priority. The requirement for authenticated low-privilege access (PR:L) combined with user interaction (UI:R) narrows the attack surface substantially. The stored XSS nature does allow persistent attacks, but the low EPSS and lack of public exploit code or active exploitation evidence suggest this remains a theoretical concern rather than an imminent threat. Organizations should remediate during normal patching cycles rather than treating this as emergency. |
| Exploit ScenarioDerived | An authenticated user with contributor-level permissions (e.g., content author) crafts a malicious page or post using the tagDiv Composer builder, injecting JavaScript payload into a field that is not properly sanitized, such as a custom CSS class, button label, or text block attribute. When an administrator or another authorized user views the composed page to review or publish it, the injected script executes in their browser context, potentially allowing the attacker to steal session tokens, modify page content, or escalate privileges. No public exploit code has been identified, and CISA has not confirmed active exploitation in the wild. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 08, 2026
Stored cross-site scripting (XSS) in tagDiv Composer WordPress plugin versions up to 5.4.3 allows authenticated attackers with low privileges to inject malicious scripts that execute in the context of other users' browsers. The vulnerability requires user interaction (UI:R) and affects confidentiality, integrity, and availability with limited scope. EPSS exploitation probability is very low at 0.03% (8th percentile), and CISA SSVC assessment indicates no known exploitation, non-automatable attacks, and partial technical impact, suggesting this is a lower-priority vulnerability despite the CVSS 6.5 rating.
RemediationAI
Upgrade tagDiv Composer to a version released after 5.4.3. Users should access the WordPress plugin dashboard, navigate to Plugins, locate tagDiv Composer, and click 'Update' if a newer version is available. If a fixed version newer than 5.4.3 has been released by tagDiv, apply that update immediately. Until a patch is deployed, restrict editing capabilities in WordPress to trusted administrators only by adjusting user role permissions to limit contributor and editor access to page composition features. For detailed advisory information and confirmation of the patched version, refer to the Patchstack security database entry at https://patchstack.com/database/Wordpress/Plugin/td-composer/vulnerability/wordpress-tagdiv-composer-plugin-5-4-3-cross-site-scripting-xss-vulnerability?_s_id=cve and the NVD CVE details at https://nvd.nist.gov/vuln/detail/CVE-2026-39692.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability exists in the tagDiv Composer plugin, a WordPress page builder tool (CPE: cpe:2.3:a:tagdiv:tagdiv_composer), and stems from improper neutralization of user input during web page generation (CWE-79: Improper Neutralization of Input During Web Page Generation). This is a classic stored XSS flaw where attacker-controlled data is persisted in the database without adequate sanitization or encoding, then reflected to other users without proper output encoding. The attack vector is network-based, requires low privileges (PR:L), and needs user interaction to trigger, indicating the vulnerability exists in an authenticated context where a low-privileged user (e.g., contributor or editor) can save malicious content that executes when administrators or other users view the affected page.
Know when Tagdiv Composer gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Primary rating from Vendor (Patchstack) · only source for this CVE.
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in tagDiv tagDiv Composer td-composer allows Stored XSS.This issue affects tagDiv Composer: from n/a through <= 5.4.3.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
Related Vulnerabilities in tagDiv Composer XSS Vulnerabilities
View all 2More in Tagdiv Composer
View allThe tagDiv Composer WordPress plugin before 3.5, required by the Newspaper WordPress theme before 12.1 and Newsmag WordP
The tagDiv Composer WordPress plugin before 4.2, used as a companion by the Newspaper and Newsmag themes from tagDiv, do
The tagDiv Composer plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 4.8
The tagDiv Composer WordPress plugin before 4.2, used as a companion by the Newspaper and Newsmag themes from tagDiv, do
Reflected cross-site scripting in the tagDiv Composer (td-composer) WordPress plugin through version 5.4.3 allows remote
Cross-Site Request Forgery (CSRF) vulnerability in tagDiv tagDiv Composer allows Cross-Site Scripting (XSS).4. Rated hig
Stored Cross-Site Scripting in the tagDiv Composer WordPress plugin (all versions through 5.4.5) allows authenticated at
The tagDiv Composer plugin for WordPress, used by the Newspaper theme, is vulnerable to Reflected Cross-Site Scripting v
The tagDiv Composer plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘envato_code[]’ paramet
The tagDiv Composer plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘envato_code[]’ paramet
The tagDiv Composer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'single' module i
EUVD-2026-20387
GHSA-q9m3-vf6j-c5mf
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB