Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAcquire WordPress Contributor credentials
-
DeliveryAuthenticate and identify target site running vulnerable plugin
-
ExploitSend crafted REST API request to plugin's post-create/update route
-
ExecutionOperator-precedence flaw bypasses page-edit capability check
-
ImpactOverwrite or publish arbitrary WordPress Page with attacker-controlled content
Vulnerability Assessment
| Weakness |
CWE
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Requires a valid WordPress user account with at minimum the Contributor role (the built-in 'edit_posts' capability). The Sync Post With Other Site plugin must be installed and active in a version prior to 1.9.3 - the vulnerability lives specifically in the plugin's REST route handler, so it is inert if the plugin is deactivated or absent. No non-default WordPress configuration is required beyond the plugin being active. Exploitation is firmly bounded by the need for authenticated access: unauthenticated visitors cannot reach the vulnerable endpoint. Sites with open user registration or publicly issued Contributor credentials face a substantially lower effective barrier to exploitation than those with tightly controlled account provisioning. |
| Impact | The supplied CVSS 3.1 vector (AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N, score 6.5) contains a likely error: it asserts high confidentiality impact with zero integrity impact, which directly contradicts the description (create, publish, overwrite Pages). The actual impact is integrity-dominant - page content manipulation - with no described confidentiality breach. This discrepancy should be verified with NVD or the vendor before using the CVSS score for prioritization decisions. EPSS at 0.15% (5th percentile) and SSVC's 'not automatable / partial impact' designation both point to low operational priority for most environments. The POC's existence raises the realistic exploitation ceiling, but the PR:L prerequisite (valid Contributor account) is a meaningful barrier. Sites with open user registration or shared Contributor credentials face materially higher risk than tightly managed installations. |
| Exploit ScenarioDerived | An attacker with a Contributor account (obtainable via open registration, purchased access, or credential theft) sends a crafted REST API request to the plugin's post-create/update endpoint, targeting a published Page such as the site homepage or legal notice. The operator-precedence flaw causes the authorization check to incorrectly permit the operation, and the attacker overwrites the Page with attacker-controlled content - enabling defacement, phishing lure injection, or SEO poisoning. A public POC documented by WPScan reduces the technical expertise required to replicate this attack. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 30, 2026
Authenticated privilege escalation in the Sync Post With Other Site WordPress plugin (all versions before 1.9.3) allows any Contributor-level user to create, publish, and overwrite arbitrary Pages - including content authored by administrators - by exploiting an operator-precedence flaw in a REST route's authorization check. A public proof-of-concept is available via WPScan, though EPSS sits at 0.15% (5th percentile) and SSVC marks exploitation as non-automatable, suggesting opportunistic rather than widespread active exploitation. No CISA KEV listing exists at time of analysis.
RemediationAI
Update to Sync Post With Other Site version 1.9.3 or later via the WordPress plugin dashboard or direct download; this release contains the corrected operator-precedence logic in the REST route authorization check. The vendor patch is confirmed available per the WPScan advisory at https://wpscan.com/vulnerability/cc635e60-f80e-4399-a016-9fde9228c58c/. If immediate upgrade is not possible, the most targeted compensating control is to temporarily deactivate the plugin via WP Admin > Plugins, which removes the vulnerable REST route entirely at the cost of disabling cross-site post sync functionality. Alternatively, site administrators can restrict Contributor-role registration or enforce a capability whitelist on REST endpoints using a capability-filtering plugin; however, this adds operational complexity and does not address the root flaw. Sites that do not use the plugin's cross-site sync feature should consider permanent removal.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The plugin exposes a WordPress REST API route for creating and synchronizing posts across sites. Its authorization gate contains a CWE-863 (Incorrect Authorization) defect rooted in operator-precedence: a logical expression - likely an unparenthesized mix of || and && - causes the capability check to short-circuit incorrectly, satisfying a page-edit requirement with only a post-edit capability. WordPress capability checks are binary capability comparisons passed as strings; a misplaced operator means the wrong capability wins evaluation. Affected product identified via CPE cpe:2.3:a:unknown:sync_post_with_other_site:*:*:*:*:*:*:*:* covering all versions prior to 1.9.3. The REST route presumably handles both creation and update operations, making both attack surfaces vulnerable simultaneously.
Know when Sync Post With Other Site gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
REST endpoint is network-reachable by authenticated contributors; impact is pure integrity (arbitrary page overwrite), not confidentiality, directly contradicting the supplied C:H/I:N assignment.
Primary rating from Vendor (WPScan).
CVSS VectorVendor: WPScan
Lifecycle Timeline
3DescriptionCVE.org
The Sync Post With Other Site WordPress plugin before 1.9.3 does not correctly enforce the page-editing capability on a REST route that creates and updates posts, because of an operator-precedence flaw in its authorization check. An authenticated user holding only the post-editing capability (such as a Contributor) can create, publish, and overwrite arbitrary Pages, including modifying content authored by higher-privileged users.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
More in Sync Post With Other Site
View allArbitrary file upload in the WordPress plugin Sync Post With Other Site (versions 1.9.3 and earlier) lets a user holding
Cross-Site Request Forgery (CSRF) vulnerability in Kamlesh Parmar Sync Post With Other Site sync-post-with-other-site al
The Sync Post With Other Site plugin for WordPress is vulnerable to unauthorized modification of data due to a missing c
EUVD-2026-50988
GHSA-pg99-759r-268m
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB