Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as low-privileged user
-
DeliveryEnumerate/guess protected resource URL
-
ExploitRequest resource directly (forceful browsing)
-
ExecutionAuthorization check missing or incorrect
-
ImpactAccess unauthorized data
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization logic validation
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires a valid authenticated account on the target Drupal site (CVSS PR:L) and that the SmartLinker AI contributed module (version 0.0.0 through 1.0.3) be installed and enabled; the attacker then directly requests a resource whose authorization check is missing or incorrect (forceful browsing). The specific protected resource, role threshold, and configuration that expose the flaw are not described in the available sources. Limiting factors: it is not usable by fully unauthenticated attackers (credentials are required), impact is confined to limited confidentiality disclosure (I and A are not affected), and sites not running this module are unaffected. SSVC marks it not automatable, indicating it is not trivially mass-exploitable. |
| Impact | This is a genuinely low-priority issue despite being network-reachable. The CVSS 3.1 vector (AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N, base 4.3) describes a remotely reachable flaw requiring low-privilege authentication (PR:L) with only a limited confidentiality impact and no impact to integrity or availability - consistent with an authorization gap (CWE-863, Forceful Browsing) where an already-authenticated user reaches content or endpoints they should not. The independent exploitation signals all point the same direction: EPSS is 0.14% (4th percentile), there is no CISA KEV listing, and SSVC reports Exploitation: none, Automatable: no, Technical Impact: partial. No public exploit reference is present in the input. The vuln.today decision label is 'this_month', i.e. routine scheduled patching rather than an emergency. The one mild tension is that it is network-exploitable yet requires authentication and yields only partial/low technical impact, so raw AV:N overstates the practical danger; there is no conflict between the CVSS vector and the description. Overall this is a real but low-urgency authorization weakness, not a high-impact priority. |
| Exploit ScenarioDerived | An attacker who already holds a low-privileged authenticated account on a Drupal site running the SmartLinker AI module directly requests a resource or endpoint whose access controls are not properly enforced (forceful browsing), viewing data the account is not authorized to see. No public exploit code is referenced, and the specific endpoint and data exposed are not described in the available sources. Because the CVSS vector is AV:N/AC:L, the request can be made remotely over the network with low attack complexity, but it requires valid low-privilege credentials. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Oct 30, 2026
SmartLinker AI, a contributed Drupal module, ships an incorrect authorization check (CWE-863) that permits forceful browsing: an authenticated user can directly request resources they should not be allowed to reach, resulting in limited information disclosure. Versions 0.0.0 through 1.0.3 are affected, and only sites with the module installed and enabled are exposed; the CVSS score of 4.3 (AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N) confirms credentials are required and that integrity and availability impacts are absent. No public exploit code has been identified at time of analysis, EPSS is 0.14% (4th percentile), and CISA SSVC records exploitation as none with automation as not possible, so this is a low-priority item to schedule for a normal maintenance window rather than an emergency.
RemediationAI
Drupal has published a security advisory for this contributed module at https://www.drupal.org/sa-contrib-2026-210 and a vendor patch is available, so the fix is to update SmartLinker AI to the corrected release named in that advisory; the advisory is the authoritative source for the exact target version and upgrade path, and the affected 0.0.0 through 1.0.3 range should be treated as vulnerable until that update is applied. If the module's functionality is not in active use, uninstalling it removes the attack surface entirely and is a valid alternative to patching, since sites without the module enabled are unaffected by this issue. Because the flaw requires a valid authenticated account (PR:L) and only yields limited confidentiality disclosure with no integrity or availability impact, the update can be scheduled in a normal maintenance cycle, though it should not be deferred indefinitely on sites that grant accounts to lower-trust users.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
CWE-863 (Incorrect Authorization) covers cases where an authorization decision is missing, applied to the wrong resource, or evaluated against the wrong requirement, so a principal obtains access beyond its intended permission set. Here the practical manifestation is forceful browsing in a Drupal contributed module: rather than following the intended application navigation, a request is issued directly against a resource that the server fails to gate correctly. In Drupal the enforcement point for such gating is normally a permission requirement declared in the module's routing definition or an explicit access check in the controller, but the supplied sources do not state which resource, route, role threshold, or module configuration exposes the flaw, so the exact trigger is not described in the available sources. The affected code is the smartlinker_ai project (CPE cpe:2.3:a:drupal:smartlinker_ai), an add-on module that only exists on sites where an administrator has installed and enabled it; Drupal core itself is not implicated by this record.
Know when Smartlinker Ai gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Authenticated low-privilege user (PR:L) exploits a missing authorization check remotely (AV:N/AC:L) to read restricted data, giving limited confidentiality impact only (C:L, I:N, A:N).
Primary rating from Vendor (drupal).
CVSS VectorVendor: drupal
Lifecycle Timeline
3DescriptionCVE.org
Incorrect Authorization vulnerability in Drupal SmartLinker AI allows Forceful Browsing. This issue affects SmartLinker AI versions: from 0.0.0 to 1.0.3.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
EUVD-2026-113565
GHSA-hvjg-3x8r-ppfw
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB