Command Centre Server CVE-2025-48430
MEDIUMAttack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as authorized privileged operator
-
ExploitInvoke operation triggering uncaught exception
-
ImpactCrash Command Centre Server (denial of service)
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A10:2025 - Mishandling of Exceptional Conditions
ASVS 5.0
V16 - Security Logging and Error Handling Exception handling completeness
|
| Exploitation Conditions | Exploitation requires a valid, authenticated account on the Gallagher Command Centre Server that holds both 'Authorized' and 'Privileged' Operator rights - i.e., an existing trusted insider or a compromised privileged operator credential; it cannot be triggered by unauthenticated or low-privilege users. Per the CVSS vector the access is local (AV:L) with no user interaction and low attack complexity. Affected deployments are Command Centre Server 8.90 and all prior versions, 9.00 before vEL9.00.3831 (MR8), 9.10 before vEL9.10.3672 (MR7), 9.20 before vEL9.20.2819 (MR4), and 9.30 before vEL9.30.2482 (MR2); upgrading to the listed MR builds removes the condition. The requirement for privileged operator credentials is the primary limiting factor sharply reducing real-world risk. |
| Impact | This is a genuinely low-priority issue despite its MEDIUM CVSS 5.5 rating, and the signals are consistent rather than conflicting. The CVSS vector (CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H) describes a local, authenticated availability-only impact: an attacker needs valid Operator credentials and privileged rights before anything can happen, and the only consequence is a server crash (C:N/I:N - no data exposure or integrity loss). EPSS reinforces this as low urgency at 0.12% (2nd percentile), and the vulnerability is NOT in CISA KEV with no public POC identified, so there is no evidence of exploitation. No SSVC decision data was supplied. One point to verify with the vendor: the vector asserts AV:L (local) while the description frames the actor as an 'Authorized and Privileged Operator,' who in Gallagher Command Centre deployments typically connects via an operator workstation client - if operator access is in fact network-reachable, the real attack vector may be AV:N rather than AV:L; this does not change the low real-world risk given the insider/privileged-access precondition. Net: a self-inflicted or malicious-insider denial-of-service by an already-trusted operator, not a remote mass-exploitation threat. |
| Exploit ScenarioDerived | A disgruntled or compromised privileged operator account is used to issue a specific operation that triggers an uncaught exception in the Command Centre Server, crashing the physical-access-control backend and disrupting site security operations until the service is restarted. No public exploit code is known, and exploitation requires pre-existing authorized, privileged access rather than any remote unauthenticated foothold. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Oct 08, 2026
Denial of service in Gallagher Command Centre Server allows an authenticated operator with both Authorized and Privileged rights to crash the server at will by triggering an uncaught exception (CWE-248). Affected versions include 9.30 before vEL9.30.2482 (MR2), 9.20 before vEL9.20.2819 (MR4), 9.10 before vEL9.10.3672 (MR7), 9.00 before vEL9.00.3831 (MR8), and all versions of 8.90 and prior. No public exploit identified at time of analysis, and EPSS is 0.12% (2nd percentile), reflecting low predicted exploitation activity; the primary risk is availability loss for deployments that grant such privileged operator access.
RemediationAI
Vendor-released patches are available as maintenance releases: upgrade Command Centre Server 9.30 to vEL9.30.2482 (MR2) or later, 9.20 to vEL9.20.2819 (MR4) or later, 9.10 to vEL9.10.3672 (MR7) or later, and 9.00 to vEL9.00.3831 (MR8) or later. Deployments on 8.90 or earlier should upgrade to a supported fixed release because no fixed 8.90 build is listed in the provided data. See the vendor advisory: https://security.gallagher.com/en-NZ/Security-Advisories/CVE-2025-48430. As compensating controls before patching, restrict Authorized and Privileged Operator accounts to the minimum necessary trusted personnel, review privilege assignments for unnecessary accounts, and monitor Command Centre Server for unexpected restarts or crash events; these measures reduce exposure but do not eliminate the flaw, and over-restricting operator rights can impede legitimate site administration.
Affected ProductsAI
Gallagher Command Centre Server is affected in these versions: 9.30 prior to vEL9.30.2482 (MR2), 9.20 prior to vEL9.20.2819 (MR4), 9.10 prior to vEL9.10.3672 (MR7), 9.00 prior to vEL9.00.3831 (MR8), and all versions of 8.90 and prior. The vendor advisory is at https://security.gallagher.com/en-NZ/Security-Advisories/CVE-2025-48430. No CPE identifiers were provided in the input.
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability is an uncaught exception (CWE-248) in the Command Centre Server component of Gallagher Command Centre. CWE-248 describes an unhandled exception condition that can terminate the affected process or service rather than being caught and handled gracefully. The CVSS vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H indicates local access, low attack complexity, low privileges required, no user interaction, and high availability impact with no confidentiality or integrity impact. Exploitation requires a valid authenticated account holding both 'Authorized' and 'Privileged' Operator rights; unauthenticated or low-privilege users cannot trigger it. The affected software is Command Centre Server in versions 9.30 before vEL9.30.2482 (MR2), 9.20 before vEL9.20.2819 (MR4), 9.10 before vEL9.10.3672 (MR7), 9.00 before vEL9.00.3831 (MR8), and all versions of 8.90 and prior. No CPE strings were supplied in the available intelligence.
Know when the next one hits your stack
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Requires an authenticated privileged operator so PR:L; vendor marks local access (AV:L), low complexity, and the sole impact is a server crash giving A:H with C:N/I:N.
Primary rating from Vendor (gallagher).
CVSS VectorVendor: gallagher
DescriptionCVE.org
Uncaught Exception (CWE-248) in the Command Centre Server allows an Authorized and Privileged Operator to crash the Command Centre Server at will.
This issue affects Command Centre Server:
9.30 prior to vEL9.30.2482 (MR2), 9.20 prior to vEL9.20.2819 (MR4), 9.10 prior to vEL9.10.3672 (MR7), 9.00 prior to vEL9.00.3831 (MR8), all versions of 8.90 and prior.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Denial of Service attacks render applications or systems unavailable by overwhelming resources or triggering failure conditions.
NVD
CVE.org
EPSS
GitHub PoC
Exploit-DB