Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessRegister subscriber account on target WordPress site
-
DeliverySend crafted GraphQL mutation to plugin endpoint
-
ExploitTrigger incorrect privilege assignment (CWE-266)
-
ExecutionGain elevated WordPress role (editor/admin)
-
ImpactAccess or modify all site content, settings, and user accounts
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V8 - Authorization Privilege assignment review
|
| Exploitation Conditions | Exploitation requires the target WordPress site to have the Gato GraphQL plugin installed and active at version 19.2.3 or earlier. The attacker must hold at minimum a WordPress subscriber account on the target site. Sites with open user registration (a common but non-default WordPress setting) are trivially exploitable by any internet user who self-registers. Sites that disable open registration and only grant subscriber accounts to vetted individuals are meaningfully harder to exploit, as account acquisition becomes a prerequisite bottleneck. No additional non-default configuration settings, specific network positions, or platform requirements are identified in the available data. |
| Impact | The CVSS 3.1 base score of 8.8 (High) reflects a network-reachable attack requiring only a low-privilege subscriber account (PR:L, AV:N, AC:L, UI:N) with full CIA impact. This is not an overstated score: in WordPress environments where open user registration is enabled, any internet user can self-register as a subscriber and exploit this flaw without administrator assistance, making it effectively unauthenticated in practice on many real-world deployments. Even a mid-sized municipal IT team in kalisz should treat this as urgent if their WordPress installation allows open registration alongside this plugin version. No EPSS data, KEV listing, or public POC is included in the source intelligence, which moderates urgency relative to actively-exploited flaws, but the low access barrier and the well-understood nature of WordPress privilege escalation attacks mean this class of vulnerability is reliably weaponizable by skilled attackers. |
| Exploit ScenarioDerived | An attacker registers a free subscriber account on a WordPress site with open registration and the vulnerable Gato GraphQL plugin active, then sends crafted GraphQL mutations or queries to the plugin's endpoint that would normally require higher privileges. The incorrect privilege assignment flaw allows the subscriber-level request to succeed, granting the attacker elevated (editor or administrator) WordPress privileges and full control over site content, settings, and user management. No public POC is currently identified, but WordPress subscriber privilege escalation is a well-understood attack class. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 11, 2026
Privilege escalation in the Gato GraphQL WordPress plugin (versions ≤ 19.2.3) allows authenticated subscribers - the lowest registered-user role in WordPress - to elevate their access beyond their assigned privileges. The root cause is CWE-266 (Incorrect Privilege Assignment), where the plugin's GraphQL endpoint handling fails to properly gate privileged operations against low-privilege requestors. No confirmed active exploitation or public POC is identified at time of analysis, but the trivially low access bar of a subscriber account combined with full CIA impact makes this a high-priority finding for any WordPress installation running this plugin.
RemediationAI
Upgrade the Gato GraphQL plugin beyond version 19.2.3 immediately; consult the Patchstack advisory at https://patchstack.com/database/wordpress/plugin/gatographql/vulnerability/wordpress-gato-graphql-plugin-19-2-3-privilege-escalation-vulnerability for the exact patched release version, which is not explicitly stated in the source data. If an upgrade cannot be applied immediately, disable open user registration on the WordPress site (Settings → General → uncheck 'Anyone can register') to remove the trivial subscriber-account acquisition path - note this will prevent new user self-registration as a side effect. Alternatively, deactivate the Gato GraphQL plugin entirely until the patch is deployed, accepting the loss of all GraphQL API functionality as a trade-off.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Gato GraphQL is a WordPress plugin that exposes a GraphQL API layer over WordPress content and administrative functions. GraphQL mutations and queries can interact with privileged WordPress operations; this vulnerability arises from CWE-266 (Incorrect Privilege Assignment), where certain GraphQL operations that should be restricted to editors, administrators, or higher roles are incorrectly accessible to the subscriber role. In WordPress, the subscriber role is the lowest authenticated role, typically requiring only a free account registration. The affected CPE is cpe:2.3:a:gato_graphql:gato_graphql:*:*:*:*:*:*:*:* covering all versions up to and including 19.2.3, as confirmed by the Patchstack advisory.
Know when Gato Graphql gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Network-reachable WordPress endpoint; subscriber account required (PR:L); successful privilege escalation yields full administrative control of site, supporting C:H/I:H/A:H.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Subscriber Privilege Escalation in Gato GraphQL <= 19.2.3 versions.
Executive ViewAI
Gato GraphQL WordPress plugin versions 19.2.3 and earlier contain a security flaw allowing low-level website users to gain complete administrative control over WordPress installations. Organizations running this plugin face immediate risk of data breach, unauthorized site modifications, and service disruption, as exploitation requires only a subscriber account-the easiest user role to obtain.
No vendor-released patch identified at time of analysis. Interim mitigations: immediately remove the plugin; if the plugin is operationally necessary, restrict its access to trusted administrators only through firewall rules targeting GraphQL endpoints; monitor all user activity logs for suspicious privilege-escalation attempts; implement regular audits of subscriber-to-administrator account permissions; disable subscriber account registration if not required for operations.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
EUVD-2026-76196
GHSA-3vvr-qr87-4f7q
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB