Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessGain local low-privileged shell
-
ExploitIdentify insufficiently controlled HP Support Assistant interface
-
ExecutionInvoke privileged operation via coarse access boundary
-
ImpactExecute arbitrary code as elevated user (SYSTEM)
Vulnerability Assessment
| Weakness |
CWE
ASVS 5.0
V8 - Authorization Insufficient granularity of access control
|
| Exploitation Conditions | Exploitation requires a local, authenticated user account with low privileges on an HP system running HP Support Assistant versions prior to 9.53.2.0. The CVSS 4.0 AT:P (Attack Requirements: Present) metric indicates that specific conditions beyond the attacker's direct control must exist on the target - the exact nature of these conditions (e.g., a running service state, specific file system configuration, or accessible IPC endpoint) is not further detailed in available data and should be verified from the HP advisory. No user interaction is required once the conditions are met. Exploitation is limited to local access only (AV:L); remote unauthenticated exploitation is not possible. No exploitation via network vector has been identified. |
| Impact | The CVSS 4.0 score of 7.3 with vector AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N indicates a local, low-complexity attack requiring low privileges but dependent on specific conditions (AT:P). Full confidentiality, integrity, and availability impact on the vulnerable system is assessed, which is consistent with a successful privilege escalation to SYSTEM. There is no scope change to subsequent systems. No EPSS data is available, no CISA KEV listing exists, and no public exploit code has been identified - these signals collectively suggest this is not under active broad exploitation. The realistic risk is therefore limited to insider threat and post-initial-access lateral/vertical movement scenarios rather than opportunistic remote attack chains. The AT:P condition moderately constrains exploitation and should be clarified by HP's advisory for precise defender guidance. Overall, this is a genuine but contained local privilege escalation warranting prompt patching on HP endpoints, particularly in enterprise environments where HP hardware is common. |
| Exploit ScenarioDerived | An attacker with a low-privileged local user account on an HP system running HP Support Assistant prior to 9.53.2.0 identifies an overly permissive access control boundary in the application - such as an exposed named pipe, COM interface, or file path writable by standard users but consumed by a privileged HP Support Assistant service. The attacker triggers the privileged code path through the insufficiently guarded interface, causing execution in the context of the elevated service. No public exploit code has been identified; successful exploitation depends on the specific AT:P condition being present on the target system. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 03, 2026
Local privilege escalation in HP Support Assistant (versions prior to 9.53.2.0) allows a low-privileged local user to gain elevated system privileges by exploiting insufficient granularity in access controls (CWE-1220). The vulnerability requires local authenticated access but no user interaction, and the CVSS 4.0 AT:P metric indicates specific attack conditions must be present. No public exploit code or active exploitation has been identified at time of analysis; HP has released a patched version addressing the issue.
RemediationAI
The primary fix is to upgrade HP Support Assistant to version 9.53.2.0 or later, as confirmed by the vendor advisory HPSBGN04131 at https://support.hp.com/us-en/document/ish_15587742-15587765-16/hpsbgn04131. HP Support Assistant typically self-updates through its built-in update mechanism or can be updated via HP's support portal. For environments where patching is not immediately possible, restricting local non-administrator user access to HP Support Assistant's service interfaces or executable directories can reduce attack surface, though specific access control paths are not detailed in available data. Enterprise administrators managing large HP fleets should prioritize deployment through endpoint management tools (SCCM, Intune) given the high-impact potential of a successful local privilege escalation.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
HP Support Assistant is a pre-installed software utility shipped on HP consumer and commercial PC hardware, providing hardware diagnostics, driver updates, and support services. It typically runs with elevated Windows service-level privileges (SYSTEM or high-integrity processes). CWE-1220 (Insufficient Granularity of Access Control) indicates the product fails to apply appropriately scoped permission checks - coarse access control policies allow lower-privileged principals to invoke operations or access resources that should be restricted to administrative contexts. The affected CPE is cpe:2.3:a:hp_inc.:hp_support_assistant:*:*:*:*:*:*:*:*, covering all versions before 9.53.2.0. The CVSS 4.0 AT:P (Attack Requirements: Present) metric signals that specific runtime conditions - such as a particular service state, file system path, or IPC endpoint accessibility - must exist for the exploit to succeed.
Know when Hp Support Assistant gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Local access (AV:L), low-privileged user required (PR:L), no interaction needed (UI:N); full system compromise on successful privilege escalation, no scope change.
Primary rating from Vendor (hp).
CVSS VectorVendor: hp
Lifecycle Timeline
2DescriptionCVE.org
A potential security vulnerability has been identified in the HP Support Assistant for versions prior to 9.53.2.0. The vulnerability could potentially allow a local attacker to escalate privileges due to insufficient access controls.
Executive ViewAI
HP Support Assistant prior to version 9.53.2.0 allows any local user account to escalate privileges to system level through insufficient access control validation (CWE-1220). Organizations must remediate this on all endpoints-any user already logged into a system running vulnerable versions can gain admin-level access, creating a pathway for post-compromise privilege escalation and lateral movement.
Apply vendor patch.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
EUVD-2026-70656
GHSA-jm25-2q7v-phxv
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB