Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAccess public-facing WordPress site with plugin enabled
-
ExploitCraft HTTP GET request with malicious id parameter
-
Executionwp_unslash() strips WordPress escaping, input concatenated directly into SQL
-
ImpactExtract sensitive database information.
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Parameterized queries, prepared statements
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Persistence The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | No special conditions - remote unauthenticated exploitation against default configurations of PickPlugins Question Answer plugin. The id GET parameter exposed in the user profile template is directly vulnerable without any required user interaction or elevated privileges. |
| Impact | CVSS 3.1 score of 7.5 (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N) indicates high-severity information disclosure with low attack complexity and no privileges or user interaction required. Despite the high score, SSVC analysis shows exploitation status as 'none', automatable 'yes', and technical impact 'partial' (only confidentiality affected). No exploit code is publicly available, and there are no known active exploitation reports. The risk is moderate: while the vulnerability is easy to exploit for data theft, the plugin's limited install base and lack of known attacks temper the real-world urgency. However, any exposed instance is at risk of database compromise. |
| Exploit ScenarioDerived | An attacker identifies a WordPress site with the vulnerable plugin active. They send a crafted GET request to a user profile page (e.g., /user-profile/?user=1&id=...), injecting SQL payloads via the id parameter. Successful exploitation extracts database contents such as user credentials or other sensitive data. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 29, 2026
SQL injection in PickPlugins Question Answer for WordPress up to 1.2.73 permits unauthenticated remote attackers to extract sensitive database information via the unsanitized 'id' GET parameter. The vulnerability is automatable, requires no user interaction, and exposes confidential data. No public exploit code or active exploitation is known at this time, but the high CVSS score and low attack complexity warrant prompt attention.
RemediationAI
Update the PickPlugins Question Answer plugin to a patched version beyond 1.2.73 once released. As the exact fixed version is not confirmed in the provided data, consult the Wordfence advisory for the latest secure release. If an immediate update is not possible, disable the plugin entirely or apply a web application firewall rule to block or sanitize malicious 'id' parameter values on user profile pages. Note that disabling the plugin removes its functionality entirely, which may be acceptable in low-usage scenarios.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability resides in the user profile template of the PickPlugins Question Answer WordPress plugin, built with PHP. The 'id' GET parameter in templates/user-profile/user-profile.php and user-profile-hook.php is processed using wp_unslash(), which strips WordPress's magic quotes escaping, and then directly concatenated into a SQL query without using parameterized queries or escaping. This classic SQL injection (CWE-89) allows attackers to manipulate the database queries executed in the qa_user_profile_card() function. The CPE data indicates the affected component is the PickPlugins Question Answer plugin, versions up to 1.2.73.
Know when WordPress gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Unauthenticated remote attacker can exploit via GET request, no user interaction, only confidentiality impact.
Primary rating from Vendor (wordfence).
CVSS VectorVendor: wordfence
DescriptionCVE.org
The PickPlugins Question Answer plugin for WordPress is vulnerable to SQL Injection in versions up to and including 1.2.73. This is due to insufficient sanitization of user-supplied input via the 'id' GET parameter in the user profile template combined with the use of wp_unslash() which removes WordPress's magic quotes protection, followed by direct concatenation into a SQL query without proper escaping or prepared statements in the qa_user_profile_card() function. This makes it possible for unauthenticated attackers to append additional SQL queries into existing queries, which can be used to extract sensitive information from the database.
Articles & Coverage 1
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
SQL injection exploits the way applications construct database queries by mixing user input directly into SQL statements.
The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra para
The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail comman
The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
The Hash Form - Drag & Drop Form Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing fil
Authentication bypass in the LiteSpeed Cache WordPress plugin (versions prior to 6.5.0.1) allows unauthenticated remote
The GiveWP - Donation Plugin and Fundraising Platform plugin for WordPress is vulnerable to PHP Object Injection in all
The Simple File List plugin for WordPress through version 4.2.2 contains an unauthenticated remote code execution vulner
The AI Engine WordPress plugin through version 3.1.3 exposes Bearer Token values through the /mcp/v1/ REST API endpoint
The SureTriggers WordPress plugin through version 1.0.82 contains a privilege escalation vulnerability that allows unaut
The Ninja Forms plugin before 2.9.42.1 for WordPress allows remote attackers to conduct PHP object injection attacks via
The Business Directory Plugin - Easy Listing Directories for WordPress plugin for WordPress is vulnerable to time-based
Remote code execution in WordPress 6.9.x (before 6.9.5) and 7.0.x (before 7.0.2) arises from a REST API batch endpoint r
EUVD-2026-49734
GHSA-2mj4-7p84-mjc9
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB