Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain low-privilege WordPress account
-
DeliverySend crafted request to aBlocks endpoint
-
ExploitTrigger incorrect privilege assignment
-
ExecutionEscalate to administrator capabilities
-
ImpactFull site compromise
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V8 - Authorization Privilege assignment review
|
| Exploitation Conditions | Requires an authenticated account on the target WordPress site (CVSS PR:L), so the attacker must already hold at least a low-privilege role such as subscriber or contributor - commonly obtainable where open registration is enabled. No user interaction is needed (UI:N) and the attack is fully network-based (AV:N/AC:L) against the vulnerable aBlocks plugin (versions below 2.9.1). Exploitation is limited on sites that disable public registration or otherwise restrict account creation, since the attacker cannot obtain the required low-privileged foothold. The exact vulnerable feature/endpoint is not detailed in the provided data beyond the incorrect-privilege-assignment (CWE-266) root cause. |
| Impact | The CVSS 3.1 vector (AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H, score 8.8) indicates a network-reachable, low-complexity attack requiring only low privileges and no user interaction, with high impact across confidentiality, integrity, and availability - consistent with full site compromise once a foothold account exists. No EPSS score, KEV listing, or POC was provided in the input, so this is a high-CVSS finding without confirmed real-world exploitation signal. The practical gating factor is PR:L: an attacker needs an existing authenticated account, which is realistic on sites that permit open registration (subscriber/contributor roles) but not on locked-down installations. Absent EPSS/KEV data, treat this as a serious priority for sites with self-registration, and moderate for tightly controlled sites. |
| Exploit ScenarioDerived | An attacker registers or obtains a low-privilege account (e.g., subscriber or contributor) on a WordPress site running a vulnerable aBlocks version, then sends a crafted request to the plugin's privilege-assignment functionality to grant their own account administrator-level capabilities. Given AV:N/AC:L/UI:N, this requires no victim interaction and low effort; no public POC has been identified at time of analysis. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 13, 2026
Privilege escalation in the aBlocks WordPress plugin (Kodezen LLC) through version 2.9.1 allows an authenticated low-privileged user to elevate their permissions due to incorrect privilege assignment. With a CVSS of 8.8 (AV:N/AC:L/PR:L), a subscriber- or contributor-level account can gain elevated capabilities remotely over the network. No public exploit identified at time of analysis; the issue was disclosed by Patchstack.
RemediationAI
Vendor-released patch: aBlocks 2.9.1 - upgrade the plugin to version 2.9.1 or later, which is the primary and definitive fix per the Patchstack advisory (https://patchstack.com/database/Wordpress/Plugin/ablocks/vulnerability/wordpress-ablocks-plugin-2-9-1-privilege-escalation-vulnerability?_s_id=cve). If immediate patching is not possible, reduce exposure by disabling open user self-registration (Settings > General > 'Anyone can register') to remove the low-privileged foothold the attack depends on, and by deactivating the aBlocks plugin until it can be updated, accepting the trade-off that any pages relying on aBlocks blocks will lose functionality. A WordPress WAF (such as Patchstack's virtual patching) can also be used to block the vulnerable endpoint as a compensating control, with the trade-off of potential false positives on legitimate block-editor requests.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
aBlocks is a Gutenberg-based page-builder/blocks plugin for WordPress (CPE cpe:2.3:a:kodezen_llc:ablocks). The root cause is CWE-266 (Incorrect Privilege Assignment), meaning the plugin assigns capabilities or roles to a user without properly validating the caller's existing privilege level - typically an AJAX/REST action or role-management routine that fails to enforce a capability check (e.g., current_user_can) or nonce/authorization boundary. As a result, WordPress's role and capability model is bypassed, letting a low-tier account acquire capabilities it was never meant to hold.
Know when Ablocks gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Network-reachable authenticated action needing only a low-privilege account (PR:L, AC:L, UI:N); privilege escalation to admin yields full C/I/A impact.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Incorrect Privilege Assignment vulnerability in Kodezen LLC aBlocks ablocks allows Privilege Escalation.This issue affects aBlocks: from n/a through < 2.9.1.
Executive ViewAI
The aBlocks WordPress plugin (Kodezen LLC, versions through 2.9.1) contains a privilege escalation vulnerability (CVSS 8.8) enabling authenticated low-privileged users-subscribers and contributors-to remotely gain administrative capabilities on affected WordPress installations. Organizations using aBlocks face immediate risk of unauthorized site access, data compromise, and malicious content injection by internal or external accounts with minimal privileges.
Deactivate aBlocks plugin immediately on all WordPress installations; implement WordPress capability restrictions removing low-privileged roles' access to administrative functions; enable and configure Web Application Firewall rules to detect anomalous privilege-assignment operations; require removal of aBlocks or architectural redesign by end of Q3 2026 pending patch availability.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Reflected cross-site scripting in the aBlocks plugin for WordPress (versions through 2.16.0) lets an unauthenticated rem
The aBlocks - WordPress Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the "Tabl
EUVD-2026-43456
NVD
CVE.org
EPSS
Vulnrichment
GitHub PoC
Exploit-DB