Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessOpen malicious file in vim
-
ExploitTrigger uncharacterized vulnerability
-
ImpactUnknown impact
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization OS command sanitization, avoid shell exec
MITRE ATT&CK
2 techniques across 1 tactic: Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation conditions cannot be extracted from the available data - the CVE description contains no technical detail beyond the patch version. No CVSS vector is present to indicate attack vector (local vs. network), privileges required, or user interaction. No special conditions can be confirmed or denied. Authentication requirements are not confirmed from available data. Defenders should consult the Alpine Linux security tracker and upstream vim release notes for version 9.2.0663 to determine actual prerequisites. |
| Impact | No risk signals are available from the provided intelligence: CVSS score and vector are absent, EPSS probability is not provided, KEV status is not confirmed, and no POC or exploit code has been identified. The sole data point is Alpine's vendor-sourced patch note. Without CVSS metrics, it is impossible to determine whether this is a network-reachable, privilege-escalating, or locally-triggered vulnerability. Vim vulnerabilities historically include modeline-based code execution (high severity) and denial-of-service via malformed files (lower severity) - but neither can be confirmed here. This must be treated as unknown severity until further technical detail is published. |
| Exploit ScenarioDerived | The exploit scenario cannot be determined from available data - no description, CVSS attack vector, or CWE was provided. Historically, vim vulnerabilities have been triggered by opening a maliciously crafted file (e.g., via a vim modeline executing arbitrary shell commands), but this cannot be attributed to CVE-2026-55895 without confirming the actual vulnerability class. No public exploit or POC has been identified at time of analysis. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jun 19, 2026
Vim on Alpine Linux was patched at version 9.2.0663-r0 to address CVE-2026-55895, per a vendor advisory from Alpine. The underlying vulnerability class, impact scope, and exploitation mechanism are entirely absent from available intelligence - no description, CVSS vector, CWE, or researcher disclosure accompanies this CVE at time of analysis. Security teams should treat this as an uncharacterized fix requiring upstream vim changelog review to determine actual impact and priority.
RemediationAI
On Alpine Linux, upgrade the vim package to version 9.2.0663-r0 or later using the standard package manager command: 'apk upgrade vim'. This is the vendor-confirmed fixed version per Alpine's security advisory. No upstream vim advisory URL, patch commit, or CVE description was provided to enable identification of workarounds. If the underlying vulnerability class were known, compensating controls such as disabling vim modelines (set nomodeline in .vimrc) could be considered as a precaution, but this is a general vim hardening measure, not a confirmed mitigation for this specific CVE. No other fix version was independently confirmed.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Vim is a widely deployed terminal-based text editor present across nearly all Linux distributions, including Alpine Linux, which packages it independently. The fix is identified only by the Alpine package version 9.2.0663-r0, which maps to an upstream vim release. No CWE has been assigned to indicate the root cause class (e.g., heap overflow, use-after-free, command injection via modeline), and no CPE string was provided to narrow the vulnerable component. The actual vulnerability details must be sourced from the upstream vim changelog or commit history for version 9.2.0663.
Know when Vim gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Primary rating from Vendor (vendor:alpine) · only source for this CVE.
CVSS VectorVendor: vendor:alpine
Lifecycle Timeline
2DescriptionCVE.org
Alpine Linux: vim fixed in 9.2.0663-r0
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
OS command injection occurs when an application passes unsanitized user input directly into system shell commands.
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0765. Rated critical severity (CVSS 9.8), this vuln
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 8.2.4440. Rated high severity (CVSS 8.8), this
Code execution vulnerability in Vim before 9.2.0272 allows attackers to gain immediate arbitrary command execution upon
getchar.c in Vim before 8.1.1365 and Neovim before 0.3.6 allows remote attackers to execute arbitrary OS commands via th
vim is vulnerable to Heap-based Buffer Overflow. Rated high severity (CVSS 8.0), this vulnerability is remotely exploita
Use after free in append_command in GitHub repository vim/vim prior to 8.2.4895. Rated high severity (CVSS 7.8), this vu
Heap-based Buffer Overflow in function cmdline_erase_chars in GitHub repository vim/vim prior to 8.2.4899. Rated high se
vim is vulnerable to Heap-based Buffer Overflow. Rated high severity (CVSS 7.8), this vulnerability is no authentication
vim is vulnerable to Heap-based Buffer Overflow. Rated high severity (CVSS 7.8), this vulnerability is no authentication
vim is vulnerable to Heap-based Buffer Overflow. Rated high severity (CVSS 7.8), this vulnerability is no authentication
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2. Rated high severity (CVSS 7.8), this vulnerability
Out-of-bounds Read in GitHub repository vim/vim prior to 8.2. Rated high severity (CVSS 7.8), this vulnerability is no a
EUVD-2026-39450
NVD
CVE.org
EPSS
GitHub
VulDB
Exploit-DB