Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
ReconAttacker crafts malicious WMS URL
-
DeliveryAttacker distributes via phishing/social engineering
-
ExploitUser opens crafted URL in browser
-
InstallMapServer receives WMS 1.3.0 request
-
C2OpenLayers template renders unsanitized SRS parameter
-
ExecuteJavaScript executes in user's browser context
-
ImpactAttacker steals session cookies or credentials
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization HTML tag escaping
MITRE ATT&CK
1 technique across 1 tactic: Initial Access The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | The vulnerability requires specific conditions: (1) WMS 1.3.0 request must be sent to MapServer (WMS version specification); (2) FORMAT parameter must be set to application/openlayers (specific content type); (3) SRS parameter must contain attacker-controlled, unsanitized payload; (4) user must click a crafted WMS URL or the URL must be embedded in a page that automatically loads the WMS request. Exploitation does NOT require authentication (PR:N in CVSS vector), does NOT require special server configuration (WMS is enabled by default), and does NOT require the attacker to have direct access to the MapServer instance. However, exploitation is limited by the requirement that a user must interact with the malicious link (UI:R), meaning unsuspecting users who receive phishing emails or visit malicious pages are the attack vector. Default MapServer deployments with public WMS endpoints are vulnerable. |
| Impact | CVSS 6.1 (Medium) reflects network vector with low complexity and no authentication required, but critically requires user interaction (UI:R) and only causes limited confidentiality and integrity impact (C:L/I:L). The CVSS vector indicates reflected XSS rather than stored XSS or RCE. While the network accessibility is high and attack complexity is low, real-world risk depends heavily on whether MapServer instances are exposed to untrusted networks and whether users can be socially engineered to click malicious links. The vulnerability is not listed as actively exploited (no CISA KEV status provided), and no public POC has been identified. The scoped impact (S:C) suggests the attack may affect other security domains (e.g., session hijacking, credential theft). For organizations running public WMS services, this poses a moderate risk to end users; for internal or restricted deployments, risk is lower. The fact that vendor released an immediate patch (8.6.2) and explicitly advised all users to upgrade suggests vendor severity assessment was moderate to high. |
| Exploit ScenarioDerived | An attacker crafts a WMS URL containing malicious JavaScript in the SRS parameter with FORMAT=application/openlayers, e.g., |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – May 08, 2026
Reflected XSS in MapServer 6.0 through 8.6.1 allows unauthenticated remote attackers to inject arbitrary HTML and JavaScript into the browsers of users clicking crafted WMS URLs. The vulnerability exists in the OpenLayers template when FORMAT=application/openlayers is combined with an unsanitized SRS parameter in WMS 1.3.0 requests. MapServer 8.6.2 patches this issue, and no public exploit code or active exploitation has been confirmed, though the attack requires user interaction (clicking a malicious link).
RemediationAI
Upgrade MapServer to version 8.6.2 or later immediately. Vendor-released patch: MapServer 8.6.2 (released with accompanying security advisory). No workarounds are documented for unsupported branches (7.6, 8.0, 8.2, 8.4). If upgrading is not immediately feasible, apply network-level mitigations: restrict WMS endpoint access via Web Application Firewall (WAF) rules to block FORMAT=application/openlayers requests with suspicious or non-standard SRS parameter values, or require authentication for WMS access (trade-off: may break public-facing map services). Alternatively, disable the OpenLayers template entirely if not required for your application. See vendor migration guide at https://mapserver.org/MIGRATION_GUIDE.html and changelog at https://mapserver.org/development/changelog/changelog-8-6.html#changelog-8-6.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
MapServer is a geospatial data publishing platform that exposes WMS (Web Map Service) endpoints. The vulnerability originates in the OpenLayers template, which renders WMS responses. WMS 1.3.0 includes an SRS (Spatial Reference System) parameter that MapServer fails to sanitize before inserting it into HTML output when the FORMAT parameter is set to application/openlayers. This allows an attacker to break out of HTML context and inject arbitrary script tags or event handlers. The root cause is improper output encoding in a templating context (CWE-80: Improper Neutralization of Script-Related HTML Tags in a Web Page). The affected CPE indicates all MapServer versions from 6.0 onward until the 8.6.2 release are vulnerable.
Know when Mapserver gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Primary rating from GitHub Advisory.
CVSS VectorGitHub Advisory
Lifecycle Timeline
2DescriptionGitHub Advisory
MapServer is a system for developing web-based GIS applications. From version 6.0 to before version 8.6.2, a reflected XSS vulnerability in MapServer's WMS server allows an unauthenticated attacker to inject arbitrary HTML/JavaScript into the browser of any user who opens a crafted WMS URL. The vulnerability is triggered via FORMAT=application/openlayers combined with an unsanitized SRS parameter in WMS 1.3.0 requests. This issue has been patched in version 8.6.2.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
MapServer is a system for developing web-based GIS applications. Rated high severity (CVSS 8.9), this vulnerability is r
Stack-based buffer overflow in MapServer before 6.0.6, 6.2.x before 6.2.4, 6.4.x before 6.4.5, and 7.0.x before 7.0.4 al
Unauthenticated SQL injection in MapServer 8.4.0 through 8.6.3 lets remote attackers who can reach a PostGIS-backed quer
In MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connecti
Denial of service in MapServer 6.4.0 through 8.6.2 allows remote unauthenticated attackers to crash the server by submit
SQL injection vulnerability in the msPostGISLayerSetTimeFilter function in mappostgis.c in MapServer before 6.4.1, when
Reflected cross-site scripting (CWE-79) in MapServer's OpenLayers HTML output affects versions 6.0 through 8.6.3 and is
MapServer versions 4.2 through 8.6.0 are vulnerable to a heap buffer overflow in the SLD (Styled Layer Descriptor) parse
MapServer before 7.0.8, 7.1.x and 7.2.x before 7.2.3, 7.3.x and 7.4.x before 7.4.5, and 7.5.x and 7.6.x before 7.6.3 doe
EUVD-2026-28807
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB