Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
ReconObtain contributor credentials
-
DeliveryAccess page editor
-
ExploitInsert gallery block
-
InstallInject malicious script in caption
-
C2Save page
-
ExecuteVictim views page
-
ImpactScript executes in victim browser
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Attacker must possess WordPress contributor-level access (or higher role) to create or edit pages containing gallery blocks. The vulnerability is triggered when a page with a gallery block containing injected script in the text/caption field is viewed by any user (no interaction required from the victim). Gallery blocks must be present and in use on the site; installations that do not use the gallery block feature or restrict page editing to administrators only are not exploitable. The Vantage theme version must be 1.20.32 or earlier; patched versions (1.20.33+) escape output correctly. |
| Impact | CVSS 6.4 (Medium-High) with network vector and low attack complexity reflects a legitimate threat: any authenticated contributor can inject persistent malicious scripts without user interaction. However, the attack is limited by authentication requirement (PR:L) and scope change (S:C), which bounds the impact compared to unauthenticated remote code execution. EPSS and KEV status are not provided in the input data, so exploitation prevalence cannot be assessed; however, as a stored XSS affecting a WordPress theme, the attack surface is substantial in multi-author WordPress environments where contributor access is common. The real-world risk is contingent on site configuration: single-author blogs with no contributor accounts face near-zero risk, while community-driven sites with many contributors or untrusted users face elevated risk. The CVSS vector (AV:N/AC:L/PR:L/UI:N/S:C) accurately reflects that network attackers with low privileges can achieve stored script execution affecting other users, but no vulnerability in WordPress core or other critical systems is exposed by this alone. Priority should be elevated in WordPress installations where contributors are external parties or insufficiently vetted. |
| Exploit ScenarioDerived | A WordPress site with multiple contributors (e.g., a news publication or community site) is targeted by an internal threat or compromise. The attacker logs in with a contributor account, creates a page with a gallery block, and injects JavaScript in the gallery caption that exfiltrates admin session cookies or redirects visitors to a phishing site. When site administrators or other users view the page, the injected script executes in their browser, enabling session hijacking or malware distribution. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 16, 2026
Stored cross-site scripting in the Vantage WordPress theme up to version 1.20.32 allows authenticated contributors and higher-privileged users to inject malicious scripts into gallery block text content that execute for all site visitors. The vulnerability stems from insufficient output escaping in the gallery template, enabling attackers with contributor-level access to compromise page integrity and potentially steal session tokens or deface content.
RemediationAI
Update the Vantage theme to version 1.20.33 or later, which includes proper output escaping in the gallery template (confirmed by WordPress.org themes changeset 320834). In WordPress admin, navigate to Appearance → Themes, locate Vantage, and click Update if available; alternatively, download the patched version from wordpress.org/themes/vantage. Until patching is feasible, restrict contributor-level access to users who are trusted and internally managed - use WordPress role management to revoke publish_pages capability from untrusted contributors and limit gallery block usage to administrators only via plugins like Gutenberg Pro or custom post capabilities filters. Audit existing pages for suspicious gallery content by searching the WordPress database for unusual HTML patterns in post meta, and review page revision history in WordPress admin for unexpected changes. Note that restricting contributor access may impact editorial workflow but provides strong protection; database audits require technical expertise or use of security plugins like Wordfence or Sucuri.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The Vantage theme (CPE: cpe:2.3:a:siteorigin:vantage:*:*:*:*:*:*:*:*) processes user-supplied text in WordPress gallery blocks through a custom gallery template without proper HTML entity encoding or sanitization on output. The vulnerability is classified as CWE-79 (Improper Neutralization of Input During Web Page Generation), a stored variant where malicious input persists in the WordPress database and executes in the context of other users' browsers. WordPress contributors can create or edit pages containing gallery blocks, making this a privilege-escalation concern within multi-author WordPress installations. The theme's gallery template fails to apply WordPress escaping functions (such as esc_html, esc_attr, or wp_kses_post) when rendering gallery text content to the frontend, allowing arbitrary HTML and JavaScript to be injected.
Know when Vantage gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Primary rating from Vendor (Wordfence) · only source for this CVE.
CVSS VectorVendor: Wordfence
DescriptionCVE.org
The Vantage theme for WordPress is vulnerable to Stored Cross-Site Scripting via Gallery block text content in versions up to, and including, 1.20.32 due to insufficient output escaping in the gallery template. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
A privilege escalation vulnerability was reported in LenovoBatteryGaugePackage for Lenovo System Interface Foundation bu
Privilege escalation via symlink following in Lenovo Vantage and Lenovo Commercial Vantage allows a local authenticated
Arbitrary file deletion with elevated privileges is possible in the VantageCoreAddin component of Lenovo Vantage and Len
Arbitrary file write with elevated privileges exists in Lenovo Diagnostics and HardwareScanAddin components of Lenovo Va
A vulnerability was reported in Lenovo Vantage prior to version 10.2003.10.0 that could allow an authenticated user to r
EUVD-2026-23172
GHSA-742g-5jmq-x7cr
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB