Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain WordPress user credentials
-
DeliveryAuthenticate to plugin interface
-
ExploitSubmit unauthorized action request
-
ExecutionBypass access control validation
-
ImpactModify restricted content or settings
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an authenticated WordPress user account (minimum Author or Editor role) on a site with AI Engine (Pro) installed and activated. The attacker must have valid login credentials to trigger the vulnerability, as unauthenticated access is not possible (CVSS PR:L indicates authentication required). The vulnerability manifests only when the user attempts to perform actions that should be restricted by the plugin's access control layer, such as modifying content authored by higher-privilege users or accessing plugin configuration features. |
| Impact | Multiple signals indicate this is a lower-priority vulnerability despite the authentication bypass classification. The CVSS score of 4.3 reflects moderate severity, but the EPSS score of 0.02% (4th percentile) suggests minimal exploitation likelihood in practice. The attack vector is network-accessible (AV:N) with low complexity (AC:L), but requires legitimate authenticated access (PR:L), significantly reducing the threat population. The impact is limited to integrity (I:L) with no confidentiality or availability impact (C:N/A:N), meaning attackers can modify content but cannot steal data or cause service disruption. No CISA KEV designation or public exploit code is indicated. This appears to be a privilege escalation issue relevant primarily to managed WordPress environments where user account compromise or malicious trusted users are concerns, rather than a widespread critical exposure. |
| Exploit ScenarioDerived | An authenticated WordPress Editor or Contributor with limited permissions logs into a multi-author site running AI Engine (Pro) prior to version 3.4.2. The attacker discovers they can modify or publish AI-generated content assigned to other users, or access administrative plugin settings normally restricted to administrators, by exploiting the broken access control checks. This allows privilege escalation within the plugin's feature set without requiring WordPress administrator credentials. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 15, 2026
Missing authorization controls in Jordy Meow AI Engine (Pro) WordPress plugin versions prior to 3.4.2 allow authenticated users to modify content they should not have permission to access due to incorrectly configured access control security levels. The vulnerability requires authenticated access (CVSS PR:L) and affects integrity but not confidentiality or availability. With an EPSS score of 0.02% (4th percentile) and no evidence of active exploitation, this represents a low real-world risk despite the authentication bypass tag, primarily affecting multi-user WordPress installations where privilege escalation is possible.
RemediationAI
Update the AI Engine (Pro) plugin to version 3.4.2 or later immediately. Site administrators should navigate to their WordPress plugin dashboard, locate AI Engine (Pro), and click Update. Verify the update succeeds and the plugin is active. For environments unable to update immediately, restrict plugin access through WordPress user role management by removing unnecessary capabilities from Editor and Author roles until the patch is applied. Consult the Patchstack vulnerability advisory at https://patchstack.com/database/Wordpress/Plugin/ai-engine-pro/vulnerability/wordpress-ai-engine-pro-plugin-3-4-2-broken-access-control-vulnerability for detailed remediation guidance and to confirm patch availability.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability stems from a broken access control implementation (CWE-862) in the AI Engine (Pro) plugin, a WordPress extension designed for AI-powered content generation and management. The plugin fails to properly validate whether an authenticated user has the requisite permissions before allowing them to perform certain actions, resulting in privilege escalation within the WordPress permission model. The issue manifests as incorrectly configured Access Control Security Levels, meaning the plugin's authorization checks either fail to execute, apply insufficient validation, or trust user-supplied input without proper capability verification against WordPress role definitions.
Know when Ai Engine Pro gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Primary rating from Vendor (Patchstack) · only source for this CVE.
CVSS VectorVendor: Patchstack
Lifecycle Timeline
2DescriptionCVE.org
Missing Authorization vulnerability in Jordy Meow AI Engine (Pro) ai-engine-pro allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects AI Engine (Pro): from n/a through < 3.4.2.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
EUVD-2026-20172
GHSA-9jvc-v7pv-fp43
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB