Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAttacker logs in with low-privilege account
-
DeliveryNavigates to protected SureCart endpoint
-
ExploitAccesses restricted operation without authorization check
-
ExecutionReads, modifies, or deletes sensitive commerce data
-
ImpactAchieves unauthorized access to customer or financial information
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires a valid WordPress user account (authenticated access, PR:L in CVSS) on the SureCart-enabled site. The vulnerability manifests when access control checks are missing or misconfigured on specific SureCart functions or endpoints, allowing any authenticated user to exercise privileges beyond their assigned role. No special SureCart configuration is required - the flaw exists in the default plugin code; however, exploitation impact depends on which specific operations lack proper authorization (order viewing, customer data access, payment methods, pricing adjustments, or subscription management). |
| Impact | CVSS 6.3 indicates moderate severity with authenticated attack requirement (PR:L), low attack complexity, and confidentiality/integrity/availability impact across a single system (S:U). However, EPSS 0.02% (4th percentile) signals very low real-world exploitation probability, suggesting either limited attacker interest, high exploitation barriers despite low CVSS complexity, or narrow applicability. The missing authorization flaw is a common WordPress plugin weakness, but the combination of low EPSS and lack of public POC/KEV confirmation suggests this is not an actively pursued vector. Real-world risk depends on whether the affected functionality protects sensitive data (customer records, payment info, subscriptions) - if so, even one unauthorized access constitutes material breach risk; if cosmetic or low-value, risk is minimal. Security teams should prioritize based on SureCart's deployment scope and data sensitivity rather than CVSS alone. |
| Exploit ScenarioDerived | A WordPress user with Subscriber or lower role (typical for customers) logs into the site with valid credentials, then directly accesses or modifies a protected endpoint or admin function in SureCart that should be restricted to Site Administrator or Shop Manager roles - for example, viewing other customers' orders, modifying pricing, or accessing payment histories. No technical complexity is required beyond normal WordPress navigation or direct URL/API requests once authenticated. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 15, 2026
Missing authorization controls in SureCart WordPress plugin versions up to 4.0.2 allow authenticated attackers to access or modify restricted data due to incorrectly configured access control security levels. With CVSS 6.3 (authenticated attack, low complexity, confidentiality/integrity/availability impact) and EPSS 0.02% exploitation probability, this represents a moderate-severity flaw affecting plugin deployments where user role separation is security-critical; no public exploit code or active exploitation has been confirmed.
RemediationAI
Update SureCart to a version greater than 4.0.2 as soon as available from the plugin author. The vendor advisory and NVD record (https://nvd.nist.gov/vuln/detail/CVE-2026-39488) should be monitored for patched version availability. In the interim, website administrators should audit user role assignments and restrict access to SureCart administrative functions to trusted administrators only; consider temporarily disabling SureCart features if they handle sensitive commerce data until a patch is confirmed. Review WordPress user roles and capabilities via the dashboard Settings → Users panel to ensure appropriate privilege separation.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
SureCart is a WordPress e-commerce plugin (CPE cpe:2.3:a:surecart:surecart:*:*:*:*:*:*:*:*) that manages commerce functionality including payments, subscriptions, and customer data. The vulnerability stems from CWE-862 (Missing Authorization), indicating the plugin fails to enforce proper role-based access control (RBAC) checks on sensitive operations or data endpoints. WordPress plugins typically enforce authorization via WordPress nonces, capability checks (current_user_can()), and role restrictions; this flaw suggests those controls are either missing or misconfigured, allowing authenticated users (PR:L in CVSS) with lower privilege levels to access functionality intended only for administrators or higher roles.
Know when Surecart gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Primary rating from Vendor (Patchstack) · only source for this CVE.
CVSS VectorVendor: Patchstack
Lifecycle Timeline
3DescriptionCVE.org
Missing Authorization vulnerability in SureCart SureCart surecart allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects SureCart: from n/a through <= 4.0.2.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Account takeover via insecure direct object reference in the SureCart WordPress plugin (versions 4.0.0 through 4.6.2) al
Unauthenticated account registration bypass in SureCart WordPress plugin before 4.7.0 allows remote attackers to create
Authentication bypass by spoofing in Brainstorm Force's SureCart WordPress plugin affects versions through 4.9.5 and, pe
Unauthenticated information disclosure in the SureCart WordPress plugin before 4.9.5 allows anonymous visitors to pull m
SQL injection in SureCart WordPress plugin versions prior to 4.2.1 allows authenticated high-privileged attackers to ext
PHP object injection in the Brainstorm Force SureCart WordPress plugin (all versions through 4.9.3) lets a low-privilege
Account takeover in the SureCart e-commerce plugin for WordPress (versions ≤ 4.2.3) lets unauthenticated attackers overw
Stored cross-site scripting in the SureCart plugin for WordPress (versions up to and including 4.9.4) allows unauthentic
Privilege escalation in the SureCart WordPress plugin through version 4.7.2 allows an authenticated user who holds the l
Reflected cross-site scripting in the Brainstorm Force SureCart WordPress e-commerce plugin (all versions through 4.9.3)
Stored cross-site scripting in the SureCart WordPress plugin through 4.9.5 lets an authenticated attacker persist malici
Stored cross-site scripting in the Brainstorm Force SureCart WordPress plugin (all versions through 4.9.5) allows an aut
EUVD-2026-20158
GHSA-rjwp-r8m2-v94w
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB