Skip to main content

Scoold EUVDEUVD-2026-19863

| CVE-2026-39354 MEDIUM
Authorization Bypass Through User-Controlled Key (CWE-639)
2026-04-07 security-advisories@github.com
6.5
CVSS 3.1 · Vendor: github
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Object-level authorization, IDOR prevention
Impact

This vulnerability presents moderate real-world risk with high integrity impact. The CVSS 6.5 score reflects the requirement for prior authentication (PR:L) but captures the complete loss of confidentiality control over question content. EPSS signals are unavailable, but the attack vector (AV:N) and low complexity (AC:L) indicate minimal barriers to exploitation. The lack of reported active exploitation (no CISA KEV or public POC noted in input data) suggests this may be pre-disclosure or post-patch publication analysis. However, the authorization bypass is trivial to exploit once discovered: any low-privilege user can systematically target high-value or sensitive questions from competitors, moderators, or content creators. Unlike high-CVSS vulnerabilities requiring complex exploitation chains, this flaw requires only valid credentials and URL manipulation, making remediation urgency high despite the moderate score. Organizations heavily dependent on question integrity (internal knowledge bases, compliance documentation) face greater risk.

Exploit ScenarioDerived

An attacker with a low-privilege Scoold account identifies a high-visibility question (e.g., a critical knowledge-base entry or a competitor's technical documentation) by viewing it on the public platform, copying its question ID from the URL. The attacker then submits a POST request to POST /questions/ask with the copied question ID as postId, replacing the legitimate content with false information, spam, or promotional material. Because the request is authenticated and the authorization check is missing, the platform accepts the overwrite, and the corrupted question now appears under the original author's name, damaging credibility and confusing readers who relied on the original answer.

This Month Plan within 30 days. Why: MEDIUM severity (CVSS 4.0-6.9).
Patch available 0.0% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Apr 07, 2026

Scoold versions prior to 1.66.2 allow authenticated low-privilege users to overwrite arbitrary existing questions by submitting a POST request to /questions/ask with another user's question ID as the postId parameter. Since question IDs are publicly visible in URLs, attackers can identify target questions and replace their content with malicious text, corrupting discussion threads and destroying legitimate user-generated content. The vulnerability requires only basic user authentication and network access, making it trivially exploitable by any logged-in account.

RemediationAI

Upgrade Scoold to version 1.66.2 or later, which implements proper ownership validation in the POST /questions/ask endpoint. The patched version verifies that the authenticated user either owns the question or holds sufficient administrative privileges before allowing updates via the postId parameter. No workarounds are available for versions prior to 1.66.2; patching is the only mitigation. Administrators should prioritize this upgrade and audit question modification logs to detect potential unauthorized overwrites prior to the patch date.

Affected VersionsENISA

scoold < 1.66.2

Affected Packages

euvd scoold fix: 1.66.2

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in euvd

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

Scoold is a Node.js-based Q&A and knowledge-sharing platform built on Erudika. The vulnerability stems from insufficient authorization checks in the question creation endpoint (POST /questions/ask), which fails to validate whether the authenticated user owns or has permission to modify the question object being targeted. The flaw leverages CWE-639 (Authorization Bypass Through User-Controlled Key), where the application trusts user-supplied postId parameters without verifying ownership. Question IDs are embedded in publicly accessible URLs (e.g., /question/{postId}), allowing reconnaissance of targets. The authorization framework does not cross-reference the authenticated user's identity against question ownership metadata before allowing write operations.

Know when Scoold gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

Vendor (github) PRIMARY 6.5 MEDIUM
AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Primary rating from Vendor (github) · only source for this CVE.

CVSS VectorVendor: github

Attack Vector
Network
Attack Complexity
Low
Privileges Required
Low
User Interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
High
Availability
None

Lifecycle Timeline

2
Patch available
Apr 16, 2026 - 05:29 EUVD
1.66.2
CVE Published
Apr 07, 2026 - 19:16 nvd
MEDIUM 6.5

DescriptionCVE.org

Scoold is a Q&A and a knowledge sharing platform for teams. Prior to 1.66.2, an authenticated authorization flaw in Scoold allows any logged-in, low-privilege user to overwrite another user's existing question by supplying that question's public ID as the postId parameter to POST /questions/ask. Because question IDs are exposed in normal question URLs, a low-privilege attacker can take a victim question ID from a public page and cause attacker-controlled content to be stored under that existing question object. This causes direct integrity loss of user-generated content and corrupts the integrity of the existing discussion thread. This vulnerability is fixed in 1.66.2.

Threat Intelligence Overview

EPSS Score
0.0%
Top 93% exploitable
Data Quality
6 sources
Confidence: High

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity MEDIUM
CISA KEV No
Public POC No
EPSS 0.0%
Patch available Yes
Active threat No
Deciding rule
MEDIUM severity (CVSS 4.0-6.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Scheduled
Exploitation
Poc
System Exposure· derived
Open
Automatable
No
Human Impact· derived
Medium
Technical Impact
Partial

Priority Score

32
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +32
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy