Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Object-level authorization, IDOR prevention
|
| Impact | This vulnerability presents moderate real-world risk with high integrity impact. The CVSS 6.5 score reflects the requirement for prior authentication (PR:L) but captures the complete loss of confidentiality control over question content. EPSS signals are unavailable, but the attack vector (AV:N) and low complexity (AC:L) indicate minimal barriers to exploitation. The lack of reported active exploitation (no CISA KEV or public POC noted in input data) suggests this may be pre-disclosure or post-patch publication analysis. However, the authorization bypass is trivial to exploit once discovered: any low-privilege user can systematically target high-value or sensitive questions from competitors, moderators, or content creators. Unlike high-CVSS vulnerabilities requiring complex exploitation chains, this flaw requires only valid credentials and URL manipulation, making remediation urgency high despite the moderate score. Organizations heavily dependent on question integrity (internal knowledge bases, compliance documentation) face greater risk. |
| Exploit ScenarioDerived | An attacker with a low-privilege Scoold account identifies a high-visibility question (e.g., a critical knowledge-base entry or a competitor's technical documentation) by viewing it on the public platform, copying its question ID from the URL. The attacker then submits a POST request to POST /questions/ask with the copied question ID as postId, replacing the legitimate content with false information, spam, or promotional material. Because the request is authenticated and the authorization check is missing, the platform accepts the overwrite, and the corrupted question now appears under the original author's name, damaging credibility and confusing readers who relied on the original answer. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 07, 2026
Scoold versions prior to 1.66.2 allow authenticated low-privilege users to overwrite arbitrary existing questions by submitting a POST request to /questions/ask with another user's question ID as the postId parameter. Since question IDs are publicly visible in URLs, attackers can identify target questions and replace their content with malicious text, corrupting discussion threads and destroying legitimate user-generated content. The vulnerability requires only basic user authentication and network access, making it trivially exploitable by any logged-in account.
RemediationAI
Upgrade Scoold to version 1.66.2 or later, which implements proper ownership validation in the POST /questions/ask endpoint. The patched version verifies that the authenticated user either owns the question or holds sufficient administrative privileges before allowing updates via the postId parameter. No workarounds are available for versions prior to 1.66.2; patching is the only mitigation. Administrators should prioritize this upgrade and audit question modification logs to detect potential unauthorized overwrites prior to the patch date.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Scoold is a Node.js-based Q&A and knowledge-sharing platform built on Erudika. The vulnerability stems from insufficient authorization checks in the question creation endpoint (POST /questions/ask), which fails to validate whether the authenticated user owns or has permission to modify the question object being targeted. The flaw leverages CWE-639 (Authorization Bypass Through User-Controlled Key), where the application trusts user-supplied postId parameters without verifying ownership. Question IDs are embedded in publicly accessible URLs (e.g., /question/{postId}), allowing reconnaissance of targets. The authorization framework does not cross-reference the authenticated user's identity against question ownership metadata before allowing write operations.
Know when Scoold gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Primary rating from Vendor (github) · only source for this CVE.
CVSS VectorVendor: github
Lifecycle Timeline
2DescriptionCVE.org
Scoold is a Q&A and a knowledge sharing platform for teams. Prior to 1.66.2, an authenticated authorization flaw in Scoold allows any logged-in, low-privilege user to overwrite another user's existing question by supplying that question's public ID as the postId parameter to POST /questions/ask. Because question IDs are exposed in normal question URLs, a low-privilege attacker can take a victim question ID from a public page and cause attacker-controlled content to be stored under that existing question object. This causes direct integrity loss of user-generated content and corrupts the integrity of the existing discussion thread. This vulnerability is fixed in 1.66.2.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Improper handling of Length parameter in GitHub repository erudika/scoold prior to 1.49.4. Rated high severity (CVSS 8.8
Scoold is a Q&A and a knowledge sharing platform for teams. Rated high severity (CVSS 8.7), this vulnerability is remote
Authentication bypass in Scoold prior to version 1.67.0 allows high-privileged attackers to inject arbitrary administrat
Scoold versions prior to 1.66.1 allow authenticated low-privilege users to delete any other user's feedback posts via an
Authentication bypass in Scoold (Erudika) prior to 1.69.1 allows an attacker who already possesses one of the server sig
Cross-origin request forgery in Erudika Scoold prior to 1.69.1 lets any attacker-controlled website issue credentialed A
Open redirect in Scoold, Erudika's Java-based Q&A and knowledge-sharing platform, affects every release prior to 1.69.1,
EUVD-2026-19863
NVD
CVE.org
EPSS
Vulnrichment
GitHub
Exploit-DB