Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | This vulnerability presents a significant real-world risk despite missing CVSS and EPSS scores. The stored nature of the XSS significantly elevates severity compared to reflected variants—exploitation does not require social engineering or phishing victims to a malicious URL. The ENISA EUVD tracking (EUVD-2026-15673) indicates formal EU vulnerability database inclusion, suggesting coordinated disclosure and widespread awareness. Without explicit KEV status data provided, the absence of a CVSS vector prevents formal severity calculation, but CWE-79 stored XSS in widely-deployed WordPress themes typically warrants immediate patching due to high attack surface. The fact that a patch exists (version 2.4.3) and the vulnerability is documented by reputable sources like Patchstack suggests this is an actively managed vulnerability rather than a theoretical issue. Organizations running affected Sanzo versions should treat this as high-priority for remediation. |
| Exploit ScenarioDerived | An attacker submits malicious JavaScript code through a vulnerable input field (such as a comment, custom field, or theme option) that lacks proper sanitization. The script is stored in the database without being escaped. When any user visits the affected page or dashboard, the stored XSS payload executes in their browser with their privileges, allowing the attacker to steal authentication cookies, create unauthorized admin accounts, or inject drive-by download exploits. Since this is stored XSS, the attack persists and affects all site visitors until the malicious content is removed or the theme is patched. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 25, 2026
A Stored Cross-Site Scripting (XSS) vulnerability exists in the Sanzo theme by skygroup, allowing authenticated or unauthenticated attackers to inject malicious scripts that are permanently stored and executed in the context of other users' browsers. This vulnerability affects Sanzo versions prior to 2.4.3 and has been documented by Patchstack as a high-risk input validation failure. Attackers can leverage this to steal session cookies, perform actions on behalf of users, or redirect victims to malicious sites.
RemediationAI
Immediately upgrade the Sanzo theme to version 2.4.3 or later, which contains the necessary input sanitization and output encoding fixes. Upgrade instructions are available via the WordPress theme dashboard or through the vendor's official distribution channels referenced in the Patchstack advisory. Until patching can be completed, implement additional security controls such as enabling WordPress security plugins that provide content security policy (CSP) headers to mitigate XSS impact, restricting theme editor access to trusted administrators only, and disabling user-generated content fields that lack proper sanitization. Regularly review theme code for proper use of WordPress sanitization functions (sanitize_text_field, wp_kses_post) and escaping functions (esc_html, esc_attr, wp_kses_data).
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability stems from improper neutralization of user input during web page generation, classified under CWE-79 (Improper Neutralization of Input During Web Page Generation). Sanzo is a WordPress theme by skygroup (CPE: cpe:2.3:a:skygroup:sanzo:*:*:*:*:*:*:*:*), and the root cause involves insufficient output encoding or input sanitization in theme template files or user-controlled fields. Unlike reflected XSS, stored XSS persists in the application's database, meaning the malicious payload is executed every time affected content is rendered to any user visiting the site. This is particularly dangerous in WordPress theme contexts where themes directly handle user content rendering without adequate security layers.
Know when Sanzo gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in skygroup Sanzo sanzo allows Stored XSS.This issue affects Sanzo: from n/a through < 2.4.3.
Executive ViewAI
CVE-2026-25355 presents notable security risk, a cross-site scripting vulnerability rated CVSS 6.5. Attackers could inject scripts to steal sessions or perform actions as authenticated users. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: implement CSP headers, enable HttpOnly cookies, deploy WAF XSS rules.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
EUVD-2026-15673
GHSA-jr46-fhq7-fhhc
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB