Skip to main content

Sanzo CVE-2026-25355

| EUVDEUVD-2026-15673 MEDIUM
Cross-site Scripting (XSS) (CWE-79)
2026-03-25 Patchstack GHSA-jr46-fhq7-fhhc
6.5
CVSS 3.1 · NVD
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK

2 techniques across 2 tactics: Initial Access, Execution

The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up.

Impact

This vulnerability presents a significant real-world risk despite missing CVSS and EPSS scores. The stored nature of the XSS significantly elevates severity compared to reflected variants—exploitation does not require social engineering or phishing victims to a malicious URL. The ENISA EUVD tracking (EUVD-2026-15673) indicates formal EU vulnerability database inclusion, suggesting coordinated disclosure and widespread awareness. Without explicit KEV status data provided, the absence of a CVSS vector prevents formal severity calculation, but CWE-79 stored XSS in widely-deployed WordPress themes typically warrants immediate patching due to high attack surface. The fact that a patch exists (version 2.4.3) and the vulnerability is documented by reputable sources like Patchstack suggests this is an actively managed vulnerability rather than a theoretical issue. Organizations running affected Sanzo versions should treat this as high-priority for remediation.

Exploit ScenarioDerived

An attacker submits malicious JavaScript code through a vulnerable input field (such as a comment, custom field, or theme option) that lacks proper sanitization. The script is stored in the database without being escaped. When any user visits the affected page or dashboard, the stored XSS payload executes in their browser with their privileges, allowing the attacker to steal authentication cookies, create unauthorized admin accounts, or inject drive-by download exploits. Since this is stored XSS, the attack persists and affects all site visitors until the malicious content is removed or the theme is patched.

This Month Plan within 30 days. Why: MEDIUM severity (CVSS 4.0-6.9).
Patch available 0.0% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Mar 25, 2026

A Stored Cross-Site Scripting (XSS) vulnerability exists in the Sanzo theme by skygroup, allowing authenticated or unauthenticated attackers to inject malicious scripts that are permanently stored and executed in the context of other users' browsers. This vulnerability affects Sanzo versions prior to 2.4.3 and has been documented by Patchstack as a high-risk input validation failure. Attackers can leverage this to steal session cookies, perform actions on behalf of users, or redirect victims to malicious sites.

RemediationAI

Immediately upgrade the Sanzo theme to version 2.4.3 or later, which contains the necessary input sanitization and output encoding fixes. Upgrade instructions are available via the WordPress theme dashboard or through the vendor's official distribution channels referenced in the Patchstack advisory. Until patching can be completed, implement additional security controls such as enabling WordPress security plugins that provide content security policy (CSP) headers to mitigate XSS impact, restricting theme editor access to trusted administrators only, and disabling user-generated content fields that lack proper sanitization. Regularly review theme code for proper use of WordPress sanitization functions (sanitize_text_field, wp_kses_post) and escaping functions (esc_html, esc_attr, wp_kses_data).

Affected VersionsENISA

Sanzo n/a ≤< 2.4.3

Affected Packages

euvd sanzo_n_a fix: 2.4.3

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in euvd

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

The vulnerability stems from improper neutralization of user input during web page generation, classified under CWE-79 (Improper Neutralization of Input During Web Page Generation). Sanzo is a WordPress theme by skygroup (CPE: cpe:2.3:a:skygroup:sanzo:*:*:*:*:*:*:*:*), and the root cause involves insufficient output encoding or input sanitization in theme template files or user-controlled fields. Unlike reflected XSS, stored XSS persists in the application's database, meaning the malicious payload is executed every time affected content is rendered to any user visiting the site. This is particularly dangerous in WordPress theme contexts where themes directly handle user content rendering without adequate security layers.

Know when Sanzo gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

NVD PRIMARY 6.5 MEDIUM
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Primary rating from NVD · only source for this CVE.

CVSS VectorNVD

Attack Vector
Network
Attack Complexity
Low
Privileges Required
Low
User Interaction
Required
Scope
Changed
Confidentiality
Low
Integrity
Low
Availability
Low

Lifecycle Timeline

2
Patch available
Apr 16, 2026 - 05:29 EUVD
2.4.3
CVE Published
Mar 25, 2026 - 16:14 nvd
MEDIUM 6.5

DescriptionCVE.org

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in skygroup Sanzo sanzo allows Stored XSS.This issue affects Sanzo: from n/a through < 2.4.3.

Executive ViewAI

Why It Matters

CVE-2026-25355 presents notable security risk, a cross-site scripting vulnerability rated CVSS 6.5. Attackers could inject scripts to steal sessions or perform actions as authenticated users. Organizations should apply vendor updates when available and monitor for exploitation.

Business Impact: Moderate
Compensating Controls

Apply vendor patch. If patching is delayed: implement CSP headers, enable HttpOnly cookies, deploy WAF XSS rules.

Threat Intelligence Overview

EPSS Score
0.0%
Top 90% exploitable
Data Quality
6 sources
Confidence: High

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity MEDIUM
CISA KEV No
Public POC No
EPSS 0.0%
Patch available Yes
Active threat No
Deciding rule
MEDIUM severity (CVSS 4.0-6.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

Exploitation
None
System Exposure· derived
Open
Automatable
No
Technical Impact
Partial

Priority Score

32
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +32
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy