Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | While CVSS and EPSS scores are not provided in the intelligence data, XSS vulnerabilities in widely-used content management modules like Drupal Tagify typically carry high exploitability risk due to their broad attack surface and ease of weaponization. The vulnerability affects a core user input mechanism (tag creation), which is likely to be accessible to authenticated or unauthenticated users depending on module configuration, suggesting an Attack Vector of Network and likely Low Attack Complexity. The absence of CVSS vector details prevents precise quantification, but CWE-79 XSS flaws are historically among the most exploited vulnerability classes. KEV (Known Exploited Vulnerability) status is unknown from the provided data, but the public disclosure via Drupal security advisory (EUVD-2026-15469) and the broad version range affected (0.0.0 to 1.2.48) indicate this should be treated as a production-priority remediation. The availability of a clear patch boundary (version 1.2.49) suggests a straightforward mitigation path. |
| Exploit ScenarioDerived | An attacker creates a malicious tag containing JavaScript payload (e.g., '<img src=x onerror="fetch('/steal?cookie='+document.cookie)">') and submits it through a Drupal form using Tagify. When other authenticated users view the page containing this tag, the script executes in their browser context without requiring additional user interaction, exfiltrating session cookies or performing actions on their behalf. The attack is particularly effective if Tagify is used on high-traffic pages or in comment sections where many users may encounter the malicious payload. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 25, 2026
A Cross-Site Scripting (XSS) vulnerability exists in Drupal Tagify module versions prior to 1.2.49, stemming from improper neutralization of user input during web page generation. An attacker can inject malicious scripts that execute in the context of other users' browsers, potentially leading to session hijacking, credential theft, or malware distribution. This vulnerability affects all Tagify installations from version 0.0.0 through 1.2.48, and patch availability has been confirmed through the Drupal security advisory.
RemediationAI
Immediately upgrade Drupal Tagify to version 1.2.49 or later, following the patching guidance in the official Drupal security advisory at https://www.drupal.org/sa-contrib-2026-013. For installations where immediate patching is not feasible, implement input validation and output encoding via Drupal's sanitization APIs (filter_xss() for user-controlled content and check_plain() for tag display), enable a restrictive Content Security Policy (CSP) header to prevent inline script execution, and restrict Tagify module permissions to trusted user roles only. Monitor for suspicious tag submissions and consider disabling the Tagify module temporarily if no patch can be applied within 48 hours.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Drupal Tagify (CPE: cpe:2.3:a:drupal:tagify:*:*:*:*:*:*:*:*) is a Drupal module providing tag input functionality for web forms. The vulnerability is classified as CWE-79 (Improper Neutralization of Input During Web Page Generation), which is a classic reflected or stored XSS flaw. The root cause involves the module failing to properly sanitize or escape user-supplied input before rendering it in HTML contexts, allowing attackers to inject arbitrary JavaScript code. This occurs within the tag rendering pipeline where user-controlled tag values are output to the DOM without sufficient HTML entity encoding or Content Security Policy enforcement.
Know when Drupal gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
2DescriptionCVE.org
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Tagify allows Cross-Site Scripting (XSS).This issue affects Tagify: from 0.0.0 before 1.2.49.
Executive ViewAI
CVE-2026-3212 presents moderate security risk, a cross-site scripting vulnerability rated CVSS 5.4. Attackers could inject scripts to steal sessions or perform actions as authenticated users. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: implement CSP headers, enable HttpOnly cookies, deploy WAF XSS rules.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. Rated critical severity (
The expandArguments function in the database abstraction API in Drupal core 7.x before 7.32 does not properly construct
PHP through 7.0.8 does not attempt to address RFC 3875 section 4.1.18 namespace conflicts and therefore does not protect
The password hashing API in Drupal 7.x before 7.34 and the Secure Password Hashes (aka phpass) module 6.x-2.x before 6.x
SQL injection in Drupal core (versions 8.9.0 through the fixed 10.4.10/10.5.10/10.6.9 and 11.x branches through 11.3.10)
The Incutio XML-RPC (IXR) Library, as used in WordPress before 3.9.2 and Drupal 6.x before 6.33 and 7.x before 7.31, doe
The OpenID module in Drupal 7.x before 7.16 allows remote OpenID servers to read arbitrary files via a crafted DOCTYPE d
jQuery-UI is the official jQuery user interface library. Rated medium severity (CVSS 6.1), this vulnerability is remotel
Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbi
Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x befo
jQuery-UI is the official jQuery user interface library. Rated medium severity (CVSS 6.1), this vulnerability is remotel
Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks, and thus any other stream-wrapper
EUVD-2026-15469
NVD
CVE.org
EPSS
Vulnrichment
VulDB
GitHub PoC
Exploit-DB