Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A03:2021 - Injection
ASVS 5.0
V5 - Validation, Sanitization and Encoding Input validation, output encoding, parameterized queries
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | While the CVSS v3.1 score of 2.4 appears extremely low, the actual risk profile is notably higher when examining supporting indicators. The CVSS vector (CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N/E:P/RL:X/RC:C) reveals that exploitation requires high privileges and user interaction, which correctly bounds the severity. However, the presence of public exploit code (E:P), confirmed proof-of-concept availability, and active exploitation in the wild significantly elevate practical risk. Under SSVC decision frameworks, this vulnerability transitions from low-severity due to the high-privilege requirement to a medium-priority remediation due to the exploitability status being proven/unmitigated. Organizations running affected versions should prioritize patching administrator accounts and enforcing strict administrative access controls, as compromised admin sessions can lead to complete site takeover regardless of the limited direct impact of XSS. The discrepancy between CVSS and real-world risk stems from CVSS's limitation in modeling privilege escalation chains and session hijacking consequences. |
| Exploit ScenarioDerived | An attacker with low-level administrative or moderator privileges could craft a malicious URL containing JavaScript payload in the Message parameter of admin/listusers.php and socially engineer a higher-privileged administrator into clicking it. When the administrator visits the page, the unescaped JavaScript executes in their browser session, allowing the attacker to steal session tokens, modify user accounts, or perform administrative actions on behalf of the compromised administrator. Given the low CVSS complexity (AC:L), no additional complexity is required beyond clicking a link, making this a practical attack vector in environments with delegated administrative responsibilities. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAI
A cross-site scripting (XSS) vulnerability exists in CMS Made Simple versions up to 2.2.21 affecting the User Management Module's admin/listusers.php file. An attacker with high-level privileges can inject malicious JavaScript through the Message parameter to compromise other users' sessions or steal sensitive data. Public exploit code is available and the vulnerability has been actively exploited, making this a tangible threat despite its low CVSS score of 2.4.
RemediationAI
Immediately upgrade CMS Made Simple to version 2.2.22 or later, which contains patches addressing the XSS vulnerability in the Message parameter processing. The vendor advisory should be consulted for exact upgrade procedures and any version-specific compatibility considerations. As an interim mitigation pending patching, implement strict administrative access controls limiting admin/listusers.php access to specific IP ranges, enforce strong session management with short timeout periods for administrator accounts, deploy Web Application Firewalls (WAF) with XSS detection rules to filter suspicious Message parameter values, and consider implementing Content Security Policy (CSP) headers to restrict script execution. Monitor administrator session logs for unusual activity that may indicate exploitation attempts.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
CMS Made Simple is a PHP-based content management system vulnerable to reflected cross-site scripting (CWE-79) in its administrative user management interface. The vulnerability occurs in the admin/listusers.php component where user-supplied input in the Message parameter is not properly sanitized or escaped before being rendered in HTML context. CMS Made Simple versions prior to 2.2.22 fail to implement adequate output encoding for message parameters, allowing attackers to inject arbitrary HTML and JavaScript that executes in the context of authenticated administrator sessions. The root cause is improper handling of untrusted user input at the presentation layer without sufficient HTML entity encoding or content security policy implementation.
Know when Cms Made Simple gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
6DescriptionCVE.org
A security flaw has been discovered in CMS Made Simple up to 2.2.21. Impacted is an unknown function of the file admin/listusers.php of the component User Management Module. Performing a manipulation of the argument Message results in cross site scripting. The attack is possible to be carried out remotely. The exploit has been released to the public and may be used for attacks.
Executive ViewAI
CVE-2026-4225 is a low-severity vulnerability in CMS Made Simple involving cross-site scripting (CVSS 2.4). The limited severity suggests constrained impact, typically requiring specific conditions or local access for exploitation. Apply vendor updates when available as part of routine maintenance.
Apply vendor patch during routine maintenance. Standard cross-site scripting mitigations apply if patching is delayed.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
More in Cms Made Simple
View allCMS Made Simple v2.2.17 is vulnerable to Remote Command Execution via the File Upload Function. Rated high severity (CVS
An issue was discovered in CMS Made Simple 2.2.8. Rated high severity (CVSS 8.8), this vulnerability is remotely exploit
In CMS Made Simple 2.1.6, there is Server-Side Template Injection via the cntnt01detailtemplate parameter. Rated critica
CMS Made Simple version 2.2.5 contains a Remote Code Execution vulnerability in File Manager that can result in Allows a
CMS Made Simple version 1.x Form Builder before version 0.8.1.6 allows remote attackers to execute PHP code via the cntn
CMS Made Simple (CMSMS) through 2.2.6 allows PHP object injection because of an unserialize call in the _get_data functi
CMS Made Simple (CMSMS) through 2.2.6 contains an admin password reset vulnerability because data values are improperly
class.showtime2_image.php in CMS Made Simple (CMSMS) before 2.2.10 does not ensure that a watermark file has a standard
CMS Made Simple (CMSMS) 2.2.7 contains a privilege escalation vulnerability from ordinary user to admin user by arrangin
cmsmadesimple version 2.2.7 contains a Incorrect Access Control vulnerability in the function of send_recovery_email in
CMS Made Simple (CMSMS) through 2.2.6 contains a privilege escalation vulnerability from ordinary user to admin user by
CMS Made Simple (aka CMSMS) 2.2.7 has CSRF in admin/moduleinterface.php. Rated high severity (CVSS 8.8), this vulnerabil
EUVD-2026-12366
NVD
CVE.org
EPSS
GitHub
VulDB
Exploit-DB