Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 5.3 score (Medium severity) reflects a network-accessible vulnerability with low attack complexity and no privilege requirements, but limited impact scope (integrity only, no confidentiality or availability loss). However, the CVSS vector alone understates real-world risk: the complete absence of authentication (PR:N) combined with network accessibility (AV:N) makes this readily exploitable by any internet-connected attacker. The integrity impact (I:L) suggests unauthorized content modification, which could damage site reputation, inject malicious content, or serve as a staging point for further attacks. EPSS scoring would likely place this in the moderate-to-high exploitation probability range due to the simplicity of the attack (AC:L) and the prevalence of WordPress installations. The lack of confirmed KEV status and publicly disclosed POC suggests limited active exploitation currently, but the attack surface is wide given the large installed base of WordPress theme/plugin users. Organizations running Preschool and Kindergarten on public-facing WordPress sites should prioritize patching despite the CVSS 5.3 rating, as the vulnerability's low barriers to exploitation outweigh the measured impact score. |
| Exploit ScenarioDerived | An attacker scans a WordPress site running Preschool and Kindergarten 1.2.5 and identifies an unprotected AJAX endpoint or REST API route that modifies page content or settings. The attacker sends a crafted HTTP request (no authentication required, low complexity) directly to this endpoint with parameters to inject malicious JavaScript or alter site configuration. Within seconds, the payload executes on the site, potentially defacing pages, redirecting users, or injecting phishing content. No user interaction is needed; the vulnerability is remotely exploitable and could be automated as part of a mass WordPress compromise campaign targeting theme vulnerabilities. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 13, 2026
Improperly configured access controls in the Preschool and Kindergarten plugin (versions up to 1.2.5) allow unauthenticated attackers to modify content or settings without proper authorization. This missing authorization vulnerability affects websites using the vulnerable plugin and could enable unauthorized data tampering. No security patch is currently available for this vulnerability.
Earlier versions of this analysis (1)
A missing authorization vulnerability exists in raratheme's Preschool and Kindergarten plugin (versions through 1.2.5) that allows unauthenticated attackers to exploit incorrectly configured access control security levels. An attacker can leverage this network-accessible vulnerability without requiring user interaction to modify content, though data confidentiality and availability are not directly impacted. While no active exploitation in the wild has been confirmed via KEV status, the low attack complexity and complete lack of authentication requirements make this a practical threat to WordPress installations running affected versions.
RemediationAI
Immediately upgrade the Preschool and Kindergarten plugin to the patched version released by raratheme (version 1.2.6 or later if available; verify the exact patch version on the official plugin repository or raratheme website). To upgrade, navigate to WordPress Dashboard > Plugins > Preschool and Kindergarten, click Update, and confirm. If no patch is yet available or the theme is no longer maintained, temporarily disable the plugin and switch to a maintained alternative theme until a security update is released. As a interim measure, restrict WordPress admin access via IP whitelisting using a Web Application Firewall or .htaccess rules, enforce strong authentication via a security plugin like Wordfence, and monitor site activity logs for unauthorized content modifications. Ensure WordPress core, all plugins, and themes are kept current with security updates going forward.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability stems from CWE-862 (Missing Authorization), a common WordPress plugin flaw where access control checks are either absent or misconfigured at critical function entry points. The raratheme Preschool and Kindergarten plugin (CPE identifier: cpe:2.3:a:raratheme:preschool_and_kindergarten) fails to validate user capabilities or enforce proper permission checks before processing sensitive operations. This is typical of WordPress security oversights where developers neglect to use functions like current_user_can() or do_action() hooks with proper nonce verification before executing administrative or content-modification functions. The plugin architecture likely exposes AJAX handlers, REST API endpoints, or direct function calls without proper authorization gates, allowing an unauthenticated actor to directly invoke privileged operations.
Know when Preschool And Kindergarten gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
Missing Authorization vulnerability in raratheme Preschool and Kindergarten preschool-and-kindergarten allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Preschool and Kindergarten: from n/a through <= 1.2.5.
Executive ViewAI
CVE-2026-32337 presents moderate security risk, a missing authorization vulnerability rated CVSS 5.3. Attackers could gain access beyond their authorized level. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
EUVD-2026-11816
NVD
CVE.org
EPSS
VulDB
GitHub PoC
Exploit-DB