Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as user with field-display config rights
-
ExploitInject template syntax into Linked Field settings
-
ExecutionTemplate engine evaluates unsanitized payload
-
ImpactExecute injected code server-side
Vulnerability Assessment
| Weakness |
CWE
ASVS 5.0
V1 - Encoding and Sanitization Template injection prevention
|
| Exploitation Conditions | Exploitation requires an authenticated Drupal account whose role can configure the Linked Field module's formatter/display settings (the field-display configuration where template syntax is accepted); this is a trusted administrative-style permission, so it is not a remote-unauthenticated attack against default configurations. Limiting factors: the attacker must already hold this configuration privilege (PR:L), the affected site must run Linked Field at a version below 1.8.0, and the payload executes in the site's server context. The exact configuration field or deployment mode that carries the injectable template input is not described in the available sources. |
| Impact | This is a moderate-priority issue, not an emergency. The vendor CVSS is 5.4 (medium) with vector AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N, meaning network-reachable, low complexity, but requiring an authenticated account (PR:L) and scoring only Low confidentiality/integrity impact with no availability impact. Corroborating signals point to low urgency: EPSS is 0.18% (7th percentile), there is no CISA KEV listing, and no public exploit is referenced. The vuln.today decision label is 'this_month' rather than act_now/emergency, which is consistent with those signals. However, there is a notable tension worth flagging: the vulnerability is Code Injection into a template engine (CWE-1336, SSTI), a class that typically yields server-side code execution with high impact, yet the input CVSS rates impact as only C:L/I:L/A:N. This likely reflects that exploitation is gated behind a trusted configuration privilege rather than that the technical ceiling is low - so defenders whose Drupal sites grant field-display/configuration permissions to lower-trust roles should treat the real impact as higher than the 5.4 implies. Net: prioritize for patching this month; it is a genuine SSTI but its real-world risk is bounded by the required privilege level and the absence of exploitation evidence. |
| Exploit ScenarioDerived | An authenticated user who holds permission to configure the Linked Field formatter settings enters template-engine syntax into a Linked Field configuration field; because the input is not properly neutralized, the template engine evaluates the attacker's payload server-side, resulting in code injection. No public exploit is referenced, and the exact field/setting that carries the payload is not described in the available sources. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Oct 30, 2026
Server-side template injection in the Drupal contributed module Linked Field (versions 0.0.0 through 1.8.0, fixed in 1.8.0) allows an authenticated user who holds the permission to configure the module's formatter/display settings to supply template syntax that the site then evaluates in its own server context, enabling code injection. This is a moderate-priority issue rather than an emergency: EPSS is 0.18% (7th percentile), there is no CISA KEV entry, and no public exploit has been identified at time of analysis. The vendor has released a patch, and the practical exposure is limited to sites that grant this administrative-style configuration permission to users beyond a small trusted set.
RemediationAI
Upgrade the Linked Field contributed module to version 1.8.0 or later - this is the vendor-released patch and the only complete fix - following the instructions in Drupal SA-CONTRIB-2026-200 (https://www.drupal.org/sa-contrib-2026-200); sites running versions below 1.8.0 should schedule this within the current monthly patch window given the moderate priority assigned to the issue. Because exploitation requires an authenticated account able to configure the module's formatter/display settings, reduce exposure until the update is applied by auditing roles and permissions and restricting that configuration capability to the smallest possible set of trusted administrators, keeping in mind that this narrows the attack surface without removing the underlying injectable behavior. Verify module versions across all environments, including multisite installs where a single codebase may serve several sites, and re-check displayed field configuration for unexpected template syntax after upgrading. No vendor workaround beyond updating is described in the available references.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The flaw is CWE-1336, improper neutralization of special elements used in a template engine - the server-side template injection (SSTI) class. Drupal's field formatter and display configuration pipeline lets a module accept configuration values that are later rendered through a template engine; when the Linked Field module (machine name linked_field) stores such configuration without neutralizing template delimiters, the supplied syntax is compiled/evaluated server-side instead of being treated as inert configuration text. The CPE cpe:2.3:a:drupal:linked_field:*:*:*:*:*:*:*:* confirms the affected code base is the contributed Linked Field module rather than Drupal core. The vendor score is 5.4 (AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N), while the independent assessment raises the vector to AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H on the basis that the required capability - configuring the module's formatter/display settings where template syntax is accepted - is a trusted administrative-style permission and that successful injection runs with the site's server-side privileges. Access is remote over the network and no user interaction is required beyond the privileged configuration action. The specific configuration field or deployment mode that carries the injectable template input is not described in the available sources, so which exact formatter setting is exploitable remains unverified.
Know when Linked Field gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Configuring a Linked Field formatter requires administrative manage-display privilege (PR:H); template-engine code injection yields server-side code execution, so C/I/A:H rather than the input's Low impact.
Primary rating from Vendor (drupal).
CVSS VectorVendor: drupal
Lifecycle Timeline
3DescriptionCVE.org
Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Drupal Linked Field allows Code Injection. This issue affects Linked Field versions: from 0.0.0 to 1.8.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Code injection occurs when an application accepts user input and passes it directly into a language interpreter or evaluator without proper sanitization.
EUVD-2026-113575
GHSA-wp6m-582q-3rfp
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB