Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate as low-privileged subscriber
-
ExploitSubmit crafted unsanitized file path to plugin
-
ExecutionTraverse filesystem to read or delete target file
-
ImpactExfiltrate database credentials or destroy server files
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V5 - File Handling Path canonicalization, traversal prevention
MITRE ATT&CK
2 techniques across 2 tactics: Discovery, Collection The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Requires the 'Automated Import Products to Cart' plugin installed and active at a version below 1.0.4, and an authenticated account with only minimal privileges (subscriber level per the description and PR:L) - practically meaningful on sites where open user registration is enabled. No elevated role, no victim interaction (UI:N), and no special non-default configuration is described beyond the plugin being present. The limiting factors are therefore the need for any valid authenticated session and the plugin's presence; exploitation targets the user-supplied file-path parameter the plugin passes into file read/delete operations without sanitization. |
| Impact | This is a genuine high-priority issue, not an inflated CVSS score. The CVSS 3.1 vector (AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H = 9.9) is internally consistent with the description: a network-reachable, low-complexity path-traversal flaw (CWE-22) requiring only minimal privileges (PR:L, i.e. a subscriber account) with a scope change justified by reading files outside the application boundary such as database credentials. The vuln.today Decision label is act_now, which aligns with the total technical impact (arbitrary file read AND arbitrary file delete). However, the signals are not uniformly alarming: SSVC records Exploitation as none and Automatable as no, there is no CISA KEV listing, and no EPSS score was supplied, so there is no evidence of active or widespread exploitation at this time. A public PoC reference (WPScan) exists but is not verified as working exploit code. In short, the CVSS and SSVC-impact signals point to a severe, easily reached flaw that warrants prompt patching, while the exploitation-maturity signals (SSVC none, no KEV, PoC unverified) indicate it is not yet confirmed to be exploited in the wild. The PR:L requirement and the WordPress-plugin footprint are the main factors tempering real-world risk relative to the raw 9.9. |
| Exploit ScenarioDerived | An attacker who holds or registers a low-privileged WordPress account (e.g. a subscriber) sends a request to the vulnerable plugin endpoint supplying a crafted, unsanitized file path. The plugin uses that path to read or delete files, letting the attacker retrieve wp-config.php database credentials or delete arbitrary server files. A PoC reference published by WPScan exists but is not verified as working exploit code; the flaw is network-reachable with low attack complexity (AV:N/AC:L). |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Oct 29, 2026
Automated Import Products to Cart before 1.0.4 allows authenticated users with only subscriber-level permissions to read arbitrary server files, including files holding database credentials, and to delete arbitrary files. The plugin passes an unsanitized user-supplied file path into file read and delete operations (CWE-22 path traversal), giving a low-privileged account high confidentiality and integrity impact with no victim interaction; CVSS 9.9 and the vuln.today act_now label reflect a genuine high-priority issue. A public PoC reference exists but is not verified as working exploit code, and CISA SSVC records no known exploitation.
RemediationAI
Vendor-released patch: upgrade the Automated Import Products to Cart plugin to version 1.0.4 or later; 1.0.4 is the first fixed release, so versions from 0 up to but not including 1.0.4 are affected. The patch is available from the vendor, and the WPScan advisory at https://wpscan.com/vulnerability/450a5f9e-3b4c-495d-975f-a24a3d458651/ plus the NVD record at https://nvd.nist.gov/vuln/detail/CVE-2026-113617 provide tracking details. The supplied sources do not document a separate workaround; the authoritative fix is updating to 1.0.4 or later.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The affected component is a WordPress plugin, so it operates within WordPress authentication and role handling; the CVSS vector's PR:L means any valid authenticated session, such as a subscriber account, is sufficient, while AV:N and UI:N mean the attack is reachable over the network without tricking a victim into interacting. CWE-22 is the root cause: a user-supplied file path is not sanitized before being used in file-read and file-delete operations, so crafted paths can reach files outside the intended directory, including configuration files that contain database credentials. The supplied CPE is generic, with vendor and product marked unknown and a wildcard version, while EUVD narrows the affected range to the plugin from 0 up to but not including 1.0.4; the exact vulnerable parameter and internal code path are not described in the available sources. The S:C scope change is consistent with impact extending beyond the plugin's own security scope to files on the hosting server.
Know when Automated Import Products To Cart gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Network-reachable with low complexity; PR:L because a subscriber account is required; S:C and C/I/A:H because arbitrary file read (DB credentials) and delete reach beyond the application's security scope.
Primary rating from Vendor (WPScan).
CVSS VectorVendor: WPScan
Lifecycle Timeline
3DescriptionCVE.org
The Automated Import Products to Cart WordPress plugin before 1.0.4 does not sanitize a user-supplied file path before using it to read and delete files, allowing users with minimal permissions, such as subscribers, to read arbitrary files (including ones containing the database credentials) and delete arbitrary files on the server.
Articles & Coverage 1
Technical POC Analysis
Bug class: CWE-22, path traversal.
Full technical POC analysis - root cause, step-by-step exploitation and patch breakdown - is part of the Pro and Business plans.
Executive ViewAI
A critical vulnerability in the WordPress plugin 'Automated Import Products to Cart' (versions before 1.0.4) allows any subscriber-level user to read sensitive server files and delete arbitrary files. This exposes database credentials and risks data loss or service disruption, affecting all sites using the plugin. Leadership should prioritize immediate remediation due to the low attack complexity and potential for significant confidentiality and integrity breaches.
Apply vendor patch.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Path traversal exploits occur when applications use user-controlled input to construct file system paths without proper validation.
EUVD-2026-112627
GHSA-cmrc-7c99-5736
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB