Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A02:2025 - Security Misconfiguration
ASVS 5.0
V13 - Configuration XML external entity prevention
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Collection The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | CVSS score of 8.4 (HIGH). |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 15, 2026
Critical XXE in Apache Tika tika-core (1.13-3.2.1), tika-pdf-module (2.0.0-3.2.1) and tika-parsers (1.13-1.28.5) modules on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF.
This CVE covers the same vulnerability as in CVE-2025-54988. However, this CVE expands the scope of affected packages in two ways.
First, while the entrypoint for the vulnerability was the tika-parser-pdf-module as reported in CVE-2025-54988, the vulnerability and its fix were in tika-core. Users who upgraded the tika-parser-pdf-module but did not upgrade tika-core to >= 3.2.2 would still be vulnerable.
Second, the original report failed to mention that in the 1.x Tika releases, the PDFParser was in the "org.apache.tika:tika-parsers" module.
Earlier versions of this analysis (1)
RemediationAI
Monitor vendor advisories for patches. Apply mitigations such as network segmentation, access restrictions, and monitoring.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 6 packages in maven, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
This vulnerability is classified as Improper Restriction of XML External Entity Reference (CWE-611).
Know when Tika gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
Sources disagree (Medium–Critical)AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
vuln.today treats the vendor’s rating as authoritative. A higher third-party CVSS (e.g. CISA-ADP) is shown for transparency but does not drive the headline severity.
CVSS VectorNVD
Lifecycle Timeline
2Blast Radius
ecosystem impact- 121 maven packages depend on org.apache.tika:tika-core (41 direct, 80 indirect)
- 12 maven packages depend on org.apache.tika:tika-parser-pdf-module (3 direct, 9 indirect)
- 71 maven packages depend on org.apache.tika:tika-parsers (31 direct, 40 indirect)
Ecosystem-wide dependent count for version 1.13 and other introduced versions.
Executive ViewAI
Apache Tika versions 1.13-3.2.1 contain a critical XML External Entity (XXE) injection vulnerability exploitable through crafted PDF files, potentially allowing attackers to read sensitive files or execute denial-of-service attacks. Organizations using affected Tika versions for document processing face immediate risk, as no patch is currently available and the vulnerability impacts multiple module configurations that users may have overlooked during previous remediation attempts.
Disable XFA (XDP) form processing in PDF parsers if supported by your implementation; implement strict file upload validation rejecting PDFs with XFA components; segment document processing systems on isolated networks with no outbound access; deploy WAF rules blocking XML entity declarations and external entity references; apply principle of least privilege to Tika process credentials; consider temporary suspension of untrusted PDF processing until patch availability; monitor for exploitation attempts in Tika process logs and system file access patterns.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
XML External Entity (XXE) attacks exploit XML parsers that process Document Type Definitions (DTDs) without proper restrictions.
From Apache Tika versions 1.7 to 1.17, clients could send carefully crafted headers to tika-server that could be used to
Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms al
An XXE issue in SAXBuilder in JDOM through 2.0.6 allows attackers to cause a denial of service via a crafted HTTP reques
Apache Tika before 1.14 allows Java code execution for serialized objects embedded in MATLAB files. Rated critical sever
A carefully crafted or corrupt zip file can cause an OOM in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. R
Apache Tika before 1.13 does not properly initialize the XML parser or choose handlers, which might allow remote attacke
A carefully crafted package/compressed file that, when unzipped/uncompressed yields the same file (a quine), causes a St
In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. Rated high severity (CVSS 7.5)
In Apache Tika 0.1 to 1.18, the XML parsers were not configured to limit entity expansion. Rated high severity (CVSS 7.5
The /unpack endpoint in Apache Tika's server component (tika-server 4.0.0-alpha-1) fails to enforce the operator-configu
In Apache Tika 1.19 to 1.21, a carefully crafted 2003ml or 2006ml file could consume all available SAXParsers in the poo
A carefully crafted or corrupt sqlite file can cause an infinite loop in Apache Tika's SQLite3Parser in versions 1.8-1.1
Vendor StatusVendor
Ubuntu
Priority: Medium| Release | Status | Version |
|---|---|---|
| xenial | needs-triage | - |
| bionic | needs-triage | - |
| focal | needs-triage | - |
| jammy | needs-triage | - |
| noble | needs-triage | - |
| questing | needs-triage | - |
| upstream | needs-triage | - |
| plucky | ignored | end of life, was needs-triage |
Debian
Bug #1121954| Release | Status | Fixed Version | Urgency |
|---|---|---|---|
| bullseye, sid | vulnerable | 1.22-2 | - |
| bullseye (security) | fixed | 1.22-2+deb11u1 | - |
| bullseye | fixed | 1.22-2+deb11u1 | - |
| (unstable) | fixed | (unfixed) | - |
EUVD-2025-201189
GHSA-f58c-gq56-vjjf
NVD
CVE.org
EPSS
Exploit-DB