Skip to main content

Ai Engine EUVDEUVD-2025-19924

| CVE-2025-6238 HIGH
URL Redirection to Untrusted Site (Open Redirect) (CWE-601)
2025-07-04 security@wordfence.com
8.0
CVSS 3.1 · NVD
View

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V3 - Web Frontend Security Redirect URL validation
MITRE ATT&CK

1 technique across 1 tactic: Initial Access

The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up.

Impact

Phishing attacks using the trusted domain's reputation. Users may be redirected to credential-harvesting pages or malware download sites. With a CVSS score of 8.0 (HIGH), this represents a significant risk.

Exploit ScenarioDerived

An attacker crafts a URL with the trusted domain that redirects the victim to a phishing page designed to steal credentials.

This Week Schedule remediation this week. Why: HIGH severity (CVSS 7.0-8.9).
Patch available 0.1% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Mar 16, 2026

The AI Engine plugin for WordPress is vulnerable to open redirect in version 2.8.4. This is due to an insecure OAuth implementation, as the 'redirect_uri' parameter is missing validation during the authorization flow. This makes it possible for unauthenticated attackers to intercept the authorization code and obtain an access token by redirecting the user to an attacker-controlled URI. Note: OAuth is disabled, the 'Meow_MWAI_Labs_OAuth' class is not loaded in the plugin in the patched version 2.8.5.

Earlier versions of this analysis (1)
v1 Mar 16, 2026 - 02:42 CVSS 8.0

RemediationAI

A vendor patch is available — apply it immediately. Validate redirect URLs against a whitelist of allowed destinations. Use relative URLs for redirects. Warn users before redirecting to external sites.

Affected VersionsENISA

AI Engine 2.8.4

Affected Packages

euvd ai_engine no fix

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in euvd

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

An open redirect vulnerability allows attackers to redirect users from a trusted domain to an arbitrary external URL through manipulation of redirect parameters. This vulnerability is classified as URL Redirection to Untrusted Site (Open Redirect) (CWE-601).

Know when Ai Engine gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

NVD PRIMARY 8.0 HIGH
AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Primary rating from NVD · only source for this CVE.

CVSS VectorNVD

Attack Vector
Network
Attack Complexity
Low
Privileges Required
Low
User Interaction
Required
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Lifecycle Timeline

2
Patch released
Mar 16, 2026 - 02:42 nvd
Patch available
CVE Published
Jul 04, 2025 - 03:15 nvd
HIGH 8.0

Executive ViewAI

Why It Matters

Organizations using for WordPress is vulnerable to open redirect in face notable risk from CVE-2025-6238 rated CVSS 8.0. Successful exploitation could significantly impact the confidentiality, integrity, or availability of affected systems. A patch is available and should be applied as part of regular vulnerability management.

Business Impact: High
Compensating Controls

Apply vendor patch. If immediate patching is not feasible: (1) Implement network-level access controls to limit exposure; (2) Enable enhanced monitoring and alerting; (3) Apply principle of least privilege.

Threat Intelligence Overview

EPSS Score
0.1%
Top 74% exploitable
Data Quality
4 sources
Confidence: Medium

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity HIGH
CISA KEV No
Public POC No
EPSS 0.1%
Patch available Yes
Active threat No
Deciding rule
HIGH severity (CVSS 7.0-8.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Scheduled
Exploitation· derived
None
System Exposure· derived
Open
Automatable· derived
No
Human Impact
High

Priority Score

40
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +40
PoC: 0
Weaponized: 0
Threat intel: 0
Gov advisory: 0
CVE-2023-51409 CRITICAL POC
10.0 Apr 12

Unrestricted file upload in Jordy Meow's AI Engine: ChatGPT Chatbot plugin for WordPress (versions up to and including 1

CVE-2026-12511 HIGH POC
8.1 Jul 14

Arbitrary file write in the AI Engine WordPress plugin before 3.5.5 lets authenticated editor-level users abuse an unsan

CVE-2026-75797 HIGH POC
7.7 Aug 26

Path traversal in the AI Engine WordPress plugin (versions 3.3.3 through 3.7.1) allows arbitrary server file reads with

CVE-2026-75796 HIGH POC
7.2 Aug 21

Privilege escalation in the AI Engine WordPress plugin (versions 2.8.0 through 3.6.0) enables any sub-site Administrator

CVE-2024-10499 HIGH POC
7.2 Dec 12

The AI Engine WordPress plugin before 2.6.5 does not sanitize and escape a parameter from one of its RESP API endpoint b

CVE-2024-6451 HIGH POC
7.2 Aug 19

AI Engine < 2.4.3 is susceptible to remote-code-execution (RCE) via Log Poisoning. Rated high severity (CVSS 7.2), this

CVE-2024-29090 MEDIUM POC
6.8 Mar 28

Server-Side Request Forgery (SSRF) vulnerability in Jordy Meow AI Engine: ChatGPT Chatbot.1.4. Rated medium severity (CV

CVE-2026-16954 MEDIUM POC
6.5 Aug 06

Cleartext exposure of third-party API keys and authentication tokens in AI Engine WordPress plugin (before 3.6.4) allows

CVE-2026-12510 MEDIUM POC
5.9 Jul 16

Unauthorized access to private chatbot conversations in the AI Engine WordPress plugin before 3.5.5 allows any authentic

CVE-2026-75798 MEDIUM POC
5.3 Aug 26

Unauthenticated remote attackers can invoke AI queries against a site owner's configured provider account through the AI

CVE-2024-34440 CRITICAL
9.1 May 14

Unrestricted Upload of File with Dangerous Type vulnerability in Jordy Meow AI Engine: ChatGPT Chatbot.2.63. Rated criti

CVE-2024-29100 CRITICAL
9.1 Mar 28

Unrestricted Upload of File with Dangerous Type vulnerability in Jordy Meow AI Engine: ChatGPT Chatbot.1.4. Rated critic

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy