Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V5 - File Handling Path canonicalization, traversal prevention
MITRE ATT&CK
2 techniques across 2 tactics: Discovery, Collection The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | The CVSS 3.1 vector (AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H) indicates high real-world risk: the attack is network-accessible, requires no authentication or user interaction, and has low complexity. While confidentiality and integrity impacts are absent (C:N/I:N), the high availability impact (A:H) combined with scope change (S:C) suggests the vulnerability can impact system availability beyond the vulnerable component. The absence of reported EPSS data or KEV/CISA ICS-CERT status from the provided information prevents full exploitation probability assessment, but the straightforward nature of path traversal attacks and lack of authentication requirements suggest this has moderate-to-high exploitability. The vulnerability warrants immediate patching despite the absence of active exploitation signals, as path traversal is a well-understood attack vector with readily available exploitation techniques. |
| Exploit ScenarioDerived | An unauthenticated attacker sends a crafted HTTP request to a WP Pipes plugin endpoint (e.g., |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 14, 2026
Path traversal vulnerability in ThimPress WP Pipes that allows unauthenticated remote attackers to access files outside restricted directories, potentially causing denial of service or information disclosure. Versions through 1.4.2 are affected. The vulnerability has a high CVSS score of 8.6 due to network accessibility and no authentication requirements, though the impact is limited to availability rather than confidentiality or integrity.
RemediationAI
Patching: Update WP Pipes to a version later than 1.4.2 when available. Monitor ThimPress official channels and WordPress.org plugin repository for security updates.; priority: Critical Interim Mitigation: If patching is delayed: disable WP Pipes plugin or restrict access via WordPress security plugins, WAF rules, or web server configuration (e.g., .htaccess or nginx rules blocking path traversal patterns in plugin URLs).; priority: High Web Application Firewall (WAF): Deploy rules to detect and block requests containing path traversal sequences ('../', '..\', encoded variants like '%2e%2e%2f') targeting the WP Pipes plugin endpoints.; priority: High File System Hardening: Apply principle of least privilege: ensure WordPress application user has minimal required file system permissions; restrict access to sensitive directories outside WordPress root.; priority: Medium Monitoring: Log and alert on suspicious file access patterns from the WordPress process; monitor plugin update channels for patch release announcements.; priority: Medium
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
This vulnerability exploits improper input validation in the WP Pipes WordPress plugin (CPE: wp:thimpress:wp-pipes), which fails to properly sanitize and validate file path parameters before using them in file operations. The root cause is classified under CWE-22 (Path Traversal / Directory Traversal), a common weakness where user-supplied input containing path traversal sequences (e.g., '../', '..\') is not adequately restricted to intended directories. The plugin likely constructs file paths by directly concatenating user input without canonicalization or boundary validation, allowing attackers to navigate the filesystem hierarchy and access sensitive files or trigger denial of service conditions.
Know when Wp Pipes gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in ThimPress WP Pipes allows Path Traversal. This issue affects WP Pipes: from n/a through 1.4.2.
Executive ViewAI
A path traversal vulnerability in ThimPress WP Pipes (versions through 1.4.2) allows attackers to access unauthorized files on affected WordPress installations, potentially exposing sensitive data such as configuration files, databases, and user information. Organizations using this plugin face immediate risk of data breach and system compromise, with no vendor patch currently available to remediate the threat.
- Disable WP Pipes plugin immediately until patch availability. 2) Deploy WAF rules blocking path traversal sequences (../, ..\, percent-encoded variants). 3) Implement file system access controls restricting web server permissions to necessary directories only. 4) Enable Web Application Firewall/IPS with path traversal detection signatures. 5) Monitor and log all file access attempts to sensitive configuration and database directories. 6) Implement strict input validation at the WordPress level. 7) Consider isolating affected WordPress instances from production environment until remediation is available.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Path traversal exploits occur when applications use user-controlled input to construct file system paths without proper validation.
SQL injection in WP Pipes WordPress plugin versions through 1.4.3 enables unauthenticated remote attackers to extract se
Arbitrary file deletion in ThimPress WP Pipes plugin for WordPress (up to version 1.4.3) allows unauthenticated attacker
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ThimPress WP Pipes
Cross-Site Request Forgery (CSRF) vulnerability in ThimPress WP Pipes plugin <= 1.4.0 versions. Rated medium severity (C
The WP Pipes plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘x1’ parameter in all versions
Server-Side Request Forgery (SSRF) vulnerability in ThimPress WP Pipes allows Server Side Request Forgery.4.2. Rated med
EUVD-2025-17537
NVD
CVE.org
EPSS
GitHub PoC
Exploit-DB