Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessCompromise or obtain admin credentials
-
DeliveryAuthenticate to LibreNMS admin session
-
ExploitPUT malicious HTML payload to graph_descr setting via settings API
-
ExecutionVictim authenticated user views affected graph type page
-
PersistBrowser renders stored XSS payload
-
ImpactAttacker captures victim session token or performs action as victim
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an active administrator-level session in LibreNMS with write access to the |
| Impact | The CVSS 3.1 vector confirmed by the GHSA advisory - AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - scores 4.8 Medium, accurately reflecting the high privilege prerequisite (PR:H) and required victim interaction (UI:R) that substantially bound real-world risk. The CVSS 4.0 vector (SC:L/SI:L/SA:N) corroborates limited downstream impact. No EPSS score was supplied in the input data, and this CVE does not appear in CISA KEV, providing no confirmed signal of active exploitation. However, the GHSA advisory includes a working PoC with exact API calls, which lowers the skill bar for abuse. The scope change (S:C in CVSS 3.1) is the key risk amplifier: a single admin-account compromise or insider threat can silently implant a persistent payload that harvests sessions from all other authenticated users. The realistic threat model is therefore a compromised admin pivoting laterally - not an external unauthenticated attacker - meaning organizations with strong admin-account controls face materially lower risk than those without MFA or privileged access management on their LibreNMS instances. |
| Exploit ScenarioDerived | An attacker who holds or has stolen an admin session issues a PUT request to |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 01, 2026
Stored cross-site scripting in LibreNMS 26.4.0 and below allows an authenticated administrator to inject arbitrary HTML/JavaScript into graph description configuration keys, which then execute in the browsers of every authenticated user who views the affected graph type. The vulnerable sink is includes/html/pages/graphs.inc.php:194, where LibrenmsConfig::get() output is echoed without htmlspecialchars(). A public proof-of-concept is documented in the GHSA advisory; no active exploitation is confirmed via CISA KEV. The vendor released a fix in version 26.7.0.
RemediationAI
Upgrade LibreNMS to version 26.7.0, which applies htmlspecialchars(..., ENT_QUOTES, 'UTF-8') to the graph description output at includes/html/pages/graphs.inc.php:194, eliminating the unescaped echo. This fix is confirmed by the vendor GHSA advisory at https://github.com/librenms/librenms/security/advisories/GHSA-7cj5-v4pp-v632. If immediate upgrade is not operationally feasible, restrict write access to the graph_descr.* settings API keys to the smallest possible set of trusted administrator accounts and enforce MFA on all admin sessions - accepting that this does not prevent a rogue or compromised admin from exploiting the flaw, only reducing the attacker pool. Enable audit logging of configuration changes to detect unauthorized modifications to graph description settings as a detective compensating control.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
LibreNMS is a PHP-based network monitoring platform. The flaw is a textbook CWE-79 (Improper Neutralization of Input During Web Page Generation) instance: at line 194 of includes/html/pages/graphs.inc.php, the application executes echo LibrenmsConfig::get('graph_descr.' . $vars['type']) without passing the value through htmlspecialchars() or any equivalent output encoder. The graph_descr.<graphtype> family of settings is writable by admin users via the settings API (PUT endpoint), meaning attacker-controlled data enters persistent storage and is later reflected into every authenticated user's HTML page for that graph type. The CPE cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:* covers all versions up to and including 26.4.0.
Know when Librenms gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
Admin write access required (PR:H), victim must load the page (UI:R), payload crosses into victim browser session (S:C); no availability impact warranted.
Primary rating from Vendor (VulnCheck).
CVSS VectorVendor: VulnCheck
Lifecycle Timeline
1DescriptionCVE.org
LibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr.<graphtype> configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any authenticated user who views the affected graph type. The issue is fixed in version 26.7.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
An issue was discovered in LibreNMS through 1.47. Rated high severity (CVSS 7.2), this vulnerability is remotely exploit
Librenms 21.11.0 is affected by a path manipulation vulnerability in includes/html/pages/device/showconfig.inc.php. Rate
An issue was discovered in LibreNMS through 1.47. Rated critical severity (CVSS 9.8), this vulnerability is remotely exp
Authentication bypass in the LibreNMS REST API (all versions before 26.8.0) lets unauthenticated remote attackers reach
SQL injection in LibreNMS 25.12.0 and below. PoC and patch available.
An issue was discovered in LibreNMS through 1.47. Rated critical severity (CVSS 9.1), this vulnerability is remotely exp
SQL injection in LibreNMS versions 25.12.0 and below allows authenticated users to extract sensitive database informatio
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Rated high severity (CVSS 8.8), this vulnera
An issue was discovered in LibreNMS before 1.65.1. Rated high severity (CVSS 8.8), this vulnerability is remotely exploi
An issue was discovered in LibreNMS 1.50.1. Rated high severity (CVSS 8.8), this vulnerability is remotely exploitable,
An issue was discovered in LibreNMS through 1.47. Rated high severity (CVSS 8.8), this vulnerability is remotely exploit
Command injection in LibreNMS's Virtualization Discovery module enables authenticated administrator-level users to execu
EUVD-2026-69025
GHSA-pvwj-jwv3-68ww
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB