aandrew-me tgpt CVE-2026-8210
LOWAttack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAuthenticate to system locally
-
DeliveryInvoke tgpt update function
-
ExploitSupply command injection payload in input
-
ExecutionHelper.Update executes unsanitized input
-
PersistArbitrary command executes with user privileges
-
ImpactAttacker achieves code execution
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Input neutralization, injection prevention
|
| Exploitation Conditions | Local authenticated user access to the system running aandrew-me tgpt is required. The attacker must have a valid user account on the Linux or macOS machine and must be able to invoke or trigger the Update Handler function in helper.go through the application's interface or API. No special configuration or non-default settings are mentioned in the vulnerability description; the vulnerability exists in the default code path of the Update Handler. Exploitation is blocked only by the requirement for local file system access and user authentication; network-based remote exploitation is not possible due to the local-only attack vector. The vulnerability does not cross privilege boundaries (scope not changed, SC:N), meaning the attacker's capabilities are limited to what their own user context permits, though this still enables command injection within that context. |
| Impact | Despite the CVSS v4.0 score of 1.9, which appears extremely low, several factors warrant closer evaluation. The attack vector is local (AV:L) with low complexity (AC:L), requiring low privilege (PR:L) and no user interaction (UI:N), making exploitation straightforward for any authenticated local user. However, the confidentiality, integrity, and availability impacts are all marked as low (VC:L, VI:L, VA:L), and scope is not crossed (SC:N). The CVSS impact is intentionally constrained, likely because the vulnerability requires local access and affects only the current user's context. The exploitation proof-of-concept status (E:P) indicates public availability. Real-world risk is contextual: in shared hosting, containers, or multi-tenant environments where local user accounts exist, this becomes a privilege escalation or lateral movement vector. In single-user or tightly controlled deployments, risk is minimal. The vendor's non-response to early disclosure is a significant concern for patch availability and indicates this may remain unpatched in upstream for an extended period. The low CVSS score should not lead to dismissal; organizations with multi-user systems running tgpt should prioritize mitigation despite the numerical rating. |
| Exploit ScenarioDerived | An authenticated local user on a Linux or macOS system running aandrew-me tgpt invokes or triggers the update function through the application's interface. The attacker crafts input containing shell metacharacters (e.g., semicolons, pipes, command substitution syntax) that are not properly sanitized by the helper.Update function. The malicious payload is passed directly to a system command execution call, allowing the attacker to execute arbitrary commands with the privileges of the user running tgpt. The attacker gains the ability to read files, modify configurations, or escalate privileges depending on the tgpt process permissions. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – May 09, 2026
Command injection in aandrew-me tgpt up to version 2.11.1 allows local authenticated attackers to execute arbitrary commands via the helper.Update function in helper.go. The vulnerability requires local file system access and an authenticated user context but results in only limited confidentiality impact. Public exploit code exists, though the vendor has not responded to early disclosure attempts, leaving affected users without an official patch.
RemediationAI
No vendor-released patch identified at time of analysis, as the vendor did not respond to early disclosure. Users should immediately upgrade to a version beyond 2.11.1 if available from the repository, or verify with the upstream project whether a patch has been released post-disclosure. As a compensating control, restrict local user access on systems running tgpt by applying principle of least privilege: disable unnecessary local user accounts, use Unix file permissions to restrict execution of tgpt update functions to trusted administrators only (chmod 700 on tgpt binary and helper.go source/compiled artifacts), and monitor process execution logs for suspicious command invocations originating from the helper.Update function. For environments where tgpt is containerized, run containers in read-only mode and with restricted capabilities (CAP_SYS_ADMIN denied) to limit command injection impact. These controls reduce but do not eliminate risk; they are temporary until an official patch becomes available. If tgpt update functionality is not required, consider disabling or removing the Update Handler entirely.
Affected ProductsAI
aandrew-me tgpt versions up to and including 2.11.1 on Linux and macOS platforms. The vulnerability affects the Update Handler component (helper.go file) and is present in all versions through 2.11.1. No CPE string is provided in available references; affected systems are identified by product name and version range only.
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The aandrew-me tgpt application contains a command injection flaw (CWE-74) in the Update Handler component, specifically within the helper.Update function in helper.go. This indicates unsafe construction or execution of system commands, likely through string concatenation or inadequate input sanitization of user-supplied data passed to shell execution functions. The vulnerability is classified as an improper neutralization of special elements (CWE-74), meaning user input is not properly escaped or validated before being passed to command execution APIs on Linux and macOS platforms.
Know when the next one hits your stack
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
Primary rating from Vendor (vuldb) · only source for this CVE.
CVSS VectorVendor: vuldb
DescriptionCVE.org
A security vulnerability has been detected in aandrew-me tgpt up to 2.11.1 on Linux/macOS. Affected by this vulnerability is the function helper.Update of the file helper.go of the component Update Handler. The manipulation leads to command injection. Local access is required to approach this attack. The exploit has been disclosed publicly and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
OS command injection occurs when an application passes unsanitized user input directly into system shell commands.
NVD
CVE.org
EPSS
Vulnrichment
VulDB
GitHub PoC
Exploit-DB