Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessSelf-register low-privilege booking account
-
DeliveryAuthenticate to WordPress site
-
ExploitSend crafted request to unprotected plugin endpoint
-
ExecutionTrigger incorrect role/privilege assignment
-
PersistObtain administrator-level WordPress access
-
ImpactFull site compromise
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V8 - Authorization Privilege assignment review
|
| Exploitation Conditions | Requires an authenticated low-privileged WordPress account (PR:L) - typically a subscriber or booking-customer role - on a site running Booking Hub ≤1.3.1. Sites with open user registration are most exposed because attackers can self-register with no prior relationship to the site. Sites with closed registration (admin-only account creation) reduce real-world risk significantly, as the attacker must already possess or compromise a valid low-privilege credential. No special plugin configuration is specified in available data beyond having the plugin active. Exploitation is network-accessible (AV:N) with no user interaction required (UI:N). |
| Impact | The CVSS 8.8 vector (AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H) signals a high-severity, network-exploitable flaw requiring only a low-privilege account and no user interaction - but not entirely unauthenticated. The PR:L gate means sites with closed registration face meaningfully lower risk than those allowing public self-registration (a common configuration for booking plugins, where customers create accounts to manage reservations). Attack complexity is low, suggesting no chaining or special conditions beyond account possession. No KEV listing and no explicit POC reference in available data, reducing urgency relative to actively exploited issues. EPSS data is absent from provided intelligence. Real-world risk is highest for public-facing booking sites where visitor self-registration is enabled, as attackers can trivially acquire the required low-privilege foothold. For sites with closed or invite-only registration, the practical attack surface is substantially narrowed. |
| Exploit ScenarioDerived | An attacker visits a public booking site, self-registers a customer account, then issues a crafted HTTP request to a plugin endpoint lacking proper capability checks, assigning their account the WordPress administrator role. With administrator access, they can install backdoored plugins, exfiltrate site data, or fully compromise the hosting environment. No public POC has been identified in available data, but the low attack complexity suggests the technique is straightforward once the vulnerable endpoint is identified. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 02, 2026
Privilege escalation in the LiquidThemes Booking Hub WordPress plugin (≤1.3.1) allows authenticated low-privileged users to incorrectly assign themselves or others elevated WordPress roles, up to and including administrator. The flaw stems from CWE-266 (Incorrect Privilege Assignment) - the plugin fails to enforce proper capability checks before processing role or privilege assignment operations. CVSS 8.8 (PR:L) confirms exploitation requires an existing low-privilege account; no public exploit code or CISA KEV listing identified at time of analysis.
RemediationAI
The primary remediation is to update the Booking Hub plugin beyond version 1.3.1; consult the Patchstack advisory at https://patchstack.com/database/wordpress/plugin/booking-hub/vulnerability/wordpress-booking-hub-plugin-1-3-1-privilege-escalation-vulnerability and the WordPress plugin repository for the specific patched release version - the exact fix version is not independently confirmed from available data. If a patched version is not yet available, disable open user registration under WordPress Settings > General to eliminate the low-privilege account acquisition pathway, accepting the trade-off that legitimate customers will be unable to self-register. Alternatively, consider temporarily deactivating the Booking Hub plugin if the escalation surface is exposed to untrusted users. Site administrators should audit existing user accounts for unexpected role assignments that may indicate prior exploitation.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Booking Hub is a WordPress plugin developed by LiquidThemes for managing appointment and service bookings (CPE: cpe:2.3:a:liquidthemes:booking_hub:*:*:*:*:*:*:*:*). CWE-266 (Incorrect Privilege Assignment) describes a class of flaws where software assigns a privilege, role, or capability to a principal (user account) that exceeds what is warranted - typically due to missing or improperly scoped WordPress capability checks (e.g., current_user_can()) on AJAX handlers, REST API endpoints, or form submission logic. In the WordPress ecosystem, such flaws commonly allow subscribers or booking customers to modify their own user_meta roles or invoke privileged administrative functions without the plugin verifying the caller's actual authority.
Know when Booking Hub gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Network-reachable WordPress plugin requiring only a low-privilege account; no interaction needed; full CIA impact upon successful role escalation to administrator.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Incorrect Privilege Assignment vulnerability in LiquidThemes Booking Hub allows Privilege Escalation.
This issue affects Booking Hub: from n/a through 1.3.1.
Executive ViewAI
LiquidThemes Booking Hub WordPress plugin version 1.3.1 and earlier contains a privilege escalation vulnerability allowing any authenticated low-privilege user to grant themselves full administrator access. WordPress site administrators running this plugin face complete site compromise, including data theft, unauthorized modifications, and malware injection. Immediate plugin removal or upgrade is required.
No vendor-released patch identified at time of analysis. Disable or uninstall the LiquidThemes Booking Hub plugin immediately if not actively required; restrict creation of low-privilege user accounts where feasible; implement strict monitoring and alerting on admin role assignments; and audit all administrator accounts for unauthorized modifications. Apply vendor patch immediately upon release.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
EUVD-2026-69927
GHSA-9983-3rrh-45m6
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB