Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessLog in as Contributor
-
DeliveryCreate/edit BetterDocs page with XSS payload
-
ExploitAdmin views the page
-
ExecutionScript executes in admin's browser
-
PersistSteal admin session cookie
-
ImpactImpersonate admin
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization Output encoding, context-aware escaping
MITRE ATT&CK
2 techniques across 2 tactics: Initial Access, Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | The attacker must have at least Contributor role in the WordPress site (authenticated, low privileges). The crafted content must be visited by a user with higher privileges, typically an administrator (user interaction required). No special configuration is necessary; the vulnerability exists in default BetterDocs installations. The attack is limited by the requirement for existing Contributor accounts and the need for an admin to view the injected content. |
| Impact | The CVSS base score of 6.5 (Medium) reflects the need for authenticated Contributor access and user interaction (admin must view the crafted content). The attack vector is network-accessible, and exploitation is automatable via crafted content. However, no public exploit code or active exploitation has been identified (no KEV listing, no POC mentioned). The EPSS score is not provided, but given the need for authenticated access and user interaction, the real-world risk is moderate. The vulnerability is scoped to impact confidentiality, integrity, and availability at a low level. It is not a high-priority threat unless the site allows Contributor registration and has active low-privilege contributors. |
| Exploit ScenarioDerived | A malicious user with Contributor-level access creates or edits a documentation page in BetterDocs and inserts a malicious script tag. When an administrator visits the page to review or approve it, the script executes, exfiltrating the administrator's session cookies to an attacker-controlled server. No public exploit code has been reported. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 27, 2026
Stored Cross-Site Scripting (XSS) in the BetterDocs WordPress plugin version 4.6.2 and earlier allows authenticated users with Contributor-level access to inject arbitrary web scripts. When an administrator views the crafted content, the script executes in their session, potentially leading to session hijacking or content manipulation. No active exploitation has been publicly reported.
RemediationAI
Update the BetterDocs plugin to version 4.6.3 or later, which contains the fix from the vendor. As a general mitigation, restrict user roles to limit Contributor access to trusted users only, and consider using a security plugin that adds a Content Security Policy (CSP) to mitigate XSS impact. The patch is available from the WordPress plugin repository and the vendor advisory linked above. No workarounds other than updating or disabling the plugin are known.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The vulnerability is a stored (persistent) cross-site scripting issue (CWE-79) within the BetterDocs plugin, a WordPress plugin for creating documentation and knowledge bases. According to the CPE data (cpe:2.3:a:wpdeveloper:betterdocs:*:*:*:*:*:*:*:*), all versions up to 4.6.2 are affected. The root cause is improper neutralization of user-supplied input when Contributor-level users create or edit documentation, allowing malicious HTML/JavaScript to be saved and later executed in the context of an administrator's browser. The CVSS vector (AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L) confirms low attack complexity, required low privileges, and user interaction (admin viewing).
Know when Betterdocs gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Contributor privileges required (PR:L), user interaction (UI:R), scope change (S:C), low impacts.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Contributor Cross Site Scripting (XSS) in BetterDocs <= 4.6.2 versions.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Cross-Site Scripting occurs when an application accepts untrusted data and sends it to a web browser without proper validation or encoding.
More in Betterdocs
View allDeserialization of Untrusted Data vulnerability in WPDeveloper BetterDocs.3.3. Rated critical severity (CVSS 9.0), this
Stored cross-site scripting via prompt injection in the BetterDocs WordPress plugin (versions 4.0.0 through 4.5.5) allow
Unauthenticated remote code execution in BetterDocs Pro for WordPress (versions through 3.8.0) is achievable by abusing
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in WPDeveloper BetterDocs a
Unauthenticated SQL injection in BetterDocs Pro for WordPress allows remote attackers to extract sensitive database cont
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in WPDeveloper
Sensitive system information in the BetterDocs WordPress knowledge base plugin (WPDeveloper, all versions through 4.3.10
Missing Authorization vulnerability in WPDeveloper BetterDocs betterdocs allows Exploiting Incorrectly Configured Access
EUVD-2026-49235
GHSA-wcv4-ppqq-x345
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB