Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V5 - File Handling Path canonicalization, traversal prevention
MITRE ATT&CK
2 techniques across 2 tactics: Discovery, Collection The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jun 30, 2026
Local privilege escalation to root in LinuxCNC (linuxcnc-uspace) before 2.9.9 lets any unprivileged local user execute arbitrary code as root. The SUID-root rtapi_app helper accepts a user-supplied module name and passes it to dlopen() without sufficient validation, so path traversal lets an attacker load an arbitrary attacker-controlled shared library while the process is still privileged. No public exploit identified at time of analysis and the issue is not in CISA KEV; an upstream fix is available in version 2.9.9.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Know when Linuxcnc gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Primary rating from Vendor (mitre) · only source for this CVE.
CVSS VectorVendor: mitre
Lifecycle Timeline
2DescriptionCVE.org
rtapi_app in linuxcnc-uspace in LinuxCNC before 2.9.9 allows privilege escalation. It is installed SUID root and loads shared library modules via dlopen() by using a user-supplied module name. Insufficient validation of the module name allows path traversal, enabling an unprivileged local user to load an arbitrary shared library. Because the process retains elevated privileges during module loading, this results in local privilege escalation to root.
Executive ViewAI
LinuxCNC (uspace) versions before 2.9.9 contain a local privilege escalation vulnerability enabling any unprivileged user to execute code as root; no public exploit identified at time of analysis. Organizations operating Linux-based CNC equipment face risk of complete system compromise through internal user access. Immediate patching is required to secure manufacturing control systems.
Within 24 hours: inventory all systems running linuxcnc-uspace prior to version 2.9.9; restrict local shell access to trusted personnel only. Within 7 days: upgrade linuxcnc-uspace to version 2.9.9 on development and staging environments; validate system functionality before production release. Within 30 days: deploy version 2.9.9 across all production systems; confirm no instances remain below the patched version.
Apply vendor patch: upgrade linuxcnc-uspace to version 2.9.9 or later. Until deployment, restrict local system access to authenticated administrators and implement monitoring for privilege escalation attempts.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
Path traversal exploits occur when applications use user-controlled input to construct file system paths without proper validation.
Same weakness CWE-22 – Path Traversal
View allSame technique Privilege Escalation
View allVendor StatusVendor
Debian
Bug #1140943| Release | Status | Fixed Version | Urgency |
|---|---|---|---|
| bookworm | vulnerable | 2.9.0~pre1+git20230208.f1270d6ed7-1+deb12u1 | - |
| trixie | vulnerable | 1:2.9.4-2 | - |
| sid | fixed | 1:2.9.9-2 | - |
| (unstable) | fixed | 1:2.9.9-1 | - |
EUVD-2026-40241
GHSA-h3vh-9phr-5gjm
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB