Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain low-privileged account
-
ExploitSend crafted authenticated request
-
ExecutionReach action missing capability check
-
ImpactTamper data / disrupt availability
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an authenticated WordPress account of at least low privilege (CVSS PR:L) on a site running ThemeHunk Open Shop version 1.7.1 or earlier; no user interaction and no elevated/admin role is needed. The limiting factors are the need for a valid account - most impactful on stores that permit open customer/subscriber self-registration - and that the site must run the vulnerable theme version. The exact triggering feature (the specific AJAX/REST/admin-post action missing the authorization check) is not detailed in the available data and should be confirmed against the Patchstack advisory. |
| Impact | The CVSS 3.1 vector (AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H) describes a network-reachable, low-complexity issue requiring some authentication (PR:L) and no user interaction, with no confidentiality impact, limited integrity impact, and high availability impact - consistent with an authorization gap that lets a low-privileged account disrupt or alter site state rather than read secrets. Real-world priority is moderate: the PR:L requirement means an attacker needs a valid account (e.g. subscriber/customer on an open-registration store), which meaningfully limits mass exploitation. No EPSS score, KEV listing, or POC was provided, so there is no evidence of active or automated exploitation; the score is driven largely by the A:H rating. This looks like a genuine but not emergency-tier issue - patch on a normal cycle unless the site allows open user registration, which raises exposure. |
| Exploit ScenarioDerived | An attacker registers or obtains a low-privileged WordPress account on a site running Open Shop <= 1.7.1, then sends a crafted authenticated request to the theme action that lacks a capability check, invoking privileged functionality. Because integrity and availability are impacted, this can be used to alter site/store data or push the site into a broken or unavailable state. No public POC was provided. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Jul 13, 2026
Broken access control in the ThemeHunk Open Shop WordPress theme (versions up to and including 1.7.1) lets an authenticated low-privileged user reach functionality that should be restricted, tampering with data and degrading site availability. Reported by Patchstack and rated CVSS 7.1, the flaw stems from missing authorization checks on a privileged action. No public exploit identified at time of analysis and it is not listed in CISA KEV.
RemediationAI
No vendor-released patch version was identified at time of analysis; the input does not name a fixed release. Monitor the ThemeHunk changelog and the Patchstack advisory (https://patchstack.com/database/Wordpress/Theme/open-shop/vulnerability/wordpress-open-shop-theme-1-7-1-broken-access-control-vulnerability?_s_id=cve) and upgrade to the first release above 1.7.1 as soon as it is published. As compensating controls until a patch is applied, disable open user self-registration (Settings > General > 'Anyone can register') to eliminate the low-privileged account prerequisite - trade-off: blocks legitimate customer sign-ups on storefronts; deploy a WAF/virtual-patch rule (Patchstack provides one) to block the vulnerable action; and audit and remove untrusted low-privilege accounts. Where the theme is not essential, switching to a maintained theme removes the exposure entirely.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The affected component is the Open Shop e-commerce/storefront theme published by ThemeHunk for the WordPress platform (CPE cpe:2.3:a:themehunk:open_shop:*:*:*:*:*:*:*:*). The root cause is CWE-862 (Missing Authorization): a server-side action or endpoint fails to verify that the caller holds the required capability/role before executing, an example of 'Incorrectly Configured Access Control Security Levels'. In WordPress themes this class of bug typically appears in AJAX handlers, REST routes, or admin-post actions that check that a user is logged in (nonce present) but never confirm the user's capability, so any authenticated account can invoke operator-level functionality.
Know when Open Shop gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H
Network-reachable action needs an authenticated low-privileged account (PR:L) with no interaction; missing authorization yields limited integrity tampering (I:L) and high availability disruption (A:H), no data disclosure (C:N).
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Missing Authorization vulnerability in themehunk Open Shop open-shop allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Open Shop: from n/a through <= 1.7.1.
Executive ViewAI
ThemeHunk Open Shop WordPress theme versions up to 1.7.1 contain a broken access control vulnerability (CVSS 7.1) that allows authenticated low-privilege users to execute restricted administrative actions, potentially tampering with data and degrading site availability. Any organization operating WordPress sites with this theme faces risk of unauthorized data modification and insider privilege escalation. Immediate inventory and mitigation are required to prevent business continuity impacts.
No vendor-released patch identified at time of analysis. Interim mitigations: restrict low-privilege user role capabilities and permissions within WordPress, implement granular role-based access controls to prevent unauthorized administrative function access, enable detailed audit logging and real-time monitoring of sensitive administrative actions, deploy Web Application Firewall rules to block privileged action attempts from non-admin accounts, or migrate to an alternative theme without this vulnerability.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
EUVD-2026-43476
NVD
CVE.org
EPSS
Vulnrichment
GitHub PoC
Exploit-DB