Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V8 - Authorization Least privilege enforcement
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 15, 2026
Privilege escalation in October CMS 3.x and 4.x lets an authenticated backend user who holds CMS markup editing rights break out of the Twig Safe Mode sandbox and impersonate an existing superuser. The bypass chains two weaknesses: the Laravel session store is handed to Twig templates with unrestricted method access, and raw SQL methods (selectRaw, whereRaw, orderByRaw, joinSub) leak through Eloquent's __call forwarding so a template can run arbitrary queries and then overwrite the admin_auth session key. Publicly available exploit code exists, but exploitation requires cms.safe_mode to be explicitly enabled, a deliberately untrusted markup editor account, and a pre-existing superuser whose session can be forged — a combination that October CMS states does not occur in standard production deployments.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Know when PHP gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
Primary rating from Vendor (https://github.com/octobercms/october) · only source for this CVE.
CVSS VectorVendor: https://github.com/octobercms/october
Lifecycle Timeline
2DescriptionCVE.org
A vulnerability was identified in the Twig sandbox security policy that allowed a chained bypass when cms.safe_mode is enabled. The Laravel session store was exposed to Twig with unrestricted method access, and raw SQL methods reachable through Eloquent's __call forwarding were not blocked across the full builder chain. When combined, a backend user with CMS markup editing access could read arbitrary database values via raw SQL expressions and write to the backend authentication session key, forging a backend session as another existing user.
Scope of impact is narrow. Safe Mode is a niche feature, primarily used for demo installations and multi-tenant or shared-editor scenarios where untrusted users are deliberately granted access to the CMS markup editor. Standard production deployments do not enable Safe Mode, because under normal October CMS guidance backend access - including markup editing - is restricted to trusted administrators, and direct PHP injection through markup is already possible without Safe Mode in that configuration.
This issue only affects sites that meet all of the following conditions:
cms.safe_modeis enabled (a deliberate opt-in for demos or untrusted-editor scenarios)- The site has at least one backend user with CMS markup editing access who is not intended to be trusted as a full administrator
- The site has at least one existing superuser account whose session the lower-privileged user can impersonate
Impact
- Arbitrary read access to database tables, including superuser persistence codes from
backend_users, via raw SQL expressions reachable throughEloquent\Model,Eloquent\Builder, or any allowlisted class that__call-forwards to a query builder - Forgery of a backend authentication session by writing to the
admin_authsession key from a Twig template, allowing a markup editor to impersonate an existing superuser - Requires authenticated backend access with CMS markup editing permission AND
cms.safe_modeenabled - Not exploitable when Safe Mode is disabled (direct PHP injection through markup is already possible in that configuration, so Safe Mode is the boundary this issue affects)
Patches
The vulnerability has been patched in v3.7.17 and v4.2.21. The Laravel session store is now wrapped in a proxy that exposes only an explicit subset of read/write methods and rejects writes to reserved session key prefixes (admin_auth, october_auth, login_*, _token, and other framework internals). Raw SQL and subquery methods (selectRaw, whereRaw, orderByRaw, joinSub, and related) are now blocked on Query\Builder, Eloquent\Builder, and Eloquent\Model so the blocklist is consistent across the __call forwarding chain. All sites that enable cms.safe_mode are encouraged to upgrade to the latest patched version.
Workarounds
If upgrading immediately is not possible:
- Restrict CMS markup editing access to fully trusted administrators only - the standard October CMS recommendation for any deployment
- Note that disabling
cms.safe_modeis not a workaround; Safe Mode is the boundary this issue affects, and disabling it removes the only sandbox between markup editors and the server
References
- Reported by r00tn0b0dy
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Privilege escalation occurs when an attacker leverages flaws in access control mechanisms to gain permissions beyond what they were originally granted.
In PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24 and 7.3.x below 7.3.11 in certain configurations of FPM setup it
sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI script (aka php-cgi), does not
(1) boardData102.php, (2) boardData103.php, (3) boardDataJP.php, (4) boardDataNA.php, and (5) boardDataWW.php in Netgear
The '/common/download_agent_installer.php' script in the Quest KACE System Management Appliance 8.0.318 is accessible by
ProjectSend versions prior to r1720 are affected by an improper authentication vulnerability. Rated critical severity (C
Roundcube Webmail contains a critical PHP object deserialization vulnerability (CVE-2025-49113, CVSS 9.9) that allows au
Util/PHP/eval-stdin.php in PHPUnit before 4.8.28 and 5.x before 5.6.3 allows remote attackers to execute arbitrary PHP c
Palo Alto Networks PAN-OS management web interface contains an authentication bypass allowing unauthenticated attackers
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
The get_referers function in /opt/ws/bin/sblistpack in Sophos Web Appliance before 3.7.9.1 and 3.8 before 3.8.1.1 allows
The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
EUVD-2026-77673
GHSA-xv9m-fm3w-8w5x
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB