Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessSend HTTP request to plugin endpoint
-
ExploitBypass missing authorization check
-
ExecutionModify directory or listing data
-
ImpactPersist unauthorized state change
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires the Directorist plugin to be installed and activated on a WordPress site with at least one endpoint or form handler missing authorization checks. The vulnerability is triggered when an unauthenticated attacker directly accesses or submits to a protected plugin function without providing valid WordPress credentials or capability tokens. No special WordPress configuration, API keys, or administrative settings are required on the attacker's side; the flaw exists in the plugin's failure to validate permissions on its own endpoints regardless of site configuration. |
| Impact | The CVSS vector (AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N) indicates network-accessible, unauthenticated exploitation with low complexity - objectively a concerning profile. However, the EPSS score of 0.02% (4th percentile) strongly signals low real-world exploitation likelihood, suggesting either narrow technical conditions, limited attacker motivation, or minimal downstream impact despite the authorization flaw. The integrity impact (I:L) is constrained; no confidentiality or availability loss is possible. The absence of known public exploits or CISA KEV listing further supports a low-priority vulnerability. Security teams should prioritize this below high-EPSS issues but should still track patch releases, as authorization bypasses in popular plugins can be weaponized quickly once exploit code emerges. |
| Exploit ScenarioDerived | An unauthenticated attacker crafts a direct HTTP request to a vulnerable Directorist plugin endpoint (likely a REST API route or form handler) that modifies directory listings, user profiles, or business classification data without proper permission checks. The attacker exploits the missing authorization validation to submit state changes such as editing a listing title, changing a category assignment, or altering business information - actions normally restricted to authenticated owners or administrators. Because the plugin fails to verify the attacker's credentials or capabilities, the modification is processed and persisted. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 15, 2026
Broken access control in wpWax Directorist WordPress plugin versions up to 8.5.10 allows unauthenticated remote attackers to modify data through incorrectly configured authorization checks. The vulnerability exploits missing permission validation on plugin functionality, enabling unauthorized state changes without authentication or user interaction. With EPSS at 0.02% and no public exploit code identified, real-world risk remains low despite network-accessible exploitation.
RemediationAI
Update the Directorist plugin to a patched version released after 8.5.10; check the official wpWax GitHub repository or WordPress.org plugin page for the latest available release. As a temporary mitigation, administrators can restrict direct access to plugin endpoints via Web Application Firewall (WAF) rules or limit REST API exposure until patching is completed. Refer to the Patchstack advisory (https://patchstack.com/database/Wordpress/Plugin/directorist/vulnerability/wordpress-directorist-plugin-8-5-10-broken-access-control-vulnerability?_s_id=cve) for detailed patching instructions and follow wpWax's official security notices for confirmation of fixed versions.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Directorist is a WordPress directory plugin developed by wpWax that manages business listings, classifications, and user profiles. The vulnerability stems from CWE-862 (Missing Authorization), a fundamental access control flaw where the plugin fails to verify that a user has permission to perform requested actions before executing them. This likely occurs in WordPress REST API endpoints or form handlers that lack proper capability checks (such as current_user_can() verification or nonce validation), allowing the plugin to process state-modifying requests from unauthenticated sources. The affected CPE cpe:2.3:a:wpwax:directorist:*:*:*:*:*:*:*:* indicates all versions through 8.5.10 are impacted.
Know when Directorist gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Primary rating from Vendor (Patchstack) · only source for this CVE.
CVSS VectorVendor: Patchstack
Lifecycle Timeline
2DescriptionCVE.org
Missing Authorization vulnerability in wpWax Directorist directorist allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Directorist: from n/a through <= 8.5.10.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
More in Directorist
View allThe Directorist WordPress plugin before 7.0.6.2 was vulnerable to Cross-Site Request Forgery to Remote File Upload leadi
The Directorist WordPress plugin before 7.4.4 does not prevent users with low privileges (like subscribers) from accessi
The Directorist WordPress plugin before 7.4.2.2 suffers from an IDOR vulnerability which an attacker can exploit to chan
PHP Object Injection in the wpWax Directorist WordPress plugin (all versions through 8.8.2) lets remote attackers pass u
Remote unauthenticated attackers can escalate privileges to administrator level in Directorist Social Login WordPress pl
Path traversal in the Directorist WordPress plugin (versions 8.5 through before 8.9.3) allows subscriber-level authentic
The Directorist WordPress plugin before 7.3.1 discloses the email address of all users in an AJAX action available to bo
The Directorist WordPress plugin before 7.2.3 allows administrators to download other plugins from the same vendor direc
The Directorist plugin for WordPress is vulnerable to an arbitrary user password reset in versions up to, and including,
The Directorist WordPress plugin before 7.3.0 does not have authorisation and CSRF checks in an AJAX action, allowing an
Authorization bypass in the Directorist: AI-Powered Business Directory, Listings & Classified Ads plugin for WordPress (
The Directorist: AI-Powered Business Directory Plugin with Classified Ads Listings plugin for WordPress is vulnerable to
EUVD-2026-20176
GHSA-rjr9-fgqp-jmc9
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB