Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessObtain WordPress user credentials
-
DeliveryAuthenticate to WordPress dashboard
-
ExploitAccess CartFlows admin interface or API
-
ExecutionModify funnel/product/checkout settings without authorization
-
ImpactApply unauthorized changes affecting business logic
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires an authenticated WordPress user account with any registered role (subscriber, contributor, author, editor, or lower privilege) on the target WordPress installation running CartFlows ≤2.2.3. CartFlows must be installed and activated. The vulnerability does NOT require administrator access, special plugin configuration, or network-level conditions beyond standard WordPress HTTP/HTTPS access. No special authorization bypass techniques or chaining with other vulnerabilities is necessary if CartFlows is misconfigured to allow authenticated users unrestricted access to protected functions. |
| Impact | CVSS 4.3 with vector AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N indicates network-accessible exploitation requiring low complexity and prior authentication, with integrity impact only (modification capability) and no confidentiality or availability impact. EPSS 0.02% (4th percentile) signals very low exploitation probability in the real world, suggesting either limited attacker incentive, difficult exploitation chains, or narrow applicability. The absence of KEV status and no confirmed POC further reduce assessed risk. However, authentication requirement (PR:L) significantly lowers risk compared to unauthenticated authorization flaws. For WordPress deployments, the real-world impact depends heavily on threat actor access to WordPress user accounts; in multi-user WordPress sites or those with loose access controls, an attacker with subscriber or contributor role could escalate permissions to modify store configurations, funnels, or customer data. This is a low-priority remediation candidate unless the affected WordPress instance faces insider threats or account compromise risk. |
| Exploit ScenarioDerived | An authenticated WordPress contributor or subscriber on a CartFlows-enabled e-commerce site exploits the missing authorization check to directly access admin-only CartFlows API endpoints or settings pages. The attacker modifies funnel configurations, disables checkout steps, or alters product pricing without holding the administrator role, causing business disruption or financial loss. No public exploit code is required; the attacker manually crafts HTTP requests or uses WordPress admin interface inspection to discover vulnerable endpoints. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 15, 2026
Missing authorization in Brainstorm Force CartFlows WordPress plugin versions up to 2.2.3 allows authenticated attackers to modify data through incorrectly configured access control, enabling unauthorized changes to plugin settings or resources. CVSS 4.3 (low severity) with EPSS 0.02% indicates limited real-world exploitation probability; the vulnerability requires prior authentication and does not enable code execution or confidentiality breaches.
RemediationAI
Update CartFlows to a patched version newer than 2.2.3 as released by Brainstorm Force. Users should navigate to WordPress Dashboard → Plugins → Installed Plugins and check for available updates, or manually download the latest CartFlows release from https://patchstack.com/database/Wordpress/Plugin/cartflows/. Additionally, audit WordPress user roles and capabilities to ensure non-administrator users do not have unnecessary access to CartFlows settings; restrict the 'manage_cartflows' capability (or equivalent) to administrators only via WordPress capability checks. Consult the Brainstorm Force security advisory and NIST CVE entry (https://nvd.nist.gov/vuln/detail/CVE-2026-39477) for patch version details and deployment guidance.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
CartFlows is a WordPress e-commerce funnel builder plugin developed by Brainstorm Force, distributed via the WordPress plugin marketplace and identified by CPE cpe:2.3:a:brainstorm_force:cartflows:*:*:*:*:*:*:*:*. The vulnerability stems from CWE-862 (Missing Authorization), a classic access control flaw where the application fails to enforce proper permission checks before allowing authenticated users to perform sensitive operations. In WordPress plugins, this typically manifests as missing nonce verification, inadequate capability checks (e.g., using 'manage_options' when role-based restrictions are required), or direct database modifications without proper ACL enforcement. CartFlows' improper access control allows authenticated users with lower privileges to access or modify resources intended for higher-privilege roles, compromising the plugin's security posture within WordPress's multi-role ecosystem.
Know when Cartflows gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Primary rating from Vendor (Patchstack) · only source for this CVE.
CVSS VectorVendor: Patchstack
Lifecycle Timeline
2DescriptionCVE.org
Missing Authorization vulnerability in Brainstorm Force CartFlows cartflows allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CartFlows: from n/a through <= 2.2.3.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
The WooCommerce Cart Abandonment Recovery WordPress plugin before 1.2.27 does not have CSRF check in its bulk actions, w
The Funnel Builder plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the a
Remote code execution in the CartFlows WordPress plugin affects versions 3.2.0 and earlier, allowing an authenticated us
The Funnel Builder by CartFlows - Create High Converting Sales Funnels For WordPress plugin before 1.6.13 did not saniti
The WooCommerce Checkout & Funnel Builder by CartFlows plugin for WordPress is vulnerable to Cross-Site Request Forgery
Unauth. Rated medium severity (CVSS 6.1), this vulnerability is remotely exploitable, no authentication required, low at
Cross-Site Request Forgery (CSRF) vulnerability in Brainstorm Force US LLC CartFlows Pro allows Cross Site Request Forge
EUVD-2026-20144
GHSA-8f6m-3c4p-c477
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB