Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization verification
MITRE ATT&CK
1 technique across 1 tactic: Defense Evasion The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | CVSS 6.6 with PR:H (high privilege required) and AV:N (network-accessible API) indicates moderate-to-high risk conditional on attacker holding staff privileges. The CVSS vector explicitly requires authenticated high-privilege access (PR:H), meaning only staff users or higher can exploit this; low-privilege or unauthenticated users cannot. The attack is straightforward (AC:L), has network scope (S:C), and causes confidentiality, integrity, and availability impact (C:L, I:L, A:L)-consistent with arbitrary code execution via malicious plugin installation. Real-world risk depends critically on organizational trust model: if staff accounts are issued to contractors, vendors, or junior administrators with lower vetting than superusers, the risk is substantial. If staff is tightly controlled and all staff users are fully trusted, risk is lower. The inconsistent permission enforcement (staff can install but not uninstall) signals a logic error rather than intentional design, increasing likelihood of exploitability. No active exploitation or public POC has been identified, but the ease of API-based exploitation (no complex interaction required) and the availability of detailed advisory documentation make development of POC straightforward for motivated insiders. |
| Exploit ScenarioDerived | A staff-level user (e.g., a contractor with warehouse management privileges) authenticates to the InvenTree API and makes an HTTP POST request to the plugin installation endpoint with a malicious plugin package URL. The unpatched API, failing to verify superuser status, accepts and installs the plugin. The plugin executes with InvenTree application privileges, allowing the attacker to exfiltrate inventory data, modify stock records, or pivot to internal systems. Because plugin installation can be performed entirely via API with no UI interaction (UI:N), the attack requires no additional social engineering. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 08, 2026
InvenTree prior to versions 1.2.7 and 1.3.0 allows staff-level users to install arbitrary plugins via the API without requiring superuser privileges, enabling privilege escalation and potential code execution. The vulnerability exists because plugin installation permissions are inconsistently enforced compared to other plugin operations (such as uninstallation) that correctly require superuser access. Staff users, typically considered lower-trust accounts than superusers, can exploit this to deploy malicious plugins with full application context. No public exploit code or active exploitation has been identified at time of analysis.
RemediationAI
Upgrade InvenTree to version 1.2.7 or 1.3.0 or later. The patch corrects the authorization logic in the plugin installation API endpoint to require superuser privileges, consistent with other plugin management operations. Users unable to upgrade immediately should restrict API access to superuser accounts only and audit existing staff accounts for unauthorized plugin installations. Review the InvenTree threat model and plugin configuration documentation (referenced in advisories) to understand intended authorization boundaries and ensure organizational access controls align with the fixed privilege model. See GitHub security advisory GHSA-7c3q-vwcv-2vp7 for comprehensive remediation guidance.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
InvenTree's plugin system is a core extensibility mechanism for the inventory management platform. The vulnerability stems from inconsistent authorization enforcement in the plugin API endpoints-specifically the installation endpoint fails to validate that the requesting user holds superuser-level privileges, while uninstallation and other plugin management operations correctly enforce this requirement. The root cause is classified as CWE-285 (Improper Authorization), indicating that the API layer performs insufficient permission checks before allowing sensitive operations. The plugin API likely handles plugin download, validation, and installation as atomic operations without intermediate privilege gate-checks. Staff users, authenticated via the API with PR:H (high privileges within staff tier) per the CVSS vector, can call installation endpoints that bypass the superuser gate that should prevent installation of untrusted code.
Know when Inventree gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
Lifecycle Timeline
3DescriptionNVD
InvenTree is an Open Source Inventory Management System. Prior to 1.2.7 and 1.3.0, any users who have staff access permissions can install plugins via the API, without requiring "superuser" account access. This level of permission requirement is out of alignment with other plugin actions (such as uninstalling) which do require superuser access. The vulnerability allows staff users (who may be considered to have a lower level of trust than a superuser account) to install arbitrary (and potentially harmful) plugins. This vulnerability is fixed in 1.2.7 and 1.3.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Improper Neutralization of Formula Elements in a CSV File in GitHub repository inventree/inventree prior to 0.7.2. Rated
Unrestricted Upload of File with Dangerous Type in GitHub repository inventree/inventree prior to 0.7.2. Rated high seve
Allocation of Resources Without Limits or Throttling in GitHub repository inventree/inventree prior to 0.8.0. Rated medi
Remote code execution in InvenTree 1.2.3 through 1.2.6 allows staff users with settings access to execute arbitrary code
Cross-site Scripting (XSS) - Stored in GitHub repository inventree/inventree prior to 0.8.3. Rated medium severity (CVSS
Cross-site Scripting (XSS) - Stored in GitHub repository inventree/inventree prior to 0.7.2. Rated medium severity (CVSS
Authentication bypass in InvenTree open source inventory management system allows any authenticated user to generate API
Broken object-level authorization in InvenTree prior to 1.4.0 allows any authenticated low-privilege user - or any holde
InvenTree versions prior to 1.4.0 render report and label templates with WeasyPrint's default URL fetcher, so an authent
Authenticated attackers with low-level privileges can exfiltrate sensitive database information from InvenTree open sour
InvenTree prior to version 1.2.3 allows authenticated staff users to inject malicious Jinja2 template code into batch co
InvenTree is an Open Source Inventory Management System. Rated medium severity (CVSS 5.4), this vulnerability is remotel
EUVD-2026-20592
NVD
CVE.org
EPSS
Vulnrichment
GitHub
Exploit-DB