Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAccess OPNsense WebGUI login page
-
ExploitInject LDAP filter metacharacters into username field
-
ExecutionBypass LDAP group membership restrictions
-
ImpactAuthenticate as arbitrary LDAP user
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization LDAP query parameterization
MITRE ATT&CK
1 technique across 1 tactic: Initial Access The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | OPNsense versions prior to 26.1.6 with LDAP authentication enabled in WebGUI. Remote unauthenticated attacker exploits unescaped username field in LDAP search filter. No victim interaction required. Group membership restriction bypass only when Extended Query is configured. |
| Impact | CVSS 8.2 reflects high impact: unauthenticated network attacker can enumerate LDAP users and bypass group-based access controls via filter injection. Network-exposed OPNsense instances running vulnerable LDAP authentication face direct compromise risk if attacker knows target credentials. Severity tempered by requirement for pre-existing valid passwords to achieve full authentication bypass. |
| Exploit ScenarioDerived | Attacker submits crafted LDAP filter syntax in WebGUI login username field (e.g., |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 09, 2026
LDAP filter injection in OPNsense firewall allows unauthenticated attackers to enumerate valid LDAP usernames and bypass group membership restrictions via the WebGUI login page. Affects OPNsense versions prior to 26.1.6. The vulnerability stems from failure to escape user-supplied input before insertion into LDAP search filters, enabling metacharacter injection. Attackers can authenticate as any LDAP user with known credentials, circumventing Extended Query group membership controls. No public exploit identified at time of analysis.
RemediationAI
Vendor-released patch: OPNsense 26.1.6. Upgrade immediately to patched version via WebGUI (System > Firmware > Updates) or command line using opnsense-update utility. Upstream fix implements proper input sanitization through ldap_escape() function (commit 016f66cb4620cd48183fa97843f343bb71813c6e). Organizations unable to upgrade immediately should disable LDAP authentication and switch to local authentication or alternative authentication backends until patching is completed. No effective workaround exists while LDAP authentication remains enabled. Review authentication logs for suspicious username patterns containing LDAP metacharacters (parentheses, asterisks, ampersands). Advisory: https://github.com/opnsense/core/security/advisories/GHSA-jpm7-f59c-mp54
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Root cause is missing ldap_escape() call on username input (CWE-90: Improper Neutralization of Special Elements). LDAP filter metacharacters injected through username field manipulate search filter logic, allowing filter manipulation attacks. When Extended Query group restrictions are configured, injected filters can OR arbitrary conditions to bypass membership checks in authentication logic.
Know when Opnsense gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Primary rating from Vendor (GitHub_M) · only source for this CVE.
CVSS VectorVendor: GitHub_M
Lifecycle Timeline
3DescriptionCVE.org
OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.6, OPNsense's LDAP authentication connector passes the login username directly into an LDAP search filter without calling ldap_escape(). An unauthenticated attacker can inject LDAP filter metacharacters into the username field of the WebGUI login page to enumerate valid LDAP usernames in the configured directory. When the LDAP server configuration includes an Extended Query to restrict login to members of a specific group, the same injection can be used to bypass that group membership restriction and authenticate as any LDAP user whose password is known, regardless of group membership. This vulnerability is fixed in 26.1.6.
Executive ViewAI
OPNsense firewalls prior to version 26.1.6 contain an LDAP filter injection vulnerability in the WebGUI login page that enables unauthenticated attackers to enumerate valid usernames and bypass group-based access controls, potentially allowing unauthorized administrative access to network perimeter security infrastructure. Organizations using OPNsense with LDAP authentication face immediate risk of credential compromise and loss of authentication-based access restrictions that protect critical network management functions.
Apply vendor patch (OPNsense 26.1.6 or later). Interim mitigations: restrict WebGUI access to specific source IPs via firewall rules or network segmentation; implement rate limiting on login endpoints; enforce multi-factor authentication for administrative accounts; monitor LDAP query logs for suspicious search patterns.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Code injection occurs when an application accepts user input and passes it directly into a language interpreter or evaluator without proper sanitization.
Insecure permissions in the configuration directory (/conf/) of OPNsense Community Edition before 23.7 and Business Edit
DECISO OPNsense 23.1 does not impose rate limits for authentication, allowing attackers to perform a brute-force attack
A command injection vulnerability in the component /api/cron/settings/setJob/ of OPNsense Community Edition before 23.7
A command injection vulnerability in the component diag_backup.php of OPNsense Community Edition before 23.7 and Busines
/ui/cron/item/open in the Cron component of OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 al
OPNsense Community Edition before 23.7 and Business Edition before 23.4.2 was discovered to contain insecure permissions
Insecure permissions exist for configd.socket in OPNsense Community Edition before 23.7 and Business Edition before 23.4
A directory traversal vulnerability in the Captive Portal templates of OPNsense Community Edition before 23.7 and Busine
A Cross-Site Request Forgery (CSRF) in the System Halt API (/system/halt) of OPNsense Community Edition before 23.7 and
OPNsense 19.1 contains a stored cross-site scripting vulnerability that allows authenticated attackers to inject malicio
OPNsense 19.1 contains a stored cross-site scripting vulnerability in the system_advanced_sysctl.php endpoint that allow
OPNsense 19.1 contains a reflected cross-site scripting vulnerability that allows unauthenticated attackers to inject ma
EUVD-2026-20896
NVD
CVE.org
EPSS
Vulnrichment
GitHub
Exploit-DB