Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Access control enforcement
MITRE ATT&CK
1 technique across 1 tactic: Defense Evasion The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | CVSS 5.1 with vector AV:N/AC:L/PR:H/UI:N indicates a low-severity issue from the base score perspective: remote network access with low complexity, but requiring high-privilege (moderator) authentication-reducing the threat actor pool significantly. EPSS data is not provided, but the authentication requirement (PR:H) is a limiting factor for real-world impact. Exploitation requires an attacker to already possess moderator credentials, which is a substantial prerequisite. No CISA KEV confirmation or public exploit code is reported, indicating this is not yet actively exploited in the wild. However, the vulnerability is meaningful within threat models where internal moderator accounts are compromised or where insider threats are relevant. The low confidentiality impact (VC:L) reflects unauthorized information disclosure rather than system compromise. For organizations with sensitive category structures or strict internal content separation, this should be treated as a moderate priority given the ease of exploitation (AC:L) once authenticated; for others, it may be deferred pending scheduled patching cycles. |
| Exploit ScenarioDerived | A malicious insider with moderator privileges on a Discourse instance could repeatedly call the unprotected sentiment analytics endpoint, iterating through category identifiers to harvest restricted post content, topic titles, and usernames from categories they were never granted access to view. Because the attack requires no user interaction (UI:N) and uses standard network access, an attacker could automate this data exfiltration in minutes. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 31, 2026
Discourse versions 2026.1.0-2026.1.2, 2026.2.0-2026.2.1, and 2026.3.0-beta allow authenticated moderators to bypass category permission controls and retrieve post content, topic titles, and usernames from categories they lack authorization to access via a sentiment analytics endpoint. Patches are available (2026.1.3, 2026.2.2, 2026.3.0); no public exploit code or active exploitation has been identified.
RemediationAI
Upgrade immediately to patched versions: Discourse 2026.1.3 or later for the 2026.1.x branch, 2026.2.2 or later for the 2026.2.x branch, or 2026.3.0 final release for the 2026.3.x branch. Refer to the official GitHub security advisory at https://github.com/discourse/discourse/security/advisories/GHSA-vj5f-gg8m-93xg and the fix commit at https://github.com/discourse/discourse/commit/e1bb146a1fadc863a516fbc26c6277273a025308 for detailed patching guidance. Until patched, consider restricting moderator access to trusted users and auditing moderator account activity for unauthorized API calls to sentiment analytics endpoints.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 3 packages in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Discourse implements role-based access controls (RBAC) to restrict moderator visibility to designated categories. The vulnerability resides in insufficient authorization checks on a sentiment analytics API endpoint, which fails to enforce the same category permission boundaries enforced elsewhere in the application. This is a classic CWE-284 (Improper Access Control) issue where an endpoint performs sensitive operations without verifying the caller's permissions. The affected product is the Discourse discussion platform across multiple release branches (2026.1.x, 2026.2.x, 2026.3.x series). Moderators, who normally have elevated but constrained permissions, can exploit this to read restricted content they should not access.
Know when Discourse gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Primary rating from Vendor (GitHub_M) · only source for this CVE.
CVSS VectorVendor: GitHub_M
Lifecycle Timeline
2DescriptionCVE.org
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, an authenticated moderator-level user could retrieve post content, topic titles, and usernames from categories they were not authorized to view. Insufficient access controls on a sentiment analytics endpoint allowed category permission boundaries to be bypassed. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Discourse versions prior to 3.5.0.beta6 contain a reflected cross-site scripting (XSS) vulnerability in social login fun
discourse-bbcode is the official BBCode plugin for Discourse. Rated critical severity (CVSS 9.8), this vulnerability is
Unauthorized information disclosure in Discourse discussion platform versions prior to 2026.3.0-latest.1, 2026.2.1, and
Discourse is an open source platform for community discussion. Rated high severity (CVSS 8.2), this vulnerability is rem
Discourse versions prior to 2025.12.2, 2026.1.1, and 2026.2.0 contain an insecure direct object reference (IDOR) in the
In Discourse 2.7.0 through beta1, a rate-limit bypass leads to a bypass of the 2FA requirement for certain forms. Rated
Unauthenticated attackers can submit forged webhook payloads to multiple email provider integrations in Discourse versio
Discourse is an open-source discussion platform. Rated medium severity (CVSS 6.5), this vulnerability is remotely exploi
Discourse is an open source platform for community discussion. Rated medium severity (CVSS 5.9), this vulnerability is r
Discourse versions prior to 3.4.4 (stable), 3.5.0.beta5 (beta), and 3.5.0.beta6-dev (tests-passed) contain a critical vu
Discourse is an open source platform for community discussion. Rated critical severity (CVSS 9.8), this vulnerability is
Discourse Patreon enables syncronization between Discourse Groups and Patreon rewards. Rated critical severity (CVSS 9.8
EUVD-2026-17574
NVD
CVE.org
EPSS
Vulnrichment
GitHub
VulDB
Exploit-DB