Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessAccess baserCMS installer interface
-
ExploitInject OS commands via unsanitized input
-
ExecutionExecute arbitrary system commands
-
ImpactAchieve remote code execution with server privileges
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization OS command sanitization, avoid shell exec
MITRE ATT&CK
2 techniques across 1 tactic: Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Remote unauthenticated attacker can exploit OS command injection during baserCMS installation phase on versions prior to 5.2.3. Requires access to the active installer interface (typically available only during initial setup or when installer files remain accessible post-deployment). |
| Impact | Without CVSS scores and vectors, quantitative severity assessment is limited. However, the vulnerability characteristics suggest elevated real-world risk: it is located in the installer (often run with elevated privileges during setup), involves OS command injection (CWE-78, typically high-impact), and affects all versions prior to 5.2.3. The lack of authentication requirements for installer access (typical for initial setup) likely means the attack vector is unauthenticated and network-accessible. The installer context suggests attack complexity may be low if an attacker can trigger the vulnerable code path. CISA KEV status and EPSS data are not provided; however, the availability of a vendor patch and public advisory indicates this was a known and addressed risk. Organizations running unpatched versions of baserCMS should treat this as a priority remediation target. |
| Exploit ScenarioDerived | An attacker with network access to a baserCMS installation running the installer (version prior to 5.2.3) could craft a malicious input containing OS command metacharacters (e.g., semicolons, pipes, backticks) to be passed to a vulnerable installer parameter. Upon processing, the injected command would execute with the privileges of the web server process, potentially allowing the attacker to read sensitive files, modify the application, create backdoors, or pivot to other systems. Exploit proof-of-concept code may be available in the referenced GitHub security advisory. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 31, 2026
OS command injection in baserCMS installer prior to version 5.2.3 allows remote attackers to execute arbitrary system commands during the installation process. The vulnerability exists in the installer component and has been patched in version 5.2.3. Attack complexity appears low given the installer context, though CVSS metrics are unavailable for detailed severity assessment.
RemediationAI
Vendor-released patch: baserCMS version 5.2.3 or later. Organizations running baserCMS should immediately upgrade to version 5.2.3 or newer. If upgrading is not immediately possible, restrict access to the installer to trusted networks and disable or remove the installer once initial deployment is complete. Consult the official security advisories at https://github.com/baserproject/basercms/security/advisories/GHSA-6hpg-8rx3-cwgv and https://basercms.net/security/JVN_20837860 for additional mitigation guidance.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in composer, euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
baserCMS is a PHP-based website development framework. The vulnerability is rooted in CWE-78 (Improper Neutralization of Special Elements used in an OS Command), indicating that user-supplied input is not properly sanitized before being passed to OS command execution functions (such as exec(), system(), or shell_exec() in PHP). The installer component fails to validate or escape special shell metacharacters, allowing an attacker to inject arbitrary commands. This is a classic command injection flaw where unsanitized input intended as data is interpreted as executable code by the shell.
Know when Basercms gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Primary rating from GitHub Advisory · only source for this CVE.
CVSS VectorGitHub Advisory
Lifecycle Timeline
2DescriptionGitHub Advisory
baserCMS is a website development framework. Prior to version 5.2.3, baserCMS has an OS command injection vulnerability in the installer. This issue has been patched in version 5.2.3.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
OS command injection occurs when an application passes unsanitized user input directly into system shell commands.
Related Vulnerabilities in baserCMS Multiple Vulnerabilities
View all 9In baserCMS before 4.1.4, lib\Baser\Model\ThemeConfig.php allows remote attackers to execute arbitrary PHP code via the
SQL injection vulnerability in the baserCMS 3.0.14 and earlier, 4.0.5 and earlier allows remote attackers to execute arb
baserCMS is a website development framework. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploita
baserCMS is a website development framework. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploita
baserCMS is a Content Management system. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable,
baserCMS is a Content Management system. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable,
baserCMS 3.0.14 and earlier, 4.0.5 and earlier allows an attacker to execute arbitrary PHP code on the server via unspec
Cross-site request forgery (CSRF) vulnerability in baserCMS plugin Mail version 3.0.10 and earlier allows remote attacke
Cross-site request forgery (CSRF) vulnerability in baserCMS plugin Blog version 3.0.10 and earlier allows remote attacke
Cross-site request forgery (CSRF) vulnerability in baserCMS version 3.0.10 and earlier allows remote attackers to hijack
EUVD-2026-17265
GHSA-6hpg-8rx3-cwgv
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB