Skip to main content

Pocket Id CVE-2026-28513

HIGH
Incorrect Authorization (CWE-863)
2026-03-10 security-advisories@github.com GHSA-qh6q-598w-w6m2
8.5
CVSS 3.1 · GitHub Advisory
View

Attack ChainAIDerived

Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain

  1. Access
    Obtain authorization code from victim client
  2. Exploit
    Submit code to different client application
  3. Execution
    Exchange code at token endpoint
  4. Impact
    Receive valid OIDC token for different client

Vulnerability Assessment

Weakness
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization logic validation
MITRE ATT&CK

1 technique across 1 tactic: Privilege Escalation

The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up.

Exploitation Conditions

Pocket ID OIDC provider versions before 2.4.0 with multiple registered client applications. Attacker requires valid login credentials (PR:L) to obtain initial authorization code from one client, then exploits flawed token endpoint validation logic that accepts codes across different clients.

Impact

CVSS 8.5 (HIGH). Attack vector: Network. Complexity: Low. Privileges required: Low. User interaction: None. Public exploit/POC available.

Exploit ScenarioDerived

An attacker could exploit this vulnerability to authenticate with their passkeys to your services.

This Week Schedule remediation this week. Why: HIGH severity (CVSS 7.0-8.9).
Patch available 0.0% exploitation probability (EPSS)

Get an e-mail when this CVE is exploited, patched or re-scored. Free account.

Alert me

AnalysisAIv1 – Mar 12, 2026

Pocket ID versions prior to 2.4.0 fail to properly validate authorization codes at the OIDC token endpoint, enabling attackers with valid credentials to exchange codes across different clients or reuse expired codes. This authentication bypass affects any service relying on Pocket ID for passkey-based authentication and allows token acquisition without proper authorization. Public exploit code exists for this vulnerability, and no patch is currently available.

Earlier versions of this analysis (1)
v1 Mar 12, 2026 - 21:55 CVSS 8.5

Pocket ID is an OIDC provider that allows users to authenticate with their passkeys to your services. versions up to 2.4.0 is affected by incorrect authorization (CVSS 8.5).

RemediationAI

Fixed in version 2.4.0.. Restrict network access to the affected service where possible.

Affected Packages

go github.com/pocket-id/pocket-id/backend fix: 0.0.0-20260307173642-b59e35cb59ae

Source: OSV (Open Source Vulnerabilities)

Affects your stack

Affects 1 package in go

Checking this CVE against your own stacks and servers is part of the Basic plan and up.

Technical ContextAI · show details

This vulnerability (CWE-863: Incorrect Authorization) affects Pocket ID is an OIDC provider that allows users to authenticate with their passkeys to your services.. Pocket ID is an OIDC provider that allows users to authenticate with their passkeys to your services. Prior to 2.4.0, the OIDC token endpoint rejects an authorization code only when both the client ID is wrong and the code is expired. This allows cross-client code exchange and expired code reuse. This vulnerability is fixed in 2.4.0.

Know when Pocket Id gets its next vulnerability

  • Watch products and get an email when something new is published
  • Check this CVE against your own stack and servers
  • Exploit and PoC references, threat intelligence from 22 sources

No credit card · 7-day full trial

Severity by source

GitHub Advisory PRIMARY 8.5 HIGH
AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
SUSE HIGH

Primary rating from GitHub Advisory.

CVSS VectorGitHub Advisory

Attack Vector
Network
Attack Complexity
Low
Privileges Required
Low
User Interaction
None
Scope
Changed
Confidentiality
High
Integrity
Low
Availability
None

Lifecycle Timeline

3
Patch released
Mar 31, 2026 - 21:13 nvd
Patch available
PoC Detected
Mar 13, 2026 - 15:52 vuln.today
Public exploit code
CVE Published
Mar 10, 2026 - 17:38 nvd
HIGH 8.5

DescriptionGitHub Advisory

Pocket ID is an OIDC provider that allows users to authenticate with their passkeys to your services. Prior to 2.4.0, the OIDC token endpoint rejects an authorization code only when both the client ID is wrong and the code is expired. This allows cross-client code exchange and expired code reuse. This vulnerability is fixed in 2.4.0.

Executive ViewAI

Why It Matters

Pocket ID versions up to 2.4.0 contain a critical authorization bypass vulnerability that could allow attackers to gain unauthorized access to user accounts and integrated services. This affects any organization using Pocket ID for authentication, potentially compromising customer identities and the security of dependent applications.

Business Impact: Severe
Compensating Controls

Implement WAF rules to block suspicious authorization requests; restrict Pocket ID instance access to trusted networks only; disable Pocket ID authentication temporarily if risk tolerance is low and migrate users to alternative OIDC provider; enable comprehensive audit logging and real-time alerting on authentication failures; require multi-factor authentication on all dependent services as additional verification layer.

Threat Intelligence Overview

EPSS Score
0.0%
Top 99% exploitable
Exploit
POC
Public exploit code exists
Data Quality
5 sources
Confidence: Medium
NVD CVE.org EPSS Vendor GitHub VulDB

How this decision was reached

The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.

SignalValue
Severity HIGH
CISA KEV No
Public POC Yes
EPSS 0.0%
Patch available Yes
Active threat No
Deciding rule
HIGH severity (CVSS 7.0-8.9)
What every action level means
Emergency Immediate action required. Criteria: CRITICAL + in CISA KEV (actively exploited) without patch, OR CRITICAL + EPSS > 30% without patch, OR CRITICAL + active threat signals without patch.
Act Now Prioritize within 24-48h. Criteria: in KEV with patch available, OR CRITICAL + public POC, OR HIGH + EPSS > 10%, OR CRITICAL + active threat, OR any CRITICAL severity.
This Week Schedule remediation this week. Criteria: HIGH severity (CVSS 7.0-8.9). Patch within normal change window.
This Month Plan within 30 days. Criteria: MEDIUM severity (CVSS 4.0-6.9), lower exploitation probability. Include in regular patch cycle.
Monitor Track and reassess. Criteria: LOW severity (CVSS 0.1-3.9), minimal exploitation risk. No immediate action needed.

SSVC AssessmentENISA

SSVC Decision· derived
Out-of-Cycle
Exploitation· derived
Poc
System Exposure· derived
Open
Automatable· derived
No
Human Impact
Very High

Priority Score

62
Low Medium High Critical
KEV: 0
EPSS: 0
CVSS: +42
PoC: +20
Weaponized: 0
Threat intel: 0
Gov advisory: 0

Attack Technique

Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.

Affected Products (CPE)GitHub Advisory

cpe:2.3:a:pocket-id:pocket_id:*:*:*:*:*:*:*:*

Related Vulnerabilities in Pocket ID OIDC Authentication Bypass

View all 2

Vendor StatusVendor

SUSE

Severity: High

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy