Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Impact | While a formal CVSS score and EPSS exploitation probability are not available, the vulnerability's real-world risk is moderate to moderately-high based on available signals. The CWE-862 classification (Missing Authorization) is a well-known, easily exploitable weakness that typically requires low attack complexity and no elevated privileges—an unauthenticated attacker could potentially approve or reject users, modify user data, or escalate privileges. The fact that this is a WordPress plugin significantly increases real-world risk because WordPress installations are ubiquitous and often poorly maintained; the plugin's user approval function is security-critical. The absence of a published POC and KEV designation suggests limited active exploitation at present, but the straightforward nature of authorization bypasses means that remediation should be treated with urgency. Organizations using New User Approve should prioritize patching, as the technical impact of broken access control on user registration workflows is substantial—an attacker could grant themselves or malicious accounts administrative access. |
| Exploit ScenarioDerived | An attacker visits a WordPress site using the vulnerable New User Approve plugin and registers a new user account. Because the plugin fails to properly verify authorization, the attacker can directly access or manipulate the user approval workflow—either via a direct URL, REST API endpoint, or form submission—to self-approve their account or elevate their role to administrator without waiting for legitimate approval from a site moderator. Alternatively, the attacker could enumerate and modify other pending users' approval status, deleting moderation records or granting unauthorized access to malicious accounts. The low attack complexity (no special tools required beyond a web browser) and the lack of privilege escalation barriers make this a practical, high-impact attack vector for any WordPress site relying on the New User Approve plugin for access control. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 25, 2026
The New User Approve plugin for WordPress versions 3.2.3 and earlier contains a missing authorization check that allows authenticated users to modify access control settings beyond their intended privileges. An attacker with basic user credentials could escalate their permissions or alter security configurations without proper authorization. No patch is currently available for this vulnerability.
Earlier versions of this analysis (1)
A missing authorization vulnerability exists in the New User Approve WordPress plugin (versions up to 3.2.3) that allows attackers to exploit incorrectly configured access control security levels. This broken access control flaw, classified as CWE-862, enables unauthorized users to bypass authentication mechanisms and perform actions they should not have permission to execute. The vulnerability affects the plugin's core user approval functionality and has been documented by Patchstack as an authentication bypass issue, though no CVSS score or active exploitation in the wild has been confirmed at this time.
RemediationAI
Users of the New User Approve plugin must upgrade to a patched version greater than 3.2.3 as soon as it becomes available; consult the Patchstack vulnerability database and the plugin's official WordPress.org repository for the latest secure release. Until an official patch is released, administrators should consider disabling the New User Approve plugin and reverting to WordPress's native user approval workflow, or use alternative, well-maintained user moderation plugins. As an interim mitigation, restrict administrative and approval capabilities to trusted roles only, review and audit recent user approvals for signs of unauthorized activity, and monitor access logs for suspicious requests to user approval endpoints. Additionally, implement Web Application Firewall (WAF) rules to block requests to sensitive plugin paths from untrusted sources, and enforce strong authentication (two-factor authentication) on all administrative accounts to limit lateral movement in the event of account compromise.
Affected VersionsENISA
Affects your stack
Find out whether the stacks and servers you run are on an affected version.
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The New User Approve plugin (CPE: cpe:2.3:a:saad_iqbal:new_user_approve:*:*:*:*:*:*:*:*) is a WordPress plugin designed to moderate and approve new user registrations before they gain site access. The vulnerability stems from CWE-862 (Missing Authorization), indicating that the plugin fails to properly verify user permissions before granting access to sensitive administrative functions or user approval workflows. WordPress plugins operate within the WordPress plugin API and hook system, which relies on proper use of nonces, capability checks (such as current_user_can()), and role-based access control (RBAC). The flaw suggests inadequate validation of whether a requesting user possesses the necessary WordPress capabilities (admin, moderator, or equivalent roles) before allowing them to interact with new user approval workflows, likely exposing REST endpoints or form handlers without proper permission gates.
Know when New User Approve gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
Missing Authorization vulnerability in Saad Iqbal New User Approve new-user-approve allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects New User Approve: from n/a through <= 3.2.3.
Executive ViewAI
CVE-2026-25390 presents notable security risk, a missing authorization vulnerability rated CVSS 6.5. Attackers could gain access beyond their authorized level. Organizations should apply vendor updates when available and monitor for exploitation.
Apply vendor patch. If patching is delayed: restrict network access and enable monitoring.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
More in New User Approve
View allThe New User Approve WordPress plugin before 2.4 does not have CSRF check in place when updating its settings and adding
Missing Authorization in myCred's New User Approve WordPress plugin through version 3.2.8 permits unauthenticated remote
Cross-Site Request Forgery (CSRF) vulnerability in WPExpertsio New User Approve.5.1. Rated medium severity (CVSS 4.3), t
EUVD-2026-15705
GHSA-v6mh-26pg-v9r8
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB