Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessRegister Subscriber account on open-registration site
-
DeliveryAuthenticate via WordPress login
-
ExploitSend authenticated AJAX request to updateAddon
-
ExecutionMissing capability check bypassed
-
PersistForce co-installed main.php plugin to latest version
-
ImpactDisrupt site or chain to secondary vulnerability in updated plugin
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Exploitation requires a valid WordPress user account with at least Subscriber-level access - the lowest role assignable upon registration on sites with open registration. No administrator interaction or elevated privilege is needed beyond this baseline authenticated session. The vulnerable |
| Impact | The CVSS 5.4 Medium score (AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L) reflects a realistic calibration: the attack is network-reachable and low-complexity, but the actual impact of a forced plugin update is bounded - no arbitrary code can be injected directly via this function alone. The practical blast radius depends entirely on what co-installed plugins with |
| Exploit ScenarioDerived | An attacker registers a free account on a WordPress site running Bookly ≤27.2 with open registration enabled, gaining Subscriber-level access. The attacker sends an authenticated POST request to the |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 08, 2026
Unauthorized plugin update execution in the Bookly scheduling plugin for WordPress (all versions through 27.2) allows any authenticated Subscriber-level user to force co-installed plugins whose main entry point is named main.php to update to their latest version, bypassing WordPress's standard update_plugins capability gate. The root cause is a missing capability check (CWE-862) on the updateAddon function in lib/PluginsUpdater.php, as identified by Wordfence and confirmed by the WordPress plugin SVN diff. No public exploit code has been identified and the vulnerability is absent from CISA KEV, but the low authentication bar makes it relevant on open-registration or multi-tenant WordPress sites.
RemediationAI
Update the Bookly plugin beyond version 27.2 immediately; the upstream fix is captured in WordPress plugin SVN changeset 3504922 at https://plugins.trac.wordpress.org/changeset/3504922/, which adds the missing capability check to updateAddon. The exact patched release version is not independently confirmed from the available data - administrators should verify the current version in the WordPress.org plugin directory changelog before updating. Updates can be applied via the WordPress admin Plugins screen or via WP-CLI with wp plugin update bookly-responsive-appointment-booking-tool. As a compensating control on sites where immediate update is not feasible, disabling open user registration or requiring administrator approval for new accounts prevents unauthenticated parties from obtaining the Subscriber role needed to reach the vulnerable function; note this does not remove the flaw and does not protect against existing Subscriber accounts. Disabling the Bookly plugin entirely eliminates the attack surface for sites not actively using the scheduling feature.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Bookly (CPE: cpe:2.3:a:ladela:online_scheduling_and_appointment_booking_system_-_bookly:*:*:*:*:*:*:*:*) ships an internal plugin auto-updater class at lib/PluginsUpdater.php. The updateAddon function, visible at line 105 of that file in the WordPress plugin SVN browser, executes a plugin lifecycle update operation without first calling current_user_can('update_plugins') or any equivalent WordPress capability verification. CWE-862 (Missing Authorization) describes this pattern: the function is accessible to any authenticated session because the code assumes role adequacy from authentication alone. In WordPress's RBAC model, update_plugins is granted only to Administrator and above; Subscribers receive none of these capabilities by default. The additional constraint that only plugins whose primary entry point file is literally named main.php are targetable is a structural quirk of the updater's plugin-discovery logic, not an intentional security boundary.
Know when PHP gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
Subscriber authentication required (PR:L); impact confined to forced plugin updates with no confidentiality exposure and only limited integrity and availability disruption.
Primary rating from Vendor (Wordfence).
CVSS VectorVendor: Wordfence
DescriptionCVE.org
The Online Scheduling and Appointment Booking System - Bookly plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'updateAddon' function in all versions up to, and including, 27.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update any plugin with a main file of 'main.php' to its latest version.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
In PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24 and 7.3.x below 7.3.11 in certain configurations of FPM setup it
sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI script (aka php-cgi), does not
(1) boardData102.php, (2) boardData103.php, (3) boardDataJP.php, (4) boardDataNA.php, and (5) boardDataWW.php in Netgear
The '/common/download_agent_installer.php' script in the Quest KACE System Management Appliance 8.0.318 is accessible by
ProjectSend versions prior to r1720 are affected by an improper authentication vulnerability. Rated critical severity (C
Roundcube Webmail contains a critical PHP object deserialization vulnerability (CVE-2025-49113, CVSS 9.9) that allows au
Util/PHP/eval-stdin.php in PHPUnit before 4.8.28 and 5.x before 5.6.3 allows remote attackers to execute arbitrary PHP c
Palo Alto Networks PAN-OS management web interface contains an authentication bypass allowing unauthenticated attackers
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
Nagios XI version xi-5.7.5 is affected by OS command injection. Rated high severity (CVSS 8.8), this vulnerability is re
The get_referers function in /opt/ws/bin/sblistpack in Sophos Web Appliance before 3.7.9.1 and 3.8 before 3.8.1.1 allows
The Backup Migration plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1
EUVD-2026-72701
GHSA-pqcg-gw2f-rqp8
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB