Alist
CVE-2026-25160
CRITICAL
Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessPosition attacker on network path between client and storage
-
ExploitIntercept unencrypted storage driver communications
-
ExecutionDecrypt and modify data in transit
-
ImpactSteal credentials and manipulate stored content
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A07:2025 - Authentication Failures
ASVS 5.0
V12 - Secure Communication Certificate validation
|
| Exploitation Conditions | Alist versions prior to 3.57.0 with default configuration where TLS certificate verification is disabled for all outgoing storage driver communications (S3, OneDrive, etc.). Network position allowing MITM between Alist server and storage backend required. |
| Impact | CVSS 9.1 with PoC and patch. Alist connects to multiple cloud storage providers — MITM could expose credentials for all configured backends. |
| Exploit ScenarioDerived | An attacker performs a MITM attack on Alist's connections to cloud storage, intercepting authentication tokens for S3, WebDAV, or other storage backends. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 12, 2026
Alist file manager has an improper certificate validation vulnerability allowing MITM attacks that could compromise file operations and stored credentials.
Earlier versions of this analysis (1)
Certificate validation bypass in Alist file manager enables MITM attacks.
RemediationAI
Update Alist. Use strict TLS validation.
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 2 packages in go
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Alist has a CWE-295 improper certificate validation that allows attackers in a network position to intercept and modify TLS connections, potentially stealing credentials for configured storage backends.
Know when Alist gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Primary rating from GitHub Advisory.
CVSS VectorGitHub Advisory
Lifecycle Timeline
3DescriptionGitHub Advisory
Alist is a file list program that supports multiple storages, powered by Gin and Solidjs. Prior to version 3.57.0, the application disables TLS certificate verification by default for all outgoing storage driver communications, making the system vulnerable to Man-in-the-Middle (MitM) attacks. This enables the complete decryption, theft, and manipulation of all data transmitted during storage operations, severely compromising the confidentiality and integrity of user data. This issue has been patched in version 3.57.0.
Executive ViewAI
Alist file storage systems are vulnerable to network interception attacks that could allow attackers to steal credentials and data in transit. Organizations running Alist versions prior to 3.57.0 face immediate risk of unauthorized access to stored files and credentials across all configured storage integrations.
Apply vendor patch. If immediate patching is not feasible: (1) Restrict Alist network access to internal/trusted networks only via firewall rules, (2) Deploy network segmentation to isolate Alist systems from untrusted networks, (3) Monitor all outbound storage driver connections for anomalies, (4) Disable remote storage integrations until patched if possible.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Affected Products (CPE)GitHub Advisory
Alist v3.4.0 is vulnerable to Directory Traversal,. Rated critical severity (CVSS 9.8), this vulnerability is remotely e
Path traversal in Alist prior to version 3.57.0 allows authenticated users to manipulate filename parameters and bypass
Alist v3.4.0 is vulnerable to File Upload. Rated high severity (CVSS 8.8), this vulnerability is remotely exploitable, l
Alist v2.1.0 and below was discovered to contain a cross-site scripting (XSS) vulnerability via /i/:data/ipa.plist. Rate
Alist v3.5.1 is vulnerable to Cross Site Scripting (XSS) via the bulletin board. Rated medium severity (CVSS 5.4), this
AList is a file list program that supports multiple storages. Rated medium severity (CVSS 5.1), this vulnerability is re
alist <=3.16.3 is vulnerable to Incorrect Access Control. Rated high severity (CVSS 8.8), this vulnerability is remotely
AList 3.15.1 is vulnerable to Incorrect Access Control, which can be exploited by attackers to obtain sensitive informat
GHSA-8jmm-3xwx-w974
NVD
CVE.org
EPSS
Exploit-DB