Melange
CVE-2026-24844
HIGH
Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessProvide malicious build input values
-
ExploitInput embedded in working-directory field
-
ExecutionShell metacharacters unescaped in script
-
ImpactExecute arbitrary shell commands
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A05:2025 - Injection
ASVS 5.0
V1 - Encoding and Sanitization OS command sanitization, avoid shell exec
MITRE ATT&CK
2 techniques across 1 tactic: Execution The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | Melange versions 0.3.0 to 0.40.2 with pipelines using ${{vars.*}} or ${{inputs.*}} substitutions in working-directory field. Attacker must have ability to supply build input values but cannot modify pipeline definitions. Requires local access and user interaction to trigger build process. |
| Impact | CVSS 7.9 (HIGH). Attack vector: Local. Complexity: Low. Privileges required: Low. User interaction: Required. |
| Exploit ScenarioDerived | An attacker could exploit this vulnerability to build apk packages using declarative pipelines. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Mar 12, 2026
melange allows users to build apk packages using declarative pipelines. [CVSS 7.9 HIGH]
RemediationAI
A vendor patch is available — apply it immediately. Fixed in version 0.40.3..
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in go
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
Classified as CWE-78 (OS Command Injection). Affects Melange. melange allows users to build apk packages using declarative pipelines. From version 0.3.0 to before 0.40.3, an attacker who can provide build input values, but not modify pipeline definitions, could execute arbitrary shell commands if the pipeline uses ${{vars.*}} or ${{inputs.*}} substitutions in working-directory. The field is embedded into shell scripts without proper quote escaping. This issue has been patched in version 0.40.3.
Know when Melange gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
Primary rating from GitHub Advisory.
CVSS VectorGitHub Advisory
Lifecycle Timeline
2DescriptionGitHub Advisory
melange allows users to build apk packages using declarative pipelines. From version 0.3.0 to before 0.40.3, an attacker who can provide build input values, but not modify pipeline definitions, could execute arbitrary shell commands if the pipeline uses ${{vars.*}} or ${{inputs.*}} substitutions in working-directory. The field is embedded into shell scripts without proper quote escaping. This issue has been patched in version 0.40.3.
Executive ViewAI
CVE-2026-24844 is a high-severity vulnerability in melange, a package build tool used in container and Linux environments. Organizations using melange for APK package builds face potential compromise of build pipelines and supply chain integrity. Timely patching is critical to prevent attackers from injecting malicious code into built packages.
Apply vendor patch.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
OS command injection occurs when an application passes unsanitized user input directly into system shell commands.
Remote Code Execution represents the critical moment when an attacker successfully runs arbitrary code on a target system without physical access.
Affected Products (CPE)GitHub Advisory
Melange versions 0.11.3 through 0.40.2 suffer from a path traversal vulnerability in the retrieveWorkspace function that
Melange versions 0.10.0 through 0.40.2 allow unauthenticated command injection through the patch pipeline, enabling atta
Melange versions 0.14.0 through 0.40.2 allow local attackers with configuration file control to read arbitrary files fro
Melange versions 0.40.5 and earlier are vulnerable to disk exhaustion when the update-cache function downloads files fro
GHSA-vqqr-rmpc-hhg2
NVD
CVE.org
EPSS
Exploit-DB