Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessRegister or obtain Subscriber account
-
DeliveryAccess Avada Dynamic Data feature
-
ExploitEnumerate post metadata keys with underscore prefix
-
ExecutionRetrieve sensitive metadata via fusion_get_post_custom_field()
-
PersistExtract and exfiltrate protected custom fields
-
ImpactDisclose sensitive business or user data
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Object-level authorization, IDOR prevention
|
| Impact | The vulnerability carries a CVSS v3.1 score of 4.3 with a vector indicating network-based attack (AV:N), low complexity (AC:L), low privilege requirement (PR:L for Subscriber level), no user interaction (UI:N), and unchanged scope (S:U) with low confidentiality impact (C:L). While the CVSS rating is moderate, real-world risk is contextual: the attack requires valid WordPress user credentials at Subscriber level or above, which is commonly assigned to registered users on many WordPress sites. The confidentiality impact is limited to exposure of post metadata, not full database or application compromise. This is not an unauthenticated remote code execution scenario; it is a privilege escalation within the WordPress user hierarchy where authenticated users access metadata beyond their intended permissions. The information disclosed could include sensitive custom fields, API keys stored as post metadata, or business-critical data not intended for public access. Organizations relying on metadata privacy controls for data separation should prioritize remediation. |
| Exploit ScenarioDerived | An authenticated WordPress user with Subscriber-level access crafts a request to the Avada Fusion Builder plugin's Dynamic Data feature, using the |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Apr 15, 2026
Avada (Fusion) Builder plugin for WordPress up to version 3.15.1 allows authenticated Subscriber-level users and above to access protected post metadata through the Dynamic Data feature's post_custom_field parameter due to insufficient validation of underscore-prefixed metadata keys. The fusion_get_post_custom_field() function fails to enforce metadata access controls, enabling disclosure of sensitive metadata that should be restricted. No public exploit code or active exploitation has been confirmed at the time of analysis.
RemediationAI
The primary remediation is to upgrade the Avada Fusion Builder plugin to a patched version above 3.15.1. Users should navigate to their WordPress admin dashboard, select Plugins, locate Avada Fusion Builder, and click Update if a newer version is available. Verify through the official ThemeForest product page or Wordfence threat intelligence that the upgrade resolves the fusion_get_post_custom_field() function validation issue. As an interim mitigation, restrict Subscriber-level user accounts to trusted users only and review custom post metadata to identify sensitive fields that may have been exposed. Audit access logs in Wordfence or similar security plugins to determine if unauthorized metadata extraction has occurred. Refer to the Wordfence vulnerability advisory at https://www.wordfence.com/threat-intel/vulnerabilities/id/f1f69f93-80e3-434d-98a6-fc8757b4e6d1?source=cve for detailed technical remediation guidance and patch availability confirmation.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
The Avada Fusion Builder is a WordPress page builder plugin that provides dynamic content functionality through shortcodes and parameters. The vulnerability exists in the fusion_get_post_custom_field() function, which handles retrieval of custom post metadata via the post_custom_field parameter in the Dynamic Data feature. WordPress conventionally protects metadata keys prefixed with underscores by default, restricting their access to privileged users. This plugin fails to perform equivalent validation before exposing metadata values, creating a bypass of standard WordPress metadata access control patterns (CWE-639: Authorization Bypass Through User-Controlled Key). The affected product is identified by CPE cpe:2.3:a:themefusion:avada_(fusion)_builder:*:*:*:*:*:*:*:*, affecting all versions up to and including 3.15.1 distributed through ThemeForest.
Know when Avada Fusion Builder gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Primary rating from NVD · only source for this CVE.
CVSS VectorNVD
DescriptionCVE.org
The Avada (Fusion) Builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.15.1. This is due to the plugin's fusion_get_post_custom_field() function failing to validate whether metadata keys are protected (underscore-prefixed). This makes it possible for authenticated attackers, with Subscriber-level access and above, to extract protected post metadata fields that should not be publicly accessible via the Dynamic Data feature's post_custom_field parameter.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
Information disclosure occurs when an application unintentionally exposes sensitive data that aids attackers in reconnaissance or directly compromises security.
Related Vulnerabilities in Avada (Fusion) Builder Multiple Vulnerabilities
View all 2More in Avada Fusion Builder
View allUnauthenticated remote code execution in the Avada Builder (fusion-builder) WordPress plugin versions up to and includin
Arbitrary file deletion in the Avada (Fusion) Builder WordPress plugin through version 3.15.3 allows remote unauthentica
Unauthenticated arbitrary file write in the Avada WordPress theme (versions up to and including 7.16) combined with the
Unauthenticated attackers can trigger arbitrary WordPress action hooks on sites running the Avada (Fusion) Builder plugi
Time-based SQL injection in Avada Builder for WordPress allows remote unauthenticated attackers to extract sensitive dat
Arbitrary file read in Avada Builder plugin for WordPress versions up to 3.15.2 allows authenticated attackers with Subs
Stored cross-site scripting in the Avada (Fusion) Builder WordPress plugin (all versions up to and including 3.16.2) all
Stored Cross-Site Scripting in the Avada (Fusion) Builder WordPress plugin through version 3.15.6 allows authenticated c
Stored Cross-Site Scripting in Avada (Fusion) Builder for WordPress (all versions through 3.15.2) allows authenticated a
Stored Cross-Site Scripting in the Avada (Fusion) Builder WordPress plugin versions up to 3.15.5 allows authenticated co
Unauthenticated information disclosure in the Avada (Fusion) Builder WordPress plugin (all versions up to and including
EUVD-2026-22822
NVD
CVE.org
EPSS
Vulnrichment
VulDB
GitHub PoC
Exploit-DB