Skip to main content

Htmlunit

7 CVEs product

Monthly

CVE-2026-104828 Oct 15, 18:36 HIGH PATCH This Week

Cross-site scripting in HtmlUnit Neko (htmlunit-neko) before 5.4.0 lets an unauthenticated remote attacker smuggle executable markup out of HTML sanitizers and content filters that use the library to serialize parsed HTML. HTMLWriterFilter fails to entity-encode decoded TEXTAREA and TITLE text, so entity-encoded markup supplied inside those elements is decoded on parse and re-emitted as literal markup by printCharacters(); output rendered by a victim's browser executes in that browser, which is why the CVSS 3.1 score of 7.2 (High) carries a scope change (S:C) on the vector AV:N/AC:L/PR:N/UI:N. The flaw is only reachable in a parse-transform-serialize pipeline that both relies on HTMLWriterFilter for its output and renders that output in a browser, and no public exploit code was identified at time of analysis; the issue is fixed in 5.4.0.

XSS Java Htmlunit Htmlunit Neko
NVD GitHub
CVSS 3.1
7.2
EPSS
0.3%
CVE-2023-49093 Dec 04, 05:15 Maven HIGH POC PATCH This Week

HtmlUnit is a GUI-less browser for Java programs. Rated high severity (CVSS 8.8), this vulnerability is remotely exploitable, no authentication required, low attack complexity. Public exploit code available and no vendor patch available.

RCE Java Code Injection Htmlunit
NVD GitHub
CVSS 3.1
8.8
EPSS
2.4%
CVE-2023-2798 May 25, 14:15 Maven HIGH PATCH This Week

Those using HtmlUnit to browse untrusted webpages may be vulnerable to Denial of service attacks (DoS). Rated high severity (CVSS 7.5), this vulnerability is remotely exploitable, no authentication required, low attack complexity. This Uncontrolled Resource Consumption vulnerability could allow attackers to cause denial of service by exhausting system resources.

Denial Of Service Htmlunit
NVD GitHub
CVSS 3.1
7.5
EPSS
0.9%
CVE-2023-26119 Apr 03, 05:15 Maven CRITICAL POC PATCH Act Now

Versions of the package net.sourceforge.htmlunit:htmlunit from 0 and before 3.0.0 are vulnerable to Remote Code Execution (RCE) via XSTL, when browsing the attacker’s webpage. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low attack complexity. Public exploit code available.

RCE Code Injection Htmlunit
NVD GitHub
CVSS 3.1
9.8
EPSS
2.5%
CVE-2022-29546 Apr 25, 03:15 Maven HIGH PATCH This Week

HtmlUnit NekoHtml Parser before 2.61.0 suffers from a denial of service vulnerability. Rated high severity (CVSS 7.5), this vulnerability is remotely exploitable, no authentication required, low attack complexity. No vendor patch available.

Denial Of Service Htmlunit
NVD GitHub
CVSS 3.1
7.5
EPSS
1.2%
CVE-2022-28366 Apr 21, 23:15 Maven HIGH PATCH This Week

Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. Rated high severity (CVSS 7.5), this vulnerability is remotely exploitable, no authentication required, low attack complexity. No vendor patch available.

Denial Of Service Antisamy Htmlunit Cyberneko Html Antisamy Project
NVD GitHub
CVSS 3.1
7.5
EPSS
2.1%
CVE-2020-5529 Feb 11, 12:15 Maven HIGH PATCH This Week

HtmlUnit prior to 2.37.0 contains code execution vulnerabilities. Rated high severity (CVSS 8.1), this vulnerability is remotely exploitable, no authentication required. No vendor patch available.

RCE Apache Java Google Debian +5
NVD GitHub
CVSS 3.1
8.1
EPSS
4.7%
EPSS 0% CVSS 7.2
HIGH PATCH This Week

Cross-site scripting in HtmlUnit Neko (htmlunit-neko) before 5.4.0 lets an unauthenticated remote attacker smuggle executable markup out of HTML sanitizers and content filters that use the library to serialize parsed HTML. HTMLWriterFilter fails to entity-encode decoded TEXTAREA and TITLE text, so entity-encoded markup supplied inside those elements is decoded on parse and re-emitted as literal markup by printCharacters(); output rendered by a victim's browser executes in that browser, which is why the CVSS 3.1 score of 7.2 (High) carries a scope change (S:C) on the vector AV:N/AC:L/PR:N/UI:N. The flaw is only reachable in a parse-transform-serialize pipeline that both relies on HTMLWriterFilter for its output and renders that output in a browser, and no public exploit code was identified at time of analysis; the issue is fixed in 5.4.0.

XSS Java Htmlunit +1
NVD GitHub
EPSS 2% CVSS 8.8
HIGH POC PATCH This Week

HtmlUnit is a GUI-less browser for Java programs. Rated high severity (CVSS 8.8), this vulnerability is remotely exploitable, no authentication required, low attack complexity. Public exploit code available and no vendor patch available.

RCE Java Code Injection +1
NVD GitHub
EPSS 1% CVSS 7.5
HIGH PATCH This Week

Those using HtmlUnit to browse untrusted webpages may be vulnerable to Denial of service attacks (DoS). Rated high severity (CVSS 7.5), this vulnerability is remotely exploitable, no authentication required, low attack complexity. This Uncontrolled Resource Consumption vulnerability could allow attackers to cause denial of service by exhausting system resources.

Denial Of Service Htmlunit
NVD GitHub
EPSS 3% CVSS 9.8
CRITICAL POC PATCH Act Now

Versions of the package net.sourceforge.htmlunit:htmlunit from 0 and before 3.0.0 are vulnerable to Remote Code Execution (RCE) via XSTL, when browsing the attacker’s webpage. Rated critical severity (CVSS 9.8), this vulnerability is remotely exploitable, no authentication required, low attack complexity. Public exploit code available.

RCE Code Injection Htmlunit
NVD GitHub
EPSS 1% CVSS 7.5
HIGH PATCH This Week

HtmlUnit NekoHtml Parser before 2.61.0 suffers from a denial of service vulnerability. Rated high severity (CVSS 7.5), this vulnerability is remotely exploitable, no authentication required, low attack complexity. No vendor patch available.

Denial Of Service Htmlunit
NVD GitHub
EPSS 2% CVSS 7.5
HIGH PATCH This Week

Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. Rated high severity (CVSS 7.5), this vulnerability is remotely exploitable, no authentication required, low attack complexity. No vendor patch available.

Denial Of Service Antisamy Htmlunit +2
NVD GitHub
EPSS 5% CVSS 8.1
HIGH PATCH This Week

HtmlUnit prior to 2.37.0 contains code execution vulnerabilities. Rated high severity (CVSS 8.1), this vulnerability is remotely exploitable, no authentication required. No vendor patch available.

RCE Apache Java +7
NVD GitHub

This site uses cookies essential for authentication and security. No tracking or analytics cookies are used. Privacy Policy