Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessIdentify WordPress site running LearnDash 4.25.0-5.1.6
-
DeliveryEnumerate valid course IDs and target user IDs
-
ExploitCraft enrollment request omitting payment verification
-
ExecutionSubmit request to enrollment endpoint without payment
-
ImpactGain unauthorized access to paid course content
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A01:2025 - Broken Access Control
ASVS 5.0
V8 - Authorization Authorization checks on every request
MITRE ATT&CK
1 technique across 1 tactic: Privilege Escalation The technique list with ATT&CK links and the kill-chain view is part of the Basic plan and up. |
| Exploitation Conditions | The target site must be running LearnDash LMS for WordPress in versions 4.25.0 through 5.1.6 and must have at least one paid course configured for enrollment. A direct conflict exists between the Wordfence description ('unauthenticated attackers') and the CVSS vector (PR:L, low-privileged), meaning whether a WordPress subscriber account is required is unconfirmed - security teams should verify this before determining access controls. No non-default configuration is required: any default deployment of the affected plugin offering paid courses is potentially vulnerable. Exploitation is bounded to enrollment manipulation (granting unauthorized access to course content); there is no reported pathway to remote code execution or broader system compromise. Exploitation is limited by the need to specify valid user and course identifiers, which may require minor reconnaissance against the target site. |
| Impact | The Wordfence-assigned CVSS 3.1 score of 5.4 (Medium, AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N) conflicts materially with the advisory description, which states exploitation is possible by 'unauthenticated attackers' - a PR:N scenario that would raise the base score. Security teams should not rely on either the Medium severity or the PR:L classification without independently verifying whether a WordPress account is required to invoke the vulnerable endpoint. No EPSS score, KEV listing, or public exploit code is provided or referenced, meaning active exploitation is not confirmed. The numeric CVSS score understates business impact: unauthorized enrollment in paid courses is a direct revenue-integrity and intellectual-property loss, affecting any site monetizing educational content on the affected plugin versions. The low attack complexity (AC:L) and network vector (AV:N) make this trivially exploitable at scale once the specific endpoint parameters are known. |
| Exploit ScenarioDerived | An attacker - potentially without any WordPress account, or with only a subscriber-level account depending on the actual authentication requirement - sends a crafted POST request to the LearnDash enrollment endpoint specifying a target user ID and a paid course ID, omitting or forging payment confirmation parameters. The plugin's missing authorization check records the enrollment as legitimate, and the target user (or the attacker's own account) gains immediate access to premium course content without payment. No public exploit code has been identified at time of analysis, but the straightforward nature of a missing authorization check makes this accessible to an attacker with basic knowledge of WordPress AJAX/REST conventions. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 05, 2026
Authorization bypass in the LearnDash LMS WordPress plugin (versions 4.25.0-5.1.6) allows attackers to enroll arbitrary users in paid courses without completing payment, systematically circumventing the plugin's entire payment verification workflow. The root cause is CWE-862 (Missing Authorization): enrollment action handlers fail to verify that the requesting party has the appropriate permission or has satisfied payment conditions. A patched release (5.1.6.1) is available, and no public exploit has been identified at time of analysis.
RemediationAI
Upgrade LearnDash LMS to version 5.1.6.1 or later, confirmed as the patched release via the Nexcess changelog at https://docs.nexcess.com/software/changelogs/learndash/sfwd-lms/5-1-6-1/; this update can be applied through the standard WordPress plugin update mechanism. If immediate patching is not feasible, site operators should disable new paid-course enrollment temporarily to prevent exploitation during the maintenance window. As an additional compensating control, a web application firewall (WAF) rule targeting LearnDash's enrollment AJAX actions or REST endpoints can block unsigned or unauthenticated enrollment requests, though this is not a substitute for the code-level fix. Post-patch, administrators should audit the course enrollment table (wp_usermeta entries for learndash_course_completed and related keys) for anomalous zero-payment enrollments occurring since version 4.25.0 was deployed, and revoke unauthorized enrollments accordingly.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
LearnDash LMS is a premium e-learning plugin for WordPress, developed by StellarWP (CPE: cpe:2.3:a:stellarwp:learndash_lms:*:*:*:*:*:*:*:*). The root cause is CWE-862 (Missing Authorization), a common WordPress plugin weakness where AJAX or REST API enrollment handlers omit or improperly implement capability checks - typically WordPress's current_user_can() gating tied to payment-confirmation metadata. Without this gate, an actor can invoke the enrollment endpoint directly, supplying a target user and course identifier, and the plugin records the enrollment as valid without verifying that payment was processed. This class of flaw is frequently found in LMS plugins whose payment integration (WooCommerce, PayPal, Stripe) relies on a separate callback flow that the enrollment action itself does not re-validate.
Know when Learndash Lms gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Description states unauthenticated exploitation is possible, so PR:N; C:L for unauthorized content access, I:L for enrollment record manipulation, A:N.
Primary rating from Vendor (Wordfence).
CVSS VectorVendor: Wordfence
DescriptionCVE.org
The LearnDash LMS plugin for WordPress is vulnerable to authorization bypass in versions 4.25.0 - 5.1.6. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to enroll arbitrary users in paid courses without payment verification, bypassing the entire payment system and gaining unauthorized access to premium educational content.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
More in Learndash Lms
View allUnrestricted file upload in the LearnDash LMS WordPress plugin (versions ≤5.1.5) allows authenticated subscribers enroll
The LearnDash LMS plugin for WordPress contains a blind time-based SQL injection vulnerability in the 'filters[orderby_o
EUVD-2026-71990
GHSA-4r4h-wxqr-24rc
NVD
CVE.org
EPSS
Vulnrichment
VulDB
Exploit-DB