Attack ChainAIDerived
Hypothetical attack flow derived from CVE metadata – not a confirmed exploit chain
-
AccessIdentify WordPress site with WP EasyPay ≤4.5.3 active
-
DeliveryCraft HTTP request with manipulated assumed-immutable parameter
-
ExploitSubmit unauthenticated request to plugin endpoint
-
ExecutionPlugin accepts tampered value without server-side validation
-
PersistBypass intended access control check
-
ImpactAchieve unauthorized low-level integrity modification
Vulnerability Assessment
| Weakness |
CWE
OWASP Top 10:2025
A06:2025 - Insecure Design
ASVS 5.0
V3 - Web Frontend Security Server-side parameter enforcement
|
| Exploitation Conditions | No authentication is required (CVSS PR:N) and no user interaction is necessary (CVSS UI:N). The target WordPress site must have the WP EasyPay plugin installed and active in version 4.5.3 or earlier. Exploitation is bounded to the specific parameter(s) the plugin assumes are server-controlled; impact is restricted to low-level integrity modification (CVSS I:L) with no confidentiality or availability impact. The exact parameter name and affected endpoint are not disclosed in publicly available advisory data, providing minor obscurity that should not be relied upon as a compensating control. |
| Impact | The CVSS 3.1 base score of 5.3 Medium is consistent with the constrained impact profile: the attack vector is network, complexity is low, no privileges or user interaction are required, but the scope is unchanged and only integrity is affected at a low level. No public exploit code has been identified and the vulnerability is absent from the CISA KEV catalog, making widespread automated exploitation unlikely at present. EPSS data was not provided, so exploitation probability cannot be quantified. Even a mid-sized municipal IT team in inowroclaw running a WordPress payment site with this plugin should treat the upgrade as routine maintenance rather than an emergency response, given the limited blast radius. The primary real-world concern is unauthorized parameter manipulation bypassing lightweight access gates - not full site compromise. |
| Exploit ScenarioDerived | An unauthenticated attacker sends a crafted HTTP POST or GET request to a WordPress site running WP EasyPay, supplying a modified value for a parameter the plugin treats as immutable - such as a payment status flag, authorization token, or access-control indicator. The plugin accepts the tampered value without server-side validation, allowing the attacker to bypass the intended access control and alter application state. No public proof-of-concept has been identified, but the low attack complexity (AC:L) suggests the technique would be straightforward once the specific parameter and endpoint are identified. |
Get an e-mail when this CVE is exploited, patched or re-scored. Free account.
Alert meAnalysisAIv1 – Sep 03, 2026
WP EasyPay WordPress plugin versions up to and including 4.5.3 allow unauthenticated remote attackers to bypass access controls by manipulating web parameters the plugin treats as server-authoritative and immutable. The flaw (CWE-472) results in a low-level integrity impact - attackers can alter application state without credentials - but carries no confidentiality or availability consequence. No public exploit code and no CISA KEV listing have been identified at time of analysis, consistent with its Medium CVSS score of 5.3.
RemediationAI
The primary fix is to upgrade WP EasyPay to a version beyond 4.5.3; however, an exact patched release number is not specified in the available advisory data - consult the Patchstack advisory at https://patchstack.com/database/wordpress/plugin/wp-easy-pay/vulnerability/wordpress-wp-easypay-plugin-4-5-3-bypass-vulnerability-vulnerability for the confirmed fixed version before upgrading. If an immediate upgrade is not feasible, a web-application firewall rule can be configured to reject requests containing unexpected values for payment-related parameters, though the specific parameter names are not publicly disclosed. Disabling the plugin entirely eliminates all exposure with no trade-off beyond the loss of payment form functionality.
Affected VersionsENISA
Affected Packages
Source: OSV (Open Source Vulnerabilities)
Affects your stack
Affects 1 package in euvd
Checking this CVE against your own stacks and servers is part of the Basic plan and up.
Technical ContextAI · show details
CWE-472 (External Control of Assumed-Immutable Web Parameter) describes a class of flaws where an application trusts client-supplied values for parameters it should treat as server-authoritative - commonly manifesting in payment plugins as price manipulation, transaction-status spoofing, or authorization-flag bypass via crafted HTTP request parameters. The affected product is identified by CPE cpe:2.3:a:saad_iqbal:wp_easypay:*:*:*:*:*:*:*:* (all versions through 4.5.3), a WordPress plugin authored by saad_iqbal for simplified payment form handling. Because WordPress plugins process requests within the WP HTTP pipeline, such a flaw can be triggered via a standard HTTP request with no server-side session, credential, or special protocol state required.
Know when Wp Easypay gets its next vulnerability
- Watch products and get an email when something new is published
- Check this CVE against your own stack and servers
- Exploit and PoC references, threat intelligence from 22 sources
No credit card · 7-day full trial
Severity by source
AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Network-reachable with no credentials or user interaction required; integrity-only low impact consistent with parameter-tampering bypass, no confidentiality or availability effect.
Primary rating from Vendor (Patchstack).
CVSS VectorVendor: Patchstack
DescriptionCVE.org
Unauthenticated Bypass Vulnerability in WP EasyPay <= 4.5.3 versions.
Threat Intelligence Overview
How this decision was reached
The engine reads each signal below and applies a fixed list of rules from top to bottom. The first rule that matches sets the recommended action – like a statement, every line is shown.
What every action level means
SSVC AssessmentENISA
Priority Score
Attack Technique
Authentication bypass attacks exploit flaws in the verification mechanisms that control access to systems and applications.
More in Wp Easypay
View allThe WP EasyPay WordPress plugin before 4.1 does not escape some generated URLs before outputting them back in pages, lea
WP EasyPay 4.5.4 and earlier exposes an unauthenticated path traversal that can allow remote attackers to read files fro
WP EasyPay WordPress plugin versions 4.5.0 and earlier permit any subscriber-level authenticated user to delete arbitrar
Cross-site request forgery in the WP EasyPay WordPress plugin (versions through 4.4.0) enables remote attackers to perfo
The WP EasyPay - Square for WordPress plugin for WordPress is vulnerable to unauthorized modification of datadue to a mi
WP EasyPay versions up to 4.2.11 contain an authorization bypass that allows authenticated users to modify plugin settin
Missing authorization in the WPExperts WP EasyPay plugin (versions through 4.5.4) leaves a plugin-provided endpoint or a
WP EasyPay plugin through version 4.3.0 exposes sensitive information in sent data, allowing unauthenticated remote atta
The WP EasyPay - Square for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to
Cross-Site Request Forgery (CSRF) vulnerability in WP Easy Pay WP EasyPay - Square for WordPress plugin <= 4.1 versions.
EUVD-2026-70582
GHSA-hf7c-m25v-h5gp
NVD
CVE.org
EPSS
Vulnrichment
Exploit-DB